aboutsummaryrefslogtreecommitdiff
path: root/net/librouteros
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-04-07 14:42:24 +0000
committerChris Rees <crees@FreeBSD.org>2012-04-07 14:42:24 +0000
commitc74a729c771d863f0ee5144203fb7f5124e6ba6f (patch)
treef04157708f1faf4b7a9afb8ff8602d1449112794 /net/librouteros
parent628a6e265bde5d49fd3cdc8d4efd1b889d695744 (diff)
downloadports-c74a729c771d863f0ee5144203fb7f5124e6ba6f.tar.gz
ports-c74a729c771d863f0ee5144203fb7f5124e6ba6f.zip
Notes
Diffstat (limited to 'net/librouteros')
-rw-r--r--net/librouteros/Makefile39
-rw-r--r--net/librouteros/distinfo2
-rw-r--r--net/librouteros/pkg-descr4
-rw-r--r--net/librouteros/pkg-plist7
4 files changed, 52 insertions, 0 deletions
diff --git a/net/librouteros/Makefile b/net/librouteros/Makefile
new file mode 100644
index 000000000000..0f4622810adb
--- /dev/null
+++ b/net/librouteros/Makefile
@@ -0,0 +1,39 @@
+# Ports collection Makefile for: librouteros
+# Date created: April 6 2012
+# Whom: Mark Felder <feld@feld.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= librouteros
+PORTVERSION= 1.1.2
+CATEGORIES= net
+MASTER_SITES= http://verplant.org/librouteros/files/
+
+MAINTAINER= feld@feld.me
+COMMENT= Library for communicating with network devices by MikroTik
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+
+MAN1= ros.1
+MAN3= librouteros.3
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include -Wno-error
+
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/librouteros/distinfo b/net/librouteros/distinfo
new file mode 100644
index 000000000000..41d90270031e
--- /dev/null
+++ b/net/librouteros/distinfo
@@ -0,0 +1,2 @@
+SHA256 (librouteros-1.1.2.tar.bz2) = 1c58ada1ab70e15bb1490b5a24e54e3baf909554173445f71921558e2c111376
+SIZE (librouteros-1.1.2.tar.bz2) = 234942
diff --git a/net/librouteros/pkg-descr b/net/librouteros/pkg-descr
new file mode 100644
index 000000000000..60f5b2786cac
--- /dev/null
+++ b/net/librouteros/pkg-descr
@@ -0,0 +1,4 @@
+librouteros (or libRouterOS) is a C library to communicate with network
+devices by MikroTik running their Linux-based operating system RouterOS.
+
+WWW: http://verplant.org/librouteros/
diff --git a/net/librouteros/pkg-plist b/net/librouteros/pkg-plist
new file mode 100644
index 000000000000..72de67b3d189
--- /dev/null
+++ b/net/librouteros/pkg-plist
@@ -0,0 +1,7 @@
+bin/ros
+include/routeros_version.h
+include/routeros_api.h
+lib/librouteros.so.2
+lib/librouteros.so
+lib/librouteros.la
+lib/librouteros.a