aboutsummaryrefslogtreecommitdiff
path: root/net/librsync/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-13 10:42:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-13 10:42:29 +0000
commit7a2c19d018fe03c917eaf82d83c4a122c5603467 (patch)
tree6e1f872f8221d344964a573fea0e50870a161f9b /net/librsync/Makefile
parente8b893c91b7f0365366d583cdace62ba8888854c (diff)
downloadports-7a2c19d018fe03c917eaf82d83c4a122c5603467.tar.gz
ports-7a2c19d018fe03c917eaf82d83c4a122c5603467.zip
Notes
Diffstat (limited to 'net/librsync/Makefile')
-rw-r--r--net/librsync/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
new file mode 100644
index 000000000000..1786907d84be
--- /dev/null
+++ b/net/librsync/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: librsync
+# Date created: Mar 13, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= librsync
+PORTVERSION= 0.9.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rproxy
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ bz2.1:${PORTSDIR}/archivers/bzip2
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+
+USE_GMAKE= yes
+
+MAN1= rdiff.1
+MAN3= librsync.3
+
+.include <bsd.port.mk>