aboutsummaryrefslogtreecommitdiff
path: root/net/libsocket++
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2002-11-29 11:12:42 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2002-11-29 11:12:42 +0000
commit2d773ffe61c9b8efaf187261142e580fab597d61 (patch)
tree9130360eb6789c70947fd15d80bd5cb02df82748 /net/libsocket++
parentd70d7a7d5ca7003185b13f4caa49c2e2e200f19b (diff)
downloadports-2d773ffe61c9b8efaf187261142e580fab597d61.tar.gz
ports-2d773ffe61c9b8efaf187261142e580fab597d61.zip
Notes
Diffstat (limited to 'net/libsocket++')
-rw-r--r--net/libsocket++/Makefile19
-rw-r--r--net/libsocket++/distinfo2
-rw-r--r--net/libsocket++/files/patch-aa14
-rw-r--r--net/libsocket++/files/patch-ab12
-rw-r--r--net/libsocket++/files/patch-ac13
-rw-r--r--net/libsocket++/files/patch-ad50
-rw-r--r--net/libsocket++/files/patch-ae34
-rw-r--r--net/libsocket++/pkg-plist28
8 files changed, 27 insertions, 145 deletions
diff --git a/net/libsocket++/Makefile b/net/libsocket++/Makefile
index 0375a7a8263f..f7f39fc71d88 100644
--- a/net/libsocket++/Makefile
+++ b/net/libsocket++/Makefile
@@ -7,28 +7,31 @@
#
PORTNAME= libsocket++
-PORTVERSION= 1.10
+PORTVERSION= 1.12.7
CATEGORIES= net
-MASTER_SITES= ftp://ftp.umsicht.fhg.de/pub/unix/language/C++/class-libraries/ \
+MASTER_SITES= http://members.aon.at/~hstraub/linux/socket++/ \
+ ftp://ftp.umsicht.fhg.de/pub/unix/language/C++/class-libraries/ \
ftp://ftp.par.univie.ac.at/pub/unix/c++/ \
ftp://jungfrau.ptf.hro.nl/pub/socket/
-DISTNAME= socket++-1.10
+DISTNAME= socket++-${PORTVERSION}
MAINTAINER= narvi@haldjas.folklore.ee
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-NOPROFILE= true
+USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 15
+USE_LIBTOOL= yes
-post-configure:
- @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+post-patch:
+ cd ${WRKSRC}; ./autogen
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/libsocket++
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/libsocket++
- ${INSTALL_MAN} ${WRKSRC}/socket++.ps ${PREFIX}/share/doc/libsocket++
.endif
- @install-info ${PREFIX}/info/socket++.info ${PREFIX}/info/dir
.include <bsd.port.mk>
diff --git a/net/libsocket++/distinfo b/net/libsocket++/distinfo
index 26f2d6e9e429..6d4d5b6473f8 100644
--- a/net/libsocket++/distinfo
+++ b/net/libsocket++/distinfo
@@ -1 +1 @@
-MD5 (socket++-1.10.tar.gz) = ce338e33e76edc4b26cb40284947b3a0
+MD5 (socket++-1.12.7.tar.gz) = 3e0c78862185044d9db43bac537a3aea
diff --git a/net/libsocket++/files/patch-aa b/net/libsocket++/files/patch-aa
deleted file mode 100644
index 9dcf87b28b2c..000000000000
--- a/net/libsocket++/files/patch-aa
+++ /dev/null
@@ -1,14 +0,0 @@
-*** local.h Tue Oct 8 14:58:35 1996
---- local.h Tue Oct 8 15:00:07 1996
-***************
-*** 75,81 ****
---- 75,83 ----
-
- #if !defined (__linux__)
- extern "C" int gethostname (char* hostname, int len);
-+ #if !(defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__))
- extern char* SYS_SIGLIST [];
-+ #endif
- #endif
-
- #ifdef __osf__
diff --git a/net/libsocket++/files/patch-ab b/net/libsocket++/files/patch-ab
deleted file mode 100644
index 9bb01973dca7..000000000000
--- a/net/libsocket++/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- sockstream.h.orig Tue Oct 17 17:07:29 1995
-+++ sockstream.h Wed Feb 5 14:04:17 1997
-@@ -119,7 +119,9 @@
- msg_peek = MSG_PEEK,
- msg_dontroute = MSG_DONTROUTE,
-
-+#if !(defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__))
- msg_maxiovlen = MSG_MAXIOVLEN
-+#endif
- };
- enum shuthow {
- shut_read,
diff --git a/net/libsocket++/files/patch-ac b/net/libsocket++/files/patch-ac
deleted file mode 100644
index bfcb78439dbd..000000000000
--- a/net/libsocket++/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- socket++.texi.orig Wed Oct 18 09:07:35 1995
-+++ socket++.texi Sat Nov 21 22:31:28 1998
-@@ -10,6 +10,10 @@
- @end iftex
-
- @ifinfo
-+@dircategory Programming & development tools
-+@direntry
-+* socket++: (socket++.info). C++ family of socket classes.
-+@end direntry
- This info file describes the C++ family of socket classes.
-
- Copyright (C) 1992,1993,1994 Gnanasekaran Swaminathan <gs4t@@virginia.edu>
diff --git a/net/libsocket++/files/patch-ad b/net/libsocket++/files/patch-ad
deleted file mode 100644
index 30934cc4eb2c..000000000000
--- a/net/libsocket++/files/patch-ad
+++ /dev/null
@@ -1,50 +0,0 @@
---- sockstream.C.old Sat Jan 29 16:47:41 2000
-+++ sockstream.C Sun Jan 30 11:28:18 2000
-@@ -43,6 +43,7 @@
-
- #include <config.h>
- #include <sockstream.h>
-+#include <osreldate.h>
-
- EXTERN_C_BEGIN
- #include <sys/time.h>
-@@ -275,8 +276,13 @@
- {
- int len = sa.size ();
- int soc = -1;
-+#if (__FreeBSD_version < 400013)
- while ((soc = ::accept (rep->sock, sa.addr (), &len)) == -1
- && errno == EINTR)
-+#else
-+ while ((soc = ::accept (rep->sock, sa.addr (), (socklen_t *) &len)) == -1
-+ && errno == EINTR)
-+#endif
- errno = 0;
- if (soc == -1)
- error ("sockbuf::accept");
-@@ -321,8 +327,13 @@
- int rval;
- int sa_len = sa.size ();
-
-+#if (__FreeBSD_version < 400013)
- if ((rval = ::recvfrom (rep->sock, (char*) buf, len,
- msgf, sa.addr (), &sa_len)) == -1)
-+#else
-+ if ((rval = ::recvfrom (rep->sock, (char*) buf, len,
-+ msgf, sa.addr (), (socklen_t *) &sa_len)) == -1)
-+#endif
- error ("sockbuf::recvfrom");
- return (rval==0) ? EOF: rval;
- }
-@@ -491,7 +502,11 @@
- int sockbuf::getopt (option op, void* buf, int len, level l) const
- {
- int rlen = len;
-+#if (__FreeBSD_version < 400013)
- if (::getsockopt (rep->sock, l, op, (char*) buf, &rlen) == -1)
-+#else
-+ if (::getsockopt (rep->sock, l, op, (char*) buf, (socklen_t *) &rlen) == -1)
-+#endif
- perror ("sockbuf::getopt");
- return rlen;
- }
diff --git a/net/libsocket++/files/patch-ae b/net/libsocket++/files/patch-ae
deleted file mode 100644
index 2b809b0dad2f..000000000000
--- a/net/libsocket++/files/patch-ae
+++ /dev/null
@@ -1,34 +0,0 @@
---- sockinet.C.old Sat Jan 29 16:57:13 2000
-+++ sockinet.C Sun Jan 30 11:30:02 2000
-@@ -10,6 +10,7 @@
-
- #include <config.h>
- #include <sockinet.h>
-+#include <osreldate.h>
-
- EXTERN_C_BEGIN
- #include <netdb.h>
-@@ -144,7 +145,11 @@
- {
- sockinetaddr sin;
- int len = sin.size();
-+#if (__FreeBSD_version < 400013)
- if (::getsockname(rep->sock, sin.addr (), &len) == -1)
-+#else
-+ if (::getsockname(rep->sock, sin.addr (), (socklen_t *) &len) == -1)
-+#endif
- perror("sockinetbuf::localaddr()");
- return sin;
- }
-@@ -168,7 +173,11 @@
- {
- sockinetaddr sin;
- int len = sin.size();
-+#if (__FreeBSD_version < 400013)
- if (::getpeername(rep->sock, sin.addr (), &len) == -1)
-+#else
-+ if (::getpeername(rep->sock, sin.addr (), (socklen_t *) &len) == -1)
-+#endif
- perror("sockinetbuf::peeraddr()");
- return sin;
- }
diff --git a/net/libsocket++/pkg-plist b/net/libsocket++/pkg-plist
index 3df125d44060..ed534ed687e8 100644
--- a/net/libsocket++/pkg-plist
+++ b/net/libsocket++/pkg-plist
@@ -1,19 +1,21 @@
lib/libsocket++.a
-lib/libsocket++_p.a
-lib/libsocket++.so.1.10
+lib/libsocket++.so.0
lib/libsocket++.so
-include/Fork.h
-include/echo.h
-include/ftp.h
-include/pipestream.h
-include/protocol.h
-include/smtp.h
-include/sockinet.h
-include/sockstream.h
-include/sockunix.h
+include/socket++/fork.h
+include/socket++/echo.h
+include/socket++/ftp.h
+include/socket++/pipestream.h
+include/socket++/protocol.h
+include/socket++/sig.h
+include/socket++/smtp.h
+include/socket++/sockinet.h
+include/socket++/sockstream.h
+include/socket++/sockunix.h
@unexec install-info --delete %D/info/socket++.info %D/info/dir
info/socket++.info
+info/socket++.info-1
+info/socket++.info-2
@exec install-info %D/info/socket++.info %D/info/dir
-share/doc/libsocket++/README
-share/doc/libsocket++/socket++.ps
+%%PORTDOCS%%share/doc/libsocket++/README
@dirrm share/doc/libsocket++
+@dirrm include/socket++