aboutsummaryrefslogtreecommitdiff
path: root/net/libsrtp
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-01-10 16:48:30 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-01-10 16:48:30 +0000
commitdf7680b625548cde767d2930fe28d2a41a918c25 (patch)
tree734351b416634821929b0cdbdf67b8c65486127f /net/libsrtp
parentbcd2a6a36393d483752e7aa719050aa82075c48d (diff)
downloadports-df7680b625548cde767d2930fe28d2a41a918c25.tar.gz
ports-df7680b625548cde767d2930fe28d2a41a918c25.zip
Notes
Diffstat (limited to 'net/libsrtp')
-rw-r--r--net/libsrtp/Makefile1
-rw-r--r--net/libsrtp/files/patch-crypto-include-sha1.h23
2 files changed, 24 insertions, 0 deletions
diff --git a/net/libsrtp/Makefile b/net/libsrtp/Makefile
index f742f98a3ecd..d6e4391db4fa 100644
--- a/net/libsrtp/Makefile
+++ b/net/libsrtp/Makefile
@@ -4,6 +4,7 @@
PORTNAME= libsrtp
DISTVERSIONPREFIX= v
DISTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= GHR
diff --git a/net/libsrtp/files/patch-crypto-include-sha1.h b/net/libsrtp/files/patch-crypto-include-sha1.h
new file mode 100644
index 000000000000..a2857a7f68c3
--- /dev/null
+++ b/net/libsrtp/files/patch-crypto-include-sha1.h
@@ -0,0 +1,23 @@
+--- crypto/include/sha1.h.orig 2014-10-13 14:35:33 UTC
++++ crypto/include/sha1.h
+@@ -68,17 +68,20 @@ typedef EVP_MD_CTX sha1_ctx_t;
+ *
+ */
+
++static
+ void inline sha1_init (sha1_ctx_t *ctx)
+ {
+ EVP_MD_CTX_init(ctx);
+ EVP_DigestInit(ctx, EVP_sha1());
+ }
+
++static
+ void inline sha1_update (sha1_ctx_t *ctx, const uint8_t *M, int octets_in_msg)
+ {
+ EVP_DigestUpdate(ctx, M, octets_in_msg);
+ }
+
++static
+ void inline sha1_final (sha1_ctx_t *ctx, uint32_t *output)
+ {
+ unsigned int len = 0;