aboutsummaryrefslogtreecommitdiff
path: root/net/libtnl/files
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 00:23:57 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 00:23:57 +0000
commit300b5df8c3647880b32a7c039fffa602e9384751 (patch)
tree9191886b034d7fc1528c762b71c82079ece3b61e /net/libtnl/files
parent1afed7cc8da801ffb0bc77b2d47cf4d42cd312b6 (diff)
Notes
Diffstat (limited to 'net/libtnl/files')
-rw-r--r--net/libtnl/files/Makefile.bsd67
1 files changed, 67 insertions, 0 deletions
diff --git a/net/libtnl/files/Makefile.bsd b/net/libtnl/files/Makefile.bsd
new file mode 100644
index 000000000000..7c048d07a416
--- /dev/null
+++ b/net/libtnl/files/Makefile.bsd
@@ -0,0 +1,67 @@
+LIB= tnl
+CXXFLAGS+= -I../libtomcrypt -w -g -fpermissive -DNO_IPX_SUPPORT -DTNL_OS_LINUX -DTNL_DEBUG -D_TNL_ENABLE_LOGGING
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 5
+SRCS= assert.cpp\
+ asymmetricKey.cpp\
+ bitStream.cpp\
+ byteBuffer.cpp\
+ certificate.cpp\
+ clientPuzzle.cpp\
+ connectionStringTable.cpp\
+ dataChunker.cpp\
+ eventConnection.cpp\
+ ghostConnection.cpp\
+ huffmanStringProcessor.cpp\
+ log.cpp\
+ netBase.cpp\
+ netConnection.cpp\
+ netInterface.cpp\
+ netObject.cpp\
+ netStringTable.cpp\
+ platform.cpp\
+ random.cpp\
+ rpc.cpp\
+ symmetricCipher.cpp\
+ tnlMethodDispatch.cpp\
+ journal.cpp\
+ udp.cpp\
+ vector.cpp
+INCS= tnl.h \
+ tnlNetBase.h \
+ tnlAssert.h \
+ tnlNetConnection.h \
+ tnlAsymmetricKey.h \
+ tnlNetEvent.h \
+ tnlBitSet.h \
+ tnlNetInterface.h \
+ tnlBitStream.h \
+ tnlNetObject.h \
+ tnlByteBuffer.h \
+ tnlNetStringTable.h \
+ tnlCertificate.h \
+ tnlNonce.h \
+ tnlClientPuzzle.h \
+ tnlPlatform.h \
+ tnlConnectionStringTable.h \
+ tnlRPC.h \
+ tnlDataChunker.h \
+ tnlRandom.h \
+ tnlEndian.h \
+ tnlString.h \
+ tnlEventConnection.h \
+ tnlSymmetricCipher.h \
+ tnlGhostConnection.h \
+ tnlThread.h \
+ tnlHuffmanStringProcessor.h \
+ tnlTypes.h \
+ tnlJournal.h \
+ tnlUDP.h \
+ tnlLog.h \
+ tnlVector.h \
+ tnlMethodDispatch.h
+INCLUDEDIR= ${PREFIX}/include/tnl
+LIBDIR= ${PREFIX}/lib
+
+.include <bsd.lib.mk>
+