aboutsummaryrefslogtreecommitdiff
path: root/net/libtorrent
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-05-16 20:44:45 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-05-16 20:44:45 +0000
commit283f747d176271b61c22d575928967e464f29fbd (patch)
tree1c1946688ed026540da080c70b630210bb1c125c /net/libtorrent
parent1461dc8ee51697f6bbc6c26cfdfad8254127875f (diff)
downloadports-283f747d176271b61c22d575928967e464f29fbd.tar.gz
ports-283f747d176271b61c22d575928967e464f29fbd.zip
Notes
Diffstat (limited to 'net/libtorrent')
-rw-r--r--net/libtorrent/Makefile3
-rw-r--r--net/libtorrent/distinfo4
-rw-r--r--net/libtorrent/files/patch-ltmain.sh4
-rw-r--r--net/libtorrent/files/patch-src_net_socket__fd.cc14
4 files changed, 12 insertions, 13 deletions
diff --git a/net/libtorrent/Makefile b/net/libtorrent/Makefile
index 62e6c3c66631..897a7214d0e6 100644
--- a/net/libtorrent/Makefile
+++ b/net/libtorrent/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.2
CATEGORIES= net
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
@@ -20,6 +20,7 @@ USE_GNOME= pkgconfig gnomehack
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
+CONFIGURE_ARGS= --disable-debug
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
post-patch:
diff --git a/net/libtorrent/distinfo b/net/libtorrent/distinfo
index 1f47842965f4..68d5b6c051c5 100644
--- a/net/libtorrent/distinfo
+++ b/net/libtorrent/distinfo
@@ -1,2 +1,2 @@
-MD5 (libtorrent-0.6.0.tar.gz) = 0593d611f1079c42c1d431057c74865c
-SIZE (libtorrent-0.6.0.tar.gz) = 304858
+MD5 (libtorrent-0.6.2.tar.gz) = 190dde2da4620f040ab1b58165da1892
+SIZE (libtorrent-0.6.2.tar.gz) = 309756
diff --git a/net/libtorrent/files/patch-ltmain.sh b/net/libtorrent/files/patch-ltmain.sh
index 49b342d2555c..718b8c0aa1fa 100644
--- a/net/libtorrent/files/patch-ltmain.sh
+++ b/net/libtorrent/files/patch-ltmain.sh
@@ -1,5 +1,5 @@
---- ltmain.sh.orig Wed Jan 19 14:56:06 2005
-+++ ltmain.sh Wed Jan 19 15:34:55 2005
+--- ltmain.sh.orig
++++ ltmain.sh
@@ -976,6 +976,7 @@
;;
diff --git a/net/libtorrent/files/patch-src_net_socket__fd.cc b/net/libtorrent/files/patch-src_net_socket__fd.cc
index 16544e0bb5eb..0518a9ced9fc 100644
--- a/net/libtorrent/files/patch-src_net_socket__fd.cc
+++ b/net/libtorrent/files/patch-src_net_socket__fd.cc
@@ -1,14 +1,12 @@
---- src/net/socket_fd.cc.orig Mon Apr 18 00:55:09 2005
-+++ src/net/socket_fd.cc Mon Apr 18 17:27:38 2005
-@@ -24,9 +24,11 @@
-
- #include <errno.h>
- #include <fcntl.h>
-+#include <sys/types.h>
+--- src/net/socket_fd.cc.orig
++++ src/net/socket_fd.cc
+@@ -28,6 +28,9 @@
#include <sys/socket.h>
#include <arpa/inet.h>
#include <netinet/in.h>
-+#include <netinet/in_systm.h>
++#ifdef __FreeBSD__
++# include <netinet/in_systm.h>
++#endif
#include <netinet/ip.h>
#include "torrent/exceptions.h"