aboutsummaryrefslogtreecommitdiff
path: root/net/libtorrent
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-18 11:14:42 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-18 11:14:42 +0000
commit02ec2b0ae33d9ca2e2d17d6baf348e330869081a (patch)
treee4168d859b06306aee5f657334a2403b3535fc67 /net/libtorrent
parent52fa68bbe9eaeb60c2cfc878ea604e16165bfb68 (diff)
downloadports-02ec2b0ae33d9ca2e2d17d6baf348e330869081a.tar.gz
ports-02ec2b0ae33d9ca2e2d17d6baf348e330869081a.zip
Notes
Diffstat (limited to 'net/libtorrent')
-rw-r--r--net/libtorrent/Makefile12
-rw-r--r--net/libtorrent/distinfo4
-rw-r--r--net/libtorrent/files/patch-src_net_socket__fd.cc14
3 files changed, 20 insertions, 10 deletions
diff --git a/net/libtorrent/Makefile b/net/libtorrent/Makefile
index ed55d2b3eaf7..62e6c3c66631 100644
--- a/net/libtorrent/Makefile
+++ b/net/libtorrent/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.5.4
+PORTVERSION= 0.6.0
CATEGORIES= net
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
@@ -16,18 +16,14 @@ COMMENT= BitTorrent Library written in C++
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
USE_GCC= 3.4
+USE_GNOME= pkgconfig gnomehack
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
post-patch:
- @${REINPLACE_CMD} -e "s#\(pkgconfigdir =\).*#\1 ${PREFIX}/libdata/pkgconfig#" \
- ${WRKSRC}/Makefile.in
-# uphold CXXFLAGS
- @${REINPLACE_CMD} -E \
- -e 's#^(CXXFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CXXFLAGS}#' \
- -e 's#^(CFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CFLAGS}#' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/malloc\.h/d' ${WRKSRC}/src/utils/sha_fast.cc
.include <bsd.port.mk>
diff --git a/net/libtorrent/distinfo b/net/libtorrent/distinfo
index f41948a9d16a..1f47842965f4 100644
--- a/net/libtorrent/distinfo
+++ b/net/libtorrent/distinfo
@@ -1,2 +1,2 @@
-MD5 (libtorrent-0.5.4.tar.gz) = 77d1c39f2c17bddc572ae426b53e8367
-SIZE (libtorrent-0.5.4.tar.gz) = 294733
+MD5 (libtorrent-0.6.0.tar.gz) = 0593d611f1079c42c1d431057c74865c
+SIZE (libtorrent-0.6.0.tar.gz) = 304858
diff --git a/net/libtorrent/files/patch-src_net_socket__fd.cc b/net/libtorrent/files/patch-src_net_socket__fd.cc
new file mode 100644
index 000000000000..16544e0bb5eb
--- /dev/null
+++ b/net/libtorrent/files/patch-src_net_socket__fd.cc
@@ -0,0 +1,14 @@
+--- src/net/socket_fd.cc.orig Mon Apr 18 00:55:09 2005
++++ src/net/socket_fd.cc Mon Apr 18 17:27:38 2005
+@@ -24,9 +24,11 @@
+
+ #include <errno.h>
+ #include <fcntl.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <netinet/in_systm.h>
+ #include <netinet/ip.h>
+
+ #include "torrent/exceptions.h"