aboutsummaryrefslogtreecommitdiff
path: root/net/libvncserver/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-09 02:55:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-09 02:55:41 +0000
commitd6b6ebe9e215476bd15d7214f31610b42318e326 (patch)
treeaa6b0af028859f08b9e54ea65b5de57992e1a095 /net/libvncserver/Makefile
parent3ffd4af20743f2285856e88da79d8b1105bbf5e2 (diff)
add libvncserver 0.6
Provide an easy API to write one's own vnc server
Notes
Notes: svn path=/head/; revision=100456
Diffstat (limited to 'net/libvncserver/Makefile')
-rw-r--r--net/libvncserver/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
new file mode 100644
index 000000000000..008a857fb42e
--- /dev/null
+++ b/net/libvncserver/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: libvncserver
+# Date created: Feb 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvncserver
+PORTVERSION= 0.6
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= LibVNCServer-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Provide an easy API to write one's own vnc server
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_REINPLACE= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" ${WRKSRC}/configure
+
+.include <bsd.port.mk>