aboutsummaryrefslogtreecommitdiff
path: root/net/licq-qt-gui/Makefile
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2001-04-10 20:09:53 +0000
committerBrian Feldman <green@FreeBSD.org>2001-04-10 20:09:53 +0000
commit11d86ccd31a76d611a3c66d2ebf87ee38e4e33bf (patch)
tree3e97cdc030d89288de02d03ad7bd120da81fb02c /net/licq-qt-gui/Makefile
parent1b592585f2098f44e1525e779f76bef8d268e6a5 (diff)
Convert the monolithic Licq port into an licq-base port and satellite
ports for different plugins. Commit the first of the plugins, qt-gui, as that has in the past been part of the normal licq port. The rest are coming after I've tried them out. I'd like to thank Jeremy Norris greatly for doing this work :) Submitted by: Jeremy Norris <ishmael27@home.com>
Notes
Notes: svn path=/head/; revision=41226
Diffstat (limited to 'net/licq-qt-gui/Makefile')
-rw-r--r--net/licq-qt-gui/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net/licq-qt-gui/Makefile b/net/licq-qt-gui/Makefile
new file mode 100644
index 000000000000..2ab3e4231ff8
--- /dev/null
+++ b/net/licq-qt-gui/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: qt-gui-licq
+# Date created: 18 October 2000
+# Whom: Jeremy Norris <ishmael272home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt-gui
+PORTVERSION= ${QT_LICQ_VER}
+CATEGORIES= net
+
+MAINTAINER= green@FreeBSD.org
+
+USE_AUTOMAKE= yes
+USE_QT_VER= 2
+
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
+ LIBS="${PTHREAD_LIBS}"
+
+post-patch:
+ @${PERL5} -pi -e 's|0777|0755|g;' \
+ -e 's|-lqt|-lqt2-mt|g' ${WRKSRC}/share/Makefile.am
+ @${PERL5} -pi -e 's|libqt.so.2|libqt2-mt.so.4|g;' \
+ -e 's|libqt.so|libqt2-mt.so|g;' ${WRKSRC}/acinclude.m4
+
+pre-configure:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/aclocal)
+
+post-configure:
+ @(cd ${WRKSRC} && ${PERL5} am_edit)
+ @${PERL5} -pi -e 's|^archive_cmds=.*nostdlib.*|| ; \
+ s|^build_libtool_need_lc=.*|build_libtool_need_lc=no| ; \
+ s|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/net/licq/Makefile.inc"
+.include <bsd.port.post.mk>