aboutsummaryrefslogtreecommitdiff
path: root/net/liferea/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-02-02 12:16:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-02-02 12:16:42 +0000
commitdb3777d96de6935e841e9746c104cc1c7de55f46 (patch)
tree5ec0ee16d9edf09e0914418d0f142e348da8aa18 /net/liferea/Makefile
parent6f2bb26c309296263a991427cd550297663dabe0 (diff)
downloadports-db3777d96de6935e841e9746c104cc1c7de55f46.tar.gz
ports-db3777d96de6935e841e9746c104cc1c7de55f46.zip
Notes
Diffstat (limited to 'net/liferea/Makefile')
-rw-r--r--net/liferea/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index fa7b958bc421..b2f7b240017d 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liferea
-PORTVERSION= 1.4.23
+PORTVERSION= 1.4.24
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -31,9 +31,9 @@ OPTIONS= LIBNOTIFY "Enable libnotify support" on \
DBUS "Enable dbus support" on \
GNUTLS "Enable SSL/HTTPS support" on \
GTKHTML "Use GtkHtml for rendering" on \
- WEBKIT "Use Webkit for rendering" off \
- MOZILLA "Use Firefox for rendering" off \
- XULRUNNER "Use Xulrunner for rendering" off
+ WEBKIT "Use Webkit for rendering" off
+# MOZILLA "Use Firefox for rendering" off \
+# XULRUNNER "Use Xulrunner for rendering" off
.include <bsd.port.pre.mk>
@@ -70,23 +70,29 @@ PLIST_SUB+= WEBKIT="@comment "
.endif
.ifdef WITH_MOZILLA
+USE_GNOME+= gconf2 libxslt
USE_GECKO= firefox mozilla
-CONFIGURE_ARGS+=--enable-gecko=${GECKO}
+CONFIGURE_ARGS+=--with-gecko=${GECKO}
PLIST_SUB+= MOZ=""
+BROKEN= does not compile
.else
-CONFIGURE_ARGS+=--disable-gecko
PLIST_SUB+= MOZ="@comment "
.endif
.ifdef WITH_XULRUNNER
+CONFIGURE_ARGS+=--with-gecko=xulrunner
BUILD_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
RUN_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
PLIST_SUB+= XUL=""
+BROKEN= does not configure
.else
-CONFIGURE_ARGS+=--disable-xulrunner
PLIST_SUB+= XUL="@comment "
.endif
+.if !defined(WITH_MOZILLA) && !defined(WITH_XULRUNNER)
+CONFIGURE_ARGS+=--disable-gecko
+.endif
+
.ifdef WITHOUT_DBUS
CONFIGURE_ARGS+=--disable-dbus
.else