aboutsummaryrefslogtreecommitdiff
path: root/net/liferea
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2005-05-25 00:43:06 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2005-05-25 00:43:06 +0000
commit244325e90ea815defb6699120b830d4fcd5aa992 (patch)
treed518408378174bcf15f38db4ee5d04d796a96f5d /net/liferea
parent91fe7ff637b3c5301e93a70cce62078d71f8ef1d (diff)
downloadports-244325e90ea815defb6699120b830d4fcd5aa992.tar.gz
ports-244325e90ea815defb6699120b830d4fcd5aa992.zip
Notes
Diffstat (limited to 'net/liferea')
-rw-r--r--net/liferea/Makefile18
-rw-r--r--net/liferea/files/patch-src::liferea44
-rw-r--r--net/liferea/files/patch-src::net::netio.c9
-rw-r--r--net/liferea/files/patch-src::ui_feedlist.c11
4 files changed, 71 insertions, 11 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 0170ace7d727..60ebd697e477 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liferea
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -21,11 +22,14 @@ USE_REINPLACE= yes
USE_LIBTOOL_VER=15
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+=${MOZILLA_ARG} --disable-dbus
MAN1= liferea.1
GCONF_SCHEMAS= liferea.schemas
+OPTIONS= DBUS "Enable dbus support" on
+
+.include <bsd.port.pre.mk>
+
.ifdef WITH_MOZILLA
.if ${WITH_MOZILLA}=="mozilla" || ${WITH_MOZILLA}=="yes"
MOZILLA= mozilla
@@ -33,6 +37,7 @@ MOZ_BUILD= mozilla
.elif ${WITH_MOZILLA}=="mozilla-devel"
MOZILLA= mozilla-devel
MOZ_BUILD= mozilla
+MOZ_SUFFIX= -devel
.elif ${WITH_MOZILLA}=="firefox"
MOZILLA= firefox
MOZ_BUILD= firefox
@@ -49,11 +54,20 @@ PLIST_SUB= MOZ=""
PLIST_SUB= MOZ="@comment "
.endif
+.ifdef WITHOUT_DBUS
+CONFIGURE_ARGS+=--disable-dbus
+.else
+LIB_DEPENDS+= dbus-1.1:${PORTSDIR}/devel/dbus
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's,/usr/lib/mozilla,${X11BASE}/lib/${MOZ_BUILD},g' \
${WRKSRC}/src/liferea
${REINPLACE_CMD} -e 's,firefox-,$$gecko_provider-,g' \
-e 's,\(gecko_provider=\).*$$,\1${MOZ_BUILD},' \
+ -e 's,-gtkmozembed,-gtkmozembed${MOZ_SUFFIX},' \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,%FREEBSD_MOZILLA_HOME%,${X11BASE}/lib/${MOZILLA},' \
+ ${WRKSRC}/src/liferea
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/liferea/files/patch-src::liferea b/net/liferea/files/patch-src::liferea
new file mode 100644
index 000000000000..b5fb3cb456bd
--- /dev/null
+++ b/net/liferea/files/patch-src::liferea
@@ -0,0 +1,44 @@
+--- src/liferea.orig Sun May 22 14:00:07 2005
++++ src/liferea Sun May 22 14:00:58 2005
+@@ -18,21 +18,24 @@
+
+ MOZILLA_FIVE_HOME=$MOZILLA_HOME
+ export MOZILLA_FIVE_HOME
++ echo Using mozilla from $MOZILLA_FIVE_HOME
+ exec "$dist_bin/liferea-bin" $params
+ fi
+ }
+
+ look_for_mozilla() {
+-
+- results=`ls -1d $1 2>/dev/null | sort -n`
+- while [ -n "$results" ]
+- do
+- path=`echo "$results" | tail -n 1`
+- results=`echo "$results" | grep -v $path`
+- path=`dirname $path` # strip comm.jar
+- path=`dirname $path` # strip chrome
+- run_with_mozilla $path
++
++ for p in $1; do
++ results=`ls -1d $p 2>/dev/null | sort -n`
++ while [ -n "$results" ]
++ do
++ path=`echo "$results" | tail -n 1`
++ results=`echo "$results" | grep -v $path`
++ path=`dirname $path` # strip comm.jar
++ path=`dirname $path` # strip chrome
++ run_with_mozilla $path
+
++ done
+ done
+ }
+
+@@ -40,6 +43,7 @@
+ run_with_mozilla $MOZILLA_FIVE_HOME
+ fi
+
++look_for_mozilla "%FREEBSD_MOZILLA_HOME%/chrome/comm.jar"
+ look_for_mozilla "/usr/lib/mozilla*/chrome/comm.jar"
+ look_for_mozilla "/usr/local/mozilla*/chrome/comm.jar"
+ look_for_mozilla "/opt/mozilla/chrome/comm.jar"
diff --git a/net/liferea/files/patch-src::net::netio.c b/net/liferea/files/patch-src::net::netio.c
deleted file mode 100644
index a7f0fe51107b..000000000000
--- a/net/liferea/files/patch-src::net::netio.c
+++ /dev/null
@@ -1,9 +0,0 @@
---- src/net/netio.c.orig 2005-04-10 17:43:21.000000000 +0300
-+++ src/net/netio.c 2005-04-10 17:45:17.000000000 +0300
-@@ -1065,5 +1065,6 @@
- g_free(cur_ptr.authinfo);
- g_free(cur_ptr.cookies);
- debug4(DEBUG_UPDATE, "download result - HTTP status: %d, error: %d, netio error:%d, data: %d", request->httpstatus, cur_ptr.problem, cur_ptr.netio_error, request->data);
-+ free(cur_ptr.content_type);
- return;
- }
diff --git a/net/liferea/files/patch-src::ui_feedlist.c b/net/liferea/files/patch-src::ui_feedlist.c
new file mode 100644
index 000000000000..55315d27fc4c
--- /dev/null
+++ b/net/liferea/files/patch-src::ui_feedlist.c
@@ -0,0 +1,11 @@
+--- src/ui_feedlist.c.orig Tue May 17 10:44:47 2005
++++ src/ui_feedlist.c Tue May 17 10:45:11 2005
+@@ -821,7 +821,7 @@
+ dbus_connection_setup_with_g_main (connection, NULL);
+
+ /* Register for the FeedReader service on the bus, so we get method calls */
+- dbus_bus_acquire_service (connection, DBUS_RSS_SERVICE, 0, &error);
++ dbus_bus_request_name (connection, DBUS_RSS_SERVICE, 0, &error);
+ if (dbus_error_is_set (&error))
+ {
+ fprintf (stderr, "*** ui_feedlist.c: Failed to get dbus service: %s | %s\n", error.name, error.message);