aboutsummaryrefslogtreecommitdiff
path: root/net/liferea
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-12-03 12:22:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-12-03 12:22:43 +0000
commitf456c022f26432767c1affca5e368ebb89b07caf (patch)
tree52c81c587969baaf0b98ab3de7664f3613e14f14 /net/liferea
parent4a3a88a7f37f663158cb3d0211b621bb67d033f8 (diff)
downloadports-f456c022f26432767c1affca5e368ebb89b07caf.tar.gz
ports-f456c022f26432767c1affca5e368ebb89b07caf.zip
Notes
Diffstat (limited to 'net/liferea')
-rw-r--r--net/liferea/Makefile24
-rw-r--r--net/liferea/distinfo6
-rw-r--r--net/liferea/files/patch-configure86
-rw-r--r--net/liferea/files/patch-dont_install_wrapper_script22
-rw-r--r--net/liferea/files/patch-src-Makefile.in12
-rw-r--r--net/liferea/pkg-plist7
6 files changed, 128 insertions, 29 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 52a7f106a0be..b4153394cfb5 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liferea
-PORTVERSION= 1.4.20
+PORTVERSION= 1.4.22
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -16,7 +16,7 @@ COMMENT= Simple RSS/RDF feed reader
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
-USE_GNOME= gnomeprefix gnomehack libgtkhtml libglade2
+USE_GNOME= gnomeprefix gnomehack libglade2
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -30,6 +30,8 @@ INSTALLS_ICONS= yes
OPTIONS= LIBNOTIFY "Enable libnotify support" on \
DBUS "Enable dbus support" on \
GNUTLS "Enable SSL/HTTPS support" on \
+ GTKHTML "Use GtkHtml for rendering" on \
+ WEBKIT "Use Webkit for rendering" off \
MOZILLA "Use Firefox for rendering" off \
XULRUNNER "Use Xulrunner for rendering" off
@@ -49,6 +51,24 @@ CONFIGURE_ARGS+=--disable-gnutls
LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
.endif
+.ifdef WITH_GTKHTML
+USE_GNOME+= libgtkhtml
+CONFIGURE_ARGS+=--enable-gtkhtml2
+PLIST_SUB+= GTKHTML=""
+.else
+CONFIGURE_ARGS+=--disable-gtkhtml2
+PLIST_SUB+= GTKHTML="@comment "
+.endif
+
+.ifdef WITH_WEBKIT
+LIB_DEPENDS+= WebKitGtk.1:${PORTSDIR}/www/webkit-gtk2
+CONFIGURE_ARGS+=--enable-webkit
+PLIST_SUB+= WEBKIT=""
+.else
+CONFIGURE_ARGS+=--disable-webkit
+PLIST_SUB+= WEBKIT="@comment "
+.endif
+
.ifdef WITH_MOZILLA
USE_GECKO= firefox mozilla
CONFIGURE_ARGS+=--enable-gecko=${GECKO}
diff --git a/net/liferea/distinfo b/net/liferea/distinfo
index d310bb28fcc6..ae0464f11839 100644
--- a/net/liferea/distinfo
+++ b/net/liferea/distinfo
@@ -1,3 +1,3 @@
-MD5 (liferea-1.4.20.tar.gz) = c52212f73276aecd3293fb9d8e232d28
-SHA256 (liferea-1.4.20.tar.gz) = 6f360b9a9096cc8b3c4ffb1550187e34b609061668057855cb63468a9341685d
-SIZE (liferea-1.4.20.tar.gz) = 1646998
+MD5 (liferea-1.4.22.tar.gz) = 4d3b8bdefad090ed9285443cfa79f731
+SHA256 (liferea-1.4.22.tar.gz) = 1f77c2e3b61f451fbdc7118c061e86e9a38cd5bedae1276a7ef16499f94f86d8
+SIZE (liferea-1.4.22.tar.gz) = 1654895
diff --git a/net/liferea/files/patch-configure b/net/liferea/files/patch-configure
new file mode 100644
index 000000000000..f9194f90a394
--- /dev/null
+++ b/net/liferea/files/patch-configure
@@ -0,0 +1,86 @@
+--- configure.orig 2008-12-03 10:08:14.000000000 +0100
++++ configure 2008-12-03 10:09:20.000000000 +0100
+@@ -28920,83 +28920,6 @@
+ Usually this means the macro was only invoked conditionally." >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+-if test -z "${HAVE_MOZILLA_TOOLKIT_TRUE}" && test -z "${HAVE_MOZILLA_TOOLKIT_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_MOZILLA_TOOLKIT\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_MOZILLA_TOOLKIT\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_DEBUG_TRUE}" && test -z "${HAVE_GECKO_DEBUG_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_1_7_TRUE}" && test -z "${HAVE_GECKO_1_7_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_7\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_1_7\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_1_8_TRUE}" && test -z "${HAVE_GECKO_1_8_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_8\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_1_8\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_1_8_1_TRUE}" && test -z "${HAVE_GECKO_1_8_1_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_8_1\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_1_8_1\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_1_9_TRUE}" && test -z "${HAVE_GECKO_1_9_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_9\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_1_9\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_HOME_TRUE}" && test -z "${HAVE_GECKO_HOME_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_HOME\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_HOME\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_DEBUG_TRUE}" && test -z "${HAVE_GECKO_DEBUG_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${HAVE_GECKO_XPCOM_GLUE_TRUE}" && test -z "${HAVE_GECKO_XPCOM_GLUE_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_XPCOM_GLUE\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"HAVE_GECKO_XPCOM_GLUE\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${WITH_XULRUNNER_TRUE}" && test -z "${WITH_XULRUNNER_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"WITH_XULRUNNER\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"WITH_XULRUNNER\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-if test -z "${WITH_MOZILLA_TRUE}" && test -z "${WITH_MOZILLA_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"WITH_MOZILLA\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"WITH_MOZILLA\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+ if test -z "${WITH_WEBKIT_TRUE}" && test -z "${WITH_WEBKIT_FALSE}"; then
+ { { echo "$as_me:$LINENO: error: conditional \"WITH_WEBKIT\" was never defined.
+ Usually this means the macro was only invoked conditionally." >&5
diff --git a/net/liferea/files/patch-dont_install_wrapper_script b/net/liferea/files/patch-dont_install_wrapper_script
deleted file mode 100644
index d050e8effe22..000000000000
--- a/net/liferea/files/patch-dont_install_wrapper_script
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/Makefile.in.orig Mon May 29 17:07:31 2006
-+++ src/Makefile.in Mon May 29 17:08:38 2006
-@@ -204,7 +204,7 @@
-
-
- bin_PROGRAMS = liferea-bin
--bin_SCRIPTS = liferea liferea-add-feed
-+bin_SCRIPTS = liferea-add-feed
-
- liferea_bin_SOURCES = \
- atom10.c atom10.h \
-@@ -374,8 +374,8 @@
- || test -f $$p1 \
- ; then \
- f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
-- echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f"; \
-- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f || exit 1; \
-+ echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/liferea"; \
-+ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/liferea || exit 1; \
- else :; fi; \
- done
-
diff --git a/net/liferea/files/patch-src-Makefile.in b/net/liferea/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..47860f7c8b23
--- /dev/null
+++ b/net/liferea/files/patch-src-Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig 2008-12-03 10:17:44.000000000 +0100
++++ src/Makefile.in 2008-12-03 10:18:37.000000000 +0100
+@@ -302,7 +302,8 @@
+ top_srcdir = @top_srcdir@
+ @WITH_GTKHTML2_TRUE@GTKHTML2 = gtkhtml2
+ @WITH_WEBKIT_TRUE@WEBKIT = webkit
+-SUBDIRS = net parsers notification ui fl_sources scripting . $(GTKHTML2) $(WEBKIT) mozilla
++@WITH_GECKO_TRUE@MOZILLA = mozilla
++SUBDIRS = net parsers notification ui fl_sources scripting . $(GTKHTML2) $(WEBKIT) $(MOZILLA)
+ AM_CPPFLAGS = \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ -DPACKAGE_LIB_DIR=\""$(pkglibdir)"\" \
diff --git a/net/liferea/pkg-plist b/net/liferea/pkg-plist
index b3119d21248d..ef1d9a578c97 100644
--- a/net/liferea/pkg-plist
+++ b/net/liferea/pkg-plist
@@ -1,9 +1,12 @@
bin/liferea
bin/liferea-add-feed
-lib/liferea/liblihtmlg.la
-lib/liferea/liblihtmlg.so
+bin/liferea-bin
+%%GTKHTML%%lib/liferea/liblihtmlg.la
+%%GTKHTML%%lib/liferea/liblihtmlg.so
%%MOZ%%lib/liferea/liblihtmlm.la
%%MOZ%%lib/liferea/liblihtmlm.so
+%%WEBKIT%%lib/liferea/liblihtmlw.la
+%%WEBKIT%%lib/liferea/liblihtmlw.so
%%XUL%%lib/liferea/liblihtmlx.la
%%XUL%%lib/liferea/liblihtmlx.so
%%NOTIFY%%lib/liferea/liblinotiflibnotify.la