aboutsummaryrefslogtreecommitdiff
path: root/net/linc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-12 13:12:30 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-12 13:12:30 +0000
commitda9abcb0d698d72c1757e9a3e78435651e46a9d3 (patch)
tree9b0913c3948511b06c4d3a3dfcb49473d985aedc /net/linc
parentbf1ea36835ce00eb7286ca8c59ef406d482d1d39 (diff)
downloadports-da9abcb0d698d72c1757e9a3e78435651e46a9d3.tar.gz
ports-da9abcb0d698d72c1757e9a3e78435651e46a9d3.zip
Notes
Diffstat (limited to 'net/linc')
-rw-r--r--net/linc/Makefile34
-rw-r--r--net/linc/distinfo1
-rw-r--r--net/linc/files/patch-Makefile.in14
-rw-r--r--net/linc/files/patch-ltmain.sh28
-rw-r--r--net/linc/pkg-comment1
-rw-r--r--net/linc/pkg-descr8
-rw-r--r--net/linc/pkg-plist23
7 files changed, 109 insertions, 0 deletions
diff --git a/net/linc/Makefile b/net/linc/Makefile
new file mode 100644
index 000000000000..a7f35962c834
--- /dev/null
+++ b/net/linc/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: linc
+# Date Created: 12 February 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linc
+PORTVERSION= 0.1.16
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= glib-1.3.13:${PORTSDIR}/devel/glib13
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>
diff --git a/net/linc/distinfo b/net/linc/distinfo
new file mode 100644
index 000000000000..87e1d465c3d9
--- /dev/null
+++ b/net/linc/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/linc-0.1.16.tar.bz2) = bb2aa352564eb4f6011b684b75877ba8
diff --git a/net/linc/files/patch-Makefile.in b/net/linc/files/patch-Makefile.in
new file mode 100644
index 000000000000..f767730af625
--- /dev/null
+++ b/net/linc/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2002/02/12 12:58:07 1.1
++++ Makefile.in 2002/02/12 13:09:12
+@@ -89,7 +89,7 @@
+ VERSION = @VERSION@
+ WARN_CFLAGS = @WARN_CFLAGS@
+
+-SUBDIRS = include src test docs
++SUBDIRS = include src docs
+
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = linc.m4
diff --git a/net/linc/files/patch-ltmain.sh b/net/linc/files/patch-ltmain.sh
new file mode 100644
index 000000000000..98cb05e4ddb3
--- /dev/null
+++ b/net/linc/files/patch-ltmain.sh
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/linc/pkg-comment b/net/linc/pkg-comment
new file mode 100644
index 000000000000..ad56f28e2fee
--- /dev/null
+++ b/net/linc/pkg-comment
@@ -0,0 +1 @@
+A library for writing networked servers & clients
diff --git a/net/linc/pkg-descr b/net/linc/pkg-descr
new file mode 100644
index 000000000000..c108528d8122
--- /dev/null
+++ b/net/linc/pkg-descr
@@ -0,0 +1,8 @@
+linc is a library that eases the task of writing networked servers & clients.
+It takes care of connection initiation and maintainance, and the details of
+various transports. It is used by the ORBit2 to handle message
+transmission/receipt.
+
+The connections can optionally be encrypted using OpenSSL.
+
+WWW: http://developer.gnome.org/projects/gap/
diff --git a/net/linc/pkg-plist b/net/linc/pkg-plist
new file mode 100644
index 000000000000..654051ef76f1
--- /dev/null
+++ b/net/linc/pkg-plist
@@ -0,0 +1,23 @@
+bin/linc-config
+include/linc-1.0/linc/linc-config.h
+include/linc-1.0/linc/linc-connection.h
+include/linc-1.0/linc/linc-protocol.h
+include/linc-1.0/linc/linc-server.h
+include/linc-1.0/linc/linc-types.h
+include/linc-1.0/linc/linc.h
+lib/liblinc.a
+lib/liblinc.so
+lib/liblinc.so.1
+libdata/pkgconfig/linc.pc
+share/aclocal/linc.m4
+share/doc/linc/c4.html
+share/doc/linc/index.html
+share/doc/linc/index.sgml
+share/doc/linc/linc-linc-protocol.html
+share/doc/linc/linc-linc-types.html
+share/doc/linc/linc-linc.html
+share/doc/linc/linc-lincconnection.html
+share/doc/linc/linc-lincserver.html
+@dirrm share/doc/linc
+@dirrm include/linc-1.0/linc
+@dirrm include/linc-1.0