aboutsummaryrefslogtreecommitdiff
path: root/net/linc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 07:34:47 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 07:34:47 +0000
commit25c1ef25e187d04f51996be4b117a2bbb4d710ef (patch)
treef1459ece302dfa650df7400da99ac0e975f6b5a5 /net/linc
parentbb379c3e81e23a4a2f43686d05173bb602a50429 (diff)
downloadports-25c1ef25e187d04f51996be4b117a2bbb4d710ef.tar.gz
ports-25c1ef25e187d04f51996be4b117a2bbb4d710ef.zip
Notes
Diffstat (limited to 'net/linc')
-rw-r--r--net/linc/Makefile6
-rw-r--r--net/linc/distinfo2
-rw-r--r--net/linc/files/patch-configure13
-rw-r--r--net/linc/files/patch-ltmain.sh45
4 files changed, 17 insertions, 49 deletions
diff --git a/net/linc/Makefile b/net/linc/Makefile
index 703657237512..d32af948fe4d 100644
--- a/net/linc/Makefile
+++ b/net/linc/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= linc
-PORTVERSION= 0.1.20
+PORTVERSION= 0.1.21
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta4
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -19,7 +19,7 @@ LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net/linc/distinfo b/net/linc/distinfo
index b9cf702d18f8..c4260032ba5a 100644
--- a/net/linc/distinfo
+++ b/net/linc/distinfo
@@ -1 +1 @@
-MD5 (gnome2/linc-0.1.20.tar.bz2) = 21742f3f06a7378c2d45db78750a9665
+MD5 (gnome2/linc-0.1.21.tar.bz2) = 2ade39312be6bfc7e85b2e106218c8c1
diff --git a/net/linc/files/patch-configure b/net/linc/files/patch-configure
new file mode 100644
index 000000000000..2b99e34f5150
--- /dev/null
+++ b/net/linc/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/04/26 07:31:03 1.1
++++ configure 2002/04/26 07:31:26
+@@ -6214,6 +6214,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/linc/files/patch-ltmain.sh b/net/linc/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/net/linc/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"