aboutsummaryrefslogtreecommitdiff
path: root/net/linknx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 17:21:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 17:21:32 +0000
commit7751fb0ecce4e91e74d2d639e823ff776eb79e42 (patch)
tree0575ed23014a3770098fd67a2fbadb9391e08afe /net/linknx
parentb82f94e1ce7ba3fb6f5fc366bda3ea930cc103ec (diff)
downloadports-7751fb0ecce4e91e74d2d639e823ff776eb79e42.tar.gz
ports-7751fb0ecce4e91e74d2d639e823ff776eb79e42.zip
Notes
Diffstat (limited to 'net/linknx')
-rw-r--r--net/linknx/Makefile8
-rw-r--r--net/linknx/files/patch-src__ioport.cpp10
2 files changed, 15 insertions, 3 deletions
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index 0adeda2fa99f..c64687f872f6 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= linknx
PORTVERSION= 0.0.1.30
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -16,7 +17,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
USES= gmake
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
+USE_AUTOTOOLS= autoconf aclocal automake
+AUTOMAKE_ARGS= --add-missing --copy --force-missing --foreign
CONFIGURE_ARGS+=CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-I${LOCALBASE}/include -L/${LOCALBASE}/lib"
@@ -25,7 +27,7 @@ OPTIONS_DEFAULT= LIBESMTP
OPTIONS_SUB=
LIBESMTP_DESC= Install libesmtp for SMTP support
LIBCURL_DESC= Install libcurl for Clickatell SMS support
-LIBLUA_DESC= Install lilua for scripting
+LIBLUA_DESC= Install liblua for scripting
MYSQL_DESC= Install libmysql for logging & persist
LIBESMTP_CONFIGURE_ENABLE= smtp
@@ -33,7 +35,7 @@ LIBESMTP_LIB_DEPENDS= libesmtp.so:${PORTSDIR}/mail/libesmtp
LIBCURL_CONFIGURE_WITH= libcurl
LIBCURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
LIBLUA_CONFIGURE_WITH= lua
-LIBLUA_USE= LUA=yes
+LIBLUA_USES= lua
LIBLUA_CFLAGS= -I${LUA_INCDIR}
LIBLUA_LDFLAGS= -L${LUA_LIBDIR}
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}/bin/mysql_config
diff --git a/net/linknx/files/patch-src__ioport.cpp b/net/linknx/files/patch-src__ioport.cpp
new file mode 100644
index 000000000000..8e31e0b1cbb5
--- /dev/null
+++ b/net/linknx/files/patch-src__ioport.cpp
@@ -0,0 +1,10 @@
+--- ./src/ioport.cpp.orig 2011-03-08 22:20:17.000000000 +0100
++++ ./src/ioport.cpp 2014-04-22 19:17:42.208791119 +0200
+@@ -21,6 +21,7 @@
+ #include <iomanip>
+ #include "ioport.h"
+ #include <fcntl.h>
++#include <unistd.h>
+
+ Logger& IOPort::logger_m(Logger::getInstance("IOPort"));
+ Logger& RxThread::logger_m(Logger::getInstance("RxThread"));