aboutsummaryrefslogtreecommitdiff
path: root/net/linneighborhood
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-18 20:20:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-18 20:20:46 +0000
commit1cbb8439eaf94c0ba8acae18bb4ed15d339df6aa (patch)
treeb86e07a6971e560ae8c9d6089975e66fe7f727a1 /net/linneighborhood
parent080c3d1ddecfa7e7b5bc65a8a7ddc1a4add7e8be (diff)
downloadports-1cbb8439eaf94c0ba8acae18bb4ed15d339df6aa.tar.gz
ports-1cbb8439eaf94c0ba8acae18bb4ed15d339df6aa.zip
Notes
Diffstat (limited to 'net/linneighborhood')
-rw-r--r--net/linneighborhood/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/net/linneighborhood/Makefile b/net/linneighborhood/Makefile
index 54a2b1015a66..2b8c14ac2511 100644
--- a/net/linneighborhood/Makefile
+++ b/net/linneighborhood/Makefile
@@ -1,5 +1,4 @@
# New ports collection makefile for: LinNeighborhood
-# Please read files/porters-note!
# Date created: 2003/04/06
# Whom: Heiner <h.eichmann@gmx.de>
#
@@ -21,15 +20,14 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"\
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"\
+ CC="${CC} -I${LOCALBASE}/include"
+# ^
+# this was done intentionaly in order to make `configure' pick up libintl.h
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102
-FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
-.endif
-
post-patch:
${CP} ${FILESDIR}/mntent* ${WRKSRC}/src
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure