aboutsummaryrefslogtreecommitdiff
path: root/net/linphone-base
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-16 14:36:21 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-16 14:36:21 +0000
commit3f3f607dd20571336628430388fdc2c934d6fc4b (patch)
tree806be0bd826af63b88d69b6367fc72b56c7a7dc5 /net/linphone-base
parentddfa4a045b95987a12a4f6b21cb2f86b705ea49d (diff)
downloadports-3f3f607dd20571336628430388fdc2c934d6fc4b.tar.gz
ports-3f3f607dd20571336628430388fdc2c934d6fc4b.zip
Notes
Diffstat (limited to 'net/linphone-base')
-rw-r--r--net/linphone-base/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index e5ff4731f1ca..fb89323b4026 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -19,28 +19,28 @@ LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
speex.2:${PORTSDIR}/audio/speex \
osip.9:${PORTSDIR}/net/libosip
+USE_GNOME= gnomehack gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-ipv6
-.ifdef WITHOUT_GNOME
-CONFIGURE_ARGS+=--enable-gnome-ui=no \
- --with-html-dir=${DOCSDIR}
+INSTALLS_SHLIB= yes
+
+MAN1= linphone.1 linphonec.1 sipomatic.1
+
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS+= --enable-gnome_ui=no --with-html-dir=${DOCSDIR}
PLIST_SUB+= GNOME="@comment " \
GNOME_PATH="" \
HTMLDOCSDIR="${DOCSDIR:S,^${PREFIX}/,,}"
.else
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnomepanel
+USE_GNOME+= gnomepanel gnomeprefix
DOCSDIR= ${GNOME_HTML_DIR}
-CONFIGURE_ARGS= --enable-gnome-ui=yes
PLIST_SUB+= GNOME="" \
GNOME_PATH="gnome/" \
HTMLDOCSDIR="${GNOME_HTML_DIR:S,^${PREFIX}/,,}"
.endif
-INSTALLS_SHLIB= yes
-
-MAN1= linphone.1 linphonec.1 sipomatic.1
.include <bsd.port.mk>