aboutsummaryrefslogtreecommitdiff
path: root/net/linphone-base
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-07-14 18:01:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-07-14 18:01:46 +0000
commit0dfe76074bbbdbf5c629a508e4a5790c9fb4eff4 (patch)
tree1ad951496790781e766d5c15c9e27fae922229e8 /net/linphone-base
parentc5237459d608947f976d0f076c4cf613b2094bbd (diff)
downloadports-0dfe76074bbbdbf5c629a508e4a5790c9fb4eff4.tar.gz
ports-0dfe76074bbbdbf5c629a508e4a5790c9fb4eff4.zip
Notes
Diffstat (limited to 'net/linphone-base')
-rw-r--r--net/linphone-base/Makefile2
-rw-r--r--net/linphone-base/files/patch-coreapi::misc.c34
2 files changed, 22 insertions, 14 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index cc0c9c2bf586..0abc569ad603 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linphone
PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://simon.morlat.free.fr/download/${PORTVERSION}/source/
diff --git a/net/linphone-base/files/patch-coreapi::misc.c b/net/linphone-base/files/patch-coreapi::misc.c
index 0f778af50c58..dfeef28b9376 100644
--- a/net/linphone-base/files/patch-coreapi::misc.c
+++ b/net/linphone-base/files/patch-coreapi::misc.c
@@ -1,15 +1,23 @@
-$FreeBSD$
+
---- coreapi/misc.c 2003/06/13 12:59:10 1.1
-+++ coreapi/misc.c 2003/06/13 12:59:39
-@@ -249,8 +249,7 @@
- hints.ai_family = PF_UNSPEC;
- hints.ai_flags = AI_NUMERICHOST;
- getaddrinfo(lc->net_conf.sel_if->ipaddr, NULL, &hints, &res);
-- if ( (strcmp(lc->net_conf.sel_if->ipaddr,"127.0.0.1")!=0)
-- && !IN6_IS_ADDR_LINKLOCAL(res->ai_addr) && !IN6_IS_ADDR_LOOPBACK(res->ai_addr))
-+ if ( (strcmp(lc->net_conf.sel_if->ipaddr,"127.0.0.1")!=0))
- #else
- if (strcmp(lc->net_conf.sel_if->ip4addr,"127.0.0.1")!=0)
- #endif
+--- coreapi/misc.c.orig Wed Mar 12 09:52:05 2003
++++ coreapi/misc.c Wed Mar 12 09:52:39 2003
+@@ -87,7 +87,7 @@
+ pid_t pid;
+
+ /* try to kill all artsd*/
+- command=g_strdup_printf("ps -u %s |grep artsd",getenv("LOGNAME"));
++ command=g_strdup_printf("ps -c %s |grep artsd",getenv("LOGNAME"));
+ out=popen(command,"r");
+ if (out!=NULL)
+ {
+@@ -102,7 +102,7 @@
+ }
+ g_free(command);
+ /* do the same with esd*/
+- command=g_strdup_printf("ps -u %s |grep esd",getenv("LOGNAME"));
++ command=g_strdup_printf("ps -c %s |grep esd",getenv("LOGNAME"));
+ out=popen(command,"r");
+ if (out!=NULL)
+ {