aboutsummaryrefslogtreecommitdiff
path: root/net/linphone-base
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-12 14:06:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-12 14:06:31 +0000
commit375fb6e8d66f23d664a40e7cf2e7d72f96f0f50e (patch)
treeaa1063dd494af4961ae9fbeeeeeadb575fdce6bf /net/linphone-base
parentcfe6265d5b79113e11b5f990d6ce537d69f12332 (diff)
- Update to version 0.12.2
- Divide net/linphone into 2 ports: net/linphone and net/linphone-base PR: ports/66396 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=109004
Diffstat (limited to 'net/linphone-base')
-rw-r--r--net/linphone-base/Makefile55
-rw-r--r--net/linphone-base/distinfo4
-rw-r--r--net/linphone-base/files/patch-Makefile.in24
-rw-r--r--net/linphone-base/files/patch-configure55
-rw-r--r--net/linphone-base/files/patch-console::Makefile.in13
-rw-r--r--net/linphone-base/files/patch-coreapi::Makefile.in13
-rw-r--r--net/linphone-base/files/patch-coreapi::enum.c16
-rw-r--r--net/linphone-base/files/patch-gnome::Makefile.in40
-rw-r--r--net/linphone-base/files/patch-mediastreamer::Makefile.in35
-rw-r--r--net/linphone-base/files/patch-oRTP::ltmain.sh15
-rw-r--r--net/linphone-base/files/patch-osipua::ltmain.sh18
-rw-r--r--net/linphone-base/files/patch-osipua::src::osipua.c12
-rw-r--r--net/linphone-base/pkg-plist152
13 files changed, 171 insertions, 281 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index 3627b501f23e..ed62b6128ed8 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -5,13 +5,13 @@
# $FreeBSD$
#
-PORTNAME= linphone
-PORTVERSION= 0.12.1
-PORTREVISION= 2
-PORTEPOCH= 1
+PORTNAME= ${LINPHONE_PORTNAME}
+PORTVERSION= ${LINPHONE_PORTVERSION}
+PORTREVISION= ${LINPHONE_PORTREVISION}
+PORTEPOCH= ${LINPHONE_PORTEPOCH}
CATEGORIES= net
-MASTER_SITES= http://simon.morlat.free.fr/download/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTVERSION}/source
+MASTER_SITES= ${LINPHONE_MASTER_SITES}
+PKGNAMESUFFIX= -base
MAINTAINER= ports@FreeBSD.org
COMMENT= A web phone that supports SIP protocol
@@ -20,28 +20,33 @@ LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
speex.2:${PORTSDIR}/audio/speex \
osip.9:${PORTSDIR}/net/libosip
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= glib20 gnomehack gnometarget intlhack pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --disable-ipv6
+CONFIGURE_ARGS= --disable-ipv6 --enable-gnome_ui=no \
+ --with-speex=${LOCALBASE} --with-html-dir=${DOCSDIR}
INSTALLS_SHLIB= yes
-MAN1= linphone.1 linphonec.1 sipomatic.1
-
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+= --enable-gnome_ui=no --with-html-dir=${DOCSDIR}
-PLIST_SUB+= GNOME="@comment " \
- GNOME_PATH="" \
- HTMLDOCSDIR="${DOCSDIR:S,^${PREFIX}/,,}"
-.else
-USE_X_PREFIX= yes
-USE_GNOME+= gnomepanel gnomeprefix
-DOCSDIR= ${GNOME_HTML_DIR}
-PLIST_SUB+= GNOME="" \
- GNOME_PATH="gnome/" \
- HTMLDOCSDIR="${GNOME_HTML_DIR:S,^${PREFIX}/,,}"
-.endif
-
-.include <bsd.port.mk>
+MAN1= linphonec.1 sipomatic.1
+
+CFLAGS+= -DPACKAGE_LOCALE_DIR='\"${PREFIX}/share/locale\"' \
+ -DPACKAGE_DATA_DIR='\"${PREFIX}/share\"' \
+ -DPACKAGE_SOUND_DIR='\"${DATADIR}/sounds\"'
+
+.include "Makefile.common"
+.include <bsd.port.pre.mk>
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/share/C/linphonec.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/share/C/sipomatic.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/share/linphone.pc ${PREFIX}/libdata/pkgconfig
+ @${MKDIR} ${DATADIR}/sounds
+ ${INSTALL_DATA} ${WRKSRC}/share/*.wav ${DATADIR}/sounds
+ @${MKDIR} ${DATADIR}/sounds/rings
+ ${INSTALL_DATA} ${WRKSRC}/share/rings/*.wav ${DATADIR}/sounds/rings
+ @${MKDIR} ${PREFIX}/share/linphonec
+ ${INSTALL_DATA} ${WRKSRC}/share/linphonec ${PREFIX}/share/linphonec
+
+.include <bsd.port.post.mk>
diff --git a/net/linphone-base/distinfo b/net/linphone-base/distinfo
index 58da85137534..92d010f38da8 100644
--- a/net/linphone-base/distinfo
+++ b/net/linphone-base/distinfo
@@ -1,2 +1,2 @@
-MD5 (linphone-0.12.1.tar.gz) = 62e94ca8e3a95297175ee0c3c6de13b1
-SIZE (linphone-0.12.1.tar.gz) = 8296534
+MD5 (linphone-0.12.2.tar.gz) = 86c01dbbcdb41786229f51ec0994ff67
+SIZE (linphone-0.12.2.tar.gz) = 3044602
diff --git a/net/linphone-base/files/patch-Makefile.in b/net/linphone-base/files/patch-Makefile.in
index 1431371048bc..c68c8ec72648 100644
--- a/net/linphone-base/files/patch-Makefile.in
+++ b/net/linphone-base/files/patch-Makefile.in
@@ -1,16 +1,24 @@
$FreeBSD$
---- Makefile.in.orig Thu Nov 20 19:41:33 2003
-+++ Makefile.in Fri Nov 21 11:04:35 2003
-@@ -156,8 +156,8 @@
+--- Makefile.in.orig Thu Apr 1 05:40:35 2004
++++ Makefile.in Thu Apr 15 03:26:01 2004
+@@ -156,13 +156,15 @@
@BUILD_TRUESPEECH_TRUE@WIN32ACM_DIR = win32acm
--SUBDIRS = support pixmaps ffmpeg po macros debian ipkg oRTP gsmlib lpc10-1.5 \
-- speex $(WIN32ACM_DIR) mediastreamer \
-+SUBDIRS = support pixmaps ffmpeg po macros debian ipkg oRTP lpc10-1.5 \
-+ $(WIN32ACM_DIR) mediastreamer \
- media_api osipua coreapi console gnome share developer-docs
++ifndef SUBDIRS
+ @BUILD_SPEEX_TRUE@SUBDIRS = support pixmaps ffmpeg po debian ipkg oRTP gsmlib lpc10-1.5 \
+ @BUILD_SPEEX_TRUE@ $(WIN32ACM_DIR) speex mediastreamer \
+ @BUILD_SPEEX_TRUE@ media_api osipua coreapi console gnome share developer-docs
+-@BUILD_SPEEX_FALSE@SUBDIRS = support pixmaps ffmpeg po debian ipkg oRTP gsmlib lpc10-1.5 \
+-@BUILD_SPEEX_FALSE@ $(WIN32ACM_DIR) speex mediastreamer \
+-@BUILD_SPEEX_FALSE@ media_api osipua coreapi console gnome share developer-docs
++@BUILD_SPEEX_FALSE@SUBDIRS = support ffmpeg po debian ipkg oRTP lpc10-1.5 \
++@BUILD_SPEEX_FALSE@ $(WIN32ACM_DIR) mediastreamer \
++@BUILD_SPEEX_FALSE@ media_api osipua coreapi console gnome developer-docs
++endif
+
+ EXTRA_DIST = linphone2.glade BUGS linphone.kdevprj \
diff --git a/net/linphone-base/files/patch-configure b/net/linphone-base/files/patch-configure
index c9d5cb8c243e..46c404eae50a 100644
--- a/net/linphone-base/files/patch-configure
+++ b/net/linphone-base/files/patch-configure
@@ -1,43 +1,26 @@
---- configure.orig Thu Nov 20 19:41:45 2003
-+++ configure Fri Nov 21 11:02:43 2003
-@@ -463,7 +463,7 @@
- # include <unistd.h>
- #endif"
+--- configure.orig Thu Apr 1 05:40:47 2004
++++ configure Thu Apr 15 03:28:18 2004
+@@ -22220,23 +22220,6 @@
+ fi
--ac_subdirs_all="$ac_subdirs_all ffmpeg speex oRTP osipua"
-+ac_subdirs_all="$ac_subdirs_all ffmpeg oRTP osipua"
- ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE INSIDE_GNOME_COMMON_TRUE INSIDE_GNOME_COMMON_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CPP EGREP INTLTOOL_DESKTOP_RULE INTLTOOL_DIRECTORY_RULE INTLTOOL_KEYS_RULE INTLTOOL_PROP_RULE INTLTOOL_OAF_RULE INTLTOOL_PONG_RULE INTLTOOL_SERVER_RULE INTLTOOL_SHEET_RULE INTLTOOL_SOUNDLIST_RULE INTLTOOL_UI_RULE INTLTOOL_XAM_RULE INTLTOOL_XML_RULE INTLTOOL_CAVES_RULE INTLTOOL_SCHEMAS_RULE INTLTOOL_THEME_RULE INTLTOOL_EXTRACT INTLTOOL_MERGE INTLTOOL_UPDATE INTLTOOL_PERL build build_cpu build_vendor build_os host host_cpu host_vendor host_os LN_S ECHO AR ac_ct_AR RANLIB ac_ct_RANLIB CXX CXXFLAGS ac_ct_CXX CXXDEPMODE CXXCPP F77 FFLAGS ac_ct_F77 LIBTOOL GETTEXT_PACKAGE USE_NLS MSGFMT GMSGFMT XGETTEXT CATALOGS CATOBJEXT DATADIRNAME GMOFILES INSTOBJEXT INTLLIBS PO_IN_DATADIR_TRUE PO_IN_DATADIR_FALSE POFILES POSUB MKINSTALLDIRS PKG_CONFIG GLIB_CFLAGS GLIB_LIBS GLIB_GENMARSHAL GOBJECT_QUERY GLIB_MKENUMS LIBGNOMEUI_CFLAGS LIBGNOMEUI_LIBS LIBGNOME_CFLAGS LIBGNOME_LIBS GNOME_APPLETS_CFLAGS GNOME_APPLETS_LIBS PTHREAD_LDFLAGS GSMLIB_CFLAGS osip_prefix IPV6_CFLAGS TRUESPEECH_CFLAGS BUILD_TRUESPEECH_TRUE BUILD_TRUESPEECH_FALSE NASM AVCODEC_LIBS GDK_CFLAGS GDK_LIBS BUILD_MEDIASTREAMER_TRUE BUILD_MEDIASTREAMER_FALSE HAVE_XINELIB_TRUE HAVE_XINELIB_FALSE HAVE_SMPEG_TRUE HAVE_SMPEG_FALSE BUILD_FFMPEG_TRUE BUILD_FFMPEG_FALSE BUILD_GDK_VO_TRUE BUILD_GDK_VO_FALSE BUILD_V4L_TRUE BUILD_V4L_FALSE BUILD_MEDIA_API_TRUE BUILD_MEDIA_API_FALSE BUILD_UGLIB_TRUE BUILD_UGLIB_FALSE BUILD_GNOME_TRUE BUILD_GNOME_FALSE BUILD_GNOME_APPLET_TRUE BUILD_GNOME_APPLET_FALSE ALSA_LIBS subdirs HTML_DIR GTKDOC HAVE_GTK_DOC_TRUE HAVE_GTK_DOC_FALSE HAVE_GTK_DOC ENABLE_GTK_DOC_TRUE ENABLE_GTK_DOC_FALSE LINPHONE_CFLAGS LINPHONE_LIBS LIBOBJS LTLIBOBJS'
- ac_subst_files=''
-@@ -22300,19 +22300,19 @@
-
-
- cat >>confdefs.h <<_ACEOF
+-cat >>confdefs.h <<_ACEOF
-#define PACKAGE_LOCALE_DIR "${realprefix}/${DATADIRNAME}/locale"
-+#define PACKAGE_LOCALE_DIR "${realprefix}/share/locale"
- _ACEOF
-
-
-
- cat >>confdefs.h <<_ACEOF
+-_ACEOF
+-
+-
+-
+-cat >>confdefs.h <<_ACEOF
-#define PACKAGE_DATA_DIR "${realprefix}/${DATADIRNAME}"
-+#define PACKAGE_DATA_DIR "${realprefix}/share/gnome"
- _ACEOF
-
-
-
- cat >>confdefs.h <<_ACEOF
+-_ACEOF
+-
+-
+-
+-cat >>confdefs.h <<_ACEOF
-#define PACKAGE_SOUND_DIR "${realprefix}/${DATADIRNAME}/sounds/linphone"
-+#define PACKAGE_SOUND_DIR "${realprefix}/share/gnome/sounds/linphone"
- _ACEOF
-
-
-@@ -23669,7 +23669,7 @@
-
-
-
--subdirs="$subdirs ffmpeg speex oRTP osipua"
-+subdirs="$subdirs ffmpeg oRTP osipua"
+-_ACEOF
+-
+-
+ found_sound=no
- ##################################################
diff --git a/net/linphone-base/files/patch-console::Makefile.in b/net/linphone-base/files/patch-console::Makefile.in
deleted file mode 100644
index 3061818ddb79..000000000000
--- a/net/linphone-base/files/patch-console::Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- console/Makefile.in.orig Wed Aug 20 17:47:05 2003
-+++ console/Makefile.in Sat Aug 23 01:16:01 2003
-@@ -164,7 +164,6 @@
- -I$(top_srcdir)/oRTP/src \
- -I$(top_srcdir)/oRTP/ \
- -I$(top_srcdir)/mediastreamer \
-- -I$(top_srcdir)/speex/libspeex \
- -I$(osip_prefix)/include/
-
-
diff --git a/net/linphone-base/files/patch-coreapi::Makefile.in b/net/linphone-base/files/patch-coreapi::Makefile.in
deleted file mode 100644
index 4606e6766796..000000000000
--- a/net/linphone-base/files/patch-coreapi::Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- coreapi/Makefile.in.orig Wed Aug 20 17:46:46 2003
-+++ coreapi/Makefile.in Sat Aug 23 01:14:24 2003
-@@ -166,7 +166,6 @@
- -I$(top_srcdir)/oRTP/src \
- -I$(top_srcdir)/oRTP/ \
- -I$(top_srcdir)/mediastreamer \
-- -I$(top_srcdir)/speex/libspeex \
- -I$(osip_prefix)/include/
-
-
diff --git a/net/linphone-base/files/patch-coreapi::enum.c b/net/linphone-base/files/patch-coreapi::enum.c
new file mode 100644
index 000000000000..268a81731e88
--- /dev/null
+++ b/net/linphone-base/files/patch-coreapi::enum.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- coreapi/enum.c.orig Sat Mar 6 01:21:40 2004
++++ coreapi/enum.c Thu Apr 15 03:46:41 2004
+@@ -21,7 +21,10 @@
+
+ #include "enum.h"
+
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <errno.h>
diff --git a/net/linphone-base/files/patch-gnome::Makefile.in b/net/linphone-base/files/patch-gnome::Makefile.in
index 265978dd7665..e6994ad1bad5 100644
--- a/net/linphone-base/files/patch-gnome::Makefile.in
+++ b/net/linphone-base/files/patch-gnome::Makefile.in
@@ -3,11 +3,47 @@ $FreeBSD$
--- gnome/Makefile.in.orig Wed Aug 20 17:47:19 2003
+++ gnome/Makefile.in Sat Aug 23 01:16:42 2003
-@@ -162,7 +162,6 @@
+@@ -160,7 +160,6 @@
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/oRTP/src \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/oRTP/ \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/mediastreamer \
-@BUILD_GNOME_TRUE@ -I$(top_srcdir)/speex/libspeex \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/coreapi \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/osipua/ \
- @BUILD_GNOME_TRUE@ -I$(top_srcdir)/osipua/src
+ @BUILD_GNOME_TRUE@ -I$(top_srcdir)/osipua/src \
+@@ -183,7 +182,7 @@
+
+ @BUILD_GNOME_TRUE@linphone_LDADD = $(LIBGNOMEUI_LIBS) $(INTLLIBS) \
+ @BUILD_GNOME_TRUE@ $(LIBGNOME_LIBS) \
+-@BUILD_GNOME_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
++@BUILD_GNOME_TRUE@ -llinphonegnome
+
+
+ AM_CFLAGS = $(LIBGNOMEUI_CFLAGS) $(LIBGNOME_CFLAGS) $(GNOME_APPLETS_CFLAGS) $(IPV6_CFLAGS)
+@@ -206,7 +205,7 @@
+
+ @BUILD_GNOME_APPLET_TRUE@linphone_applet_LDADD = \
+ @BUILD_GNOME_APPLET_TRUE@ $(GNOME_APPLETS_LIBS) \
+-@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
++@BUILD_GNOME_APPLET_TRUE@ -llinphonegnome
+
+
+
+@@ -241,7 +240,7 @@
+ @BUILD_GNOME_TRUE@ propertybox.$(OBJEXT) addressbook.$(OBJEXT)
+ linphone_OBJECTS = $(am_linphone_OBJECTS)
+ @BUILD_GNOME_TRUE@linphone_DEPENDENCIES = \
+-@BUILD_GNOME_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
++@BUILD_GNOME_TRUE@ -llinphonegnome
+ @BUILD_GNOME_FALSE@linphone_DEPENDENCIES =
+ linphone_LDFLAGS =
+ @BUILD_GNOME_APPLET_TRUE@am_linphone_applet_OBJECTS = \
+@@ -256,7 +255,7 @@
+ @BUILD_GNOME_APPLET_TRUE@ linphone_applet-applet.$(OBJEXT)
+ linphone_applet_OBJECTS = $(am_linphone_applet_OBJECTS)
+ @BUILD_GNOME_APPLET_TRUE@linphone_applet_DEPENDENCIES = \
+-@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
++@BUILD_GNOME_APPLET_TRUE@ -llinphonegnome
+ @BUILD_GNOME_APPLET_FALSE@linphone_applet_DEPENDENCIES =
+ linphone_applet_LDFLAGS =
+
diff --git a/net/linphone-base/files/patch-mediastreamer::Makefile.in b/net/linphone-base/files/patch-mediastreamer::Makefile.in
index bab51371dd00..4570677c1ee6 100644
--- a/net/linphone-base/files/patch-mediastreamer::Makefile.in
+++ b/net/linphone-base/files/patch-mediastreamer::Makefile.in
@@ -1,8 +1,8 @@
$FreeBSD$
---- mediastreamer/Makefile.in.orig Thu Nov 20 19:41:39 2003
-+++ mediastreamer/Makefile.in Fri Nov 21 10:59:28 2003
+--- mediastreamer/Makefile.in.orig Thu Apr 1 05:40:41 2004
++++ mediastreamer/Makefile.in Thu Apr 15 03:30:15 2004
@@ -222,7 +222,7 @@
@@ -11,30 +11,16 @@ $FreeBSD$
+ -lgsm \
../lpc10-1.5/liblpc10.la \
../oRTP/src/libortp.la \
- $(ALSA_LIBS) \
-@@ -252,7 +252,7 @@
-
- #the speex encoder and decoder
- libmsspeex_la_SOURCES = msspeexenc.c msspeexenc.h msspeexdec.c msspeexdec.h
--libmsspeex_la_LIBADD = libmediastreamer.la $(top_srcdir)/speex/libspeex/libspeex.la
-+libmsspeex_la_LIBADD = libmediastreamer.la -lspeex
-
- #the v4l plugin
- libmsv4l_la_SOURCES = msv4l.c msv4l.h
-@@ -335,12 +335,8 @@
+ $(SUPPORTLIB) \
+@@ -336,7 +336,6 @@
-I$(top_srcdir)/mediastreamer \
-I$(top_srcdir)/oRTP/src \
-I$(top_srcdir)/oRTP \
- -I$(top_srcdir)/gsmlib \
-I$(top_srcdir)/lpc10-1.5 \
-I$(top_srcdir)/ffmpeg/libavcodec \
-- -I/usr/X11R6/include/X11 \
-- -I/usr/include/SDL \
-- -I$(top_srcdir)/speex/libspeex \
- $(TRUESPEECH_INCLUDES)
-
- subdir = mediastreamer
-@@ -351,12 +347,12 @@
+ -I/usr/X11R6/include/X11 \
+@@ -352,12 +351,12 @@
libmediastreamer_la_LDFLAGS =
@BUILD_TRUESPEECH_TRUE@libmediastreamer_la_DEPENDENCIES = \
@@ -49,12 +35,3 @@ $FreeBSD$
@BUILD_TRUESPEECH_FALSE@ ../lpc10-1.5/liblpc10.la \
@BUILD_TRUESPEECH_FALSE@ ../oRTP/src/libortp.la
@BUILD_TRUESPEECH_TRUE@am__objects_1 = mstruespeechencoder.lo \
-@@ -386,7 +382,7 @@
- libmssmpeg_la_OBJECTS = $(am_libmssmpeg_la_OBJECTS)
- libmsspeex_la_LDFLAGS =
- libmsspeex_la_DEPENDENCIES = libmediastreamer.la \
-- $(top_srcdir)/speex/libspeex/libspeex.la
-+ -lspeex
- am_libmsspeex_la_OBJECTS = msspeexenc.lo msspeexdec.lo
- libmsspeex_la_OBJECTS = $(am_libmsspeex_la_OBJECTS)
- libmsv4l_la_LDFLAGS =
diff --git a/net/linphone-base/files/patch-oRTP::ltmain.sh b/net/linphone-base/files/patch-oRTP::ltmain.sh
deleted file mode 100644
index b2ed1cfb3dd6..000000000000
--- a/net/linphone-base/files/patch-oRTP::ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- oRTP/ltmain.sh.orig Thu Nov 20 19:42:06 2003
-+++ oRTP/ltmain.sh Fri Nov 21 13:13:05 2003
-@@ -5478,10 +5478,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/linphone-base/files/patch-osipua::ltmain.sh b/net/linphone-base/files/patch-osipua::ltmain.sh
deleted file mode 100644
index e2ecc7c5b1fa..000000000000
--- a/net/linphone-base/files/patch-osipua::ltmain.sh
+++ /dev/null
@@ -1,18 +0,0 @@
-
-$FreeBSD$
-
---- osipua/ltmain.sh.orig Wed May 14 00:40:19 2003
-+++ osipua/ltmain.sh Sun Aug 17 19:30:25 2003
-@@ -4325,10 +4325,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/linphone-base/files/patch-osipua::src::osipua.c b/net/linphone-base/files/patch-osipua::src::osipua.c
deleted file mode 100644
index 0ebdee4d5cd1..000000000000
--- a/net/linphone-base/files/patch-osipua::src::osipua.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- osipua/src/osipua.c.orig Mon Oct 20 17:55:05 2003
-+++ osipua/src/osipua.c Fri Nov 21 11:52:31 2003
-@@ -591,8 +591,7 @@
- if (ipaddr != NULL)
- {
- osip_trace(OSIP_INFO1,("osip_ua_find 1: %s <> %s \n",ua->ua_ipaddr,ipaddr));
-- if ((strcasecmp(ua->ua_ipaddr,ipaddr)==0) || (strcasecmp("127.0.0.1",ipaddr)==0) ||
-- IN6_IS_ADDR_LOOPBACK(res->ai_addr))
-+ if ((strcasecmp(ua->ua_ipaddr,ipaddr)==0) || (strcasecmp("127.0.0.1",ipaddr)==0))
- {
- ret_ua=ua; /* ip addresses match */
- }
diff --git a/net/linphone-base/pkg-plist b/net/linphone-base/pkg-plist
index 04d8816161e5..13e55a0a3683 100644
--- a/net/linphone-base/pkg-plist
+++ b/net/linphone-base/pkg-plist
@@ -1,9 +1,12 @@
-%%GNOME%%bin/linphone
bin/linphonec
bin/sipomatic
include/linphone/config.h
+include/linphone/glist.h
+include/linphone/gshell.h
+include/linphone/gspawn.h
include/linphone/linphonecore.h
include/linphone/sndcard.h
+include/linphone/uglib.h
include/ortp/ortp-config.h
include/ortp/ortp.h
include/ortp/payloadtype.h
@@ -51,119 +54,52 @@ lib/libosipalloc.so.0
lib/libosipua.a
lib/libosipua.so
lib/libosipua.so.2
-%%GNOME%%libdata/bonobo/servers/GNOME_LinphoneApplet.server
libdata/pkgconfig/linphone.pc
-%%GNOME%%libexec/linphone_applet
-%%HTMLDOCSDIR%%/mediastreamer/book1.html
-%%HTMLDOCSDIR%%/mediastreamer/coreapi.html
-%%HTMLDOCSDIR%%/mediastreamer/index.sgml
-%%HTMLDOCSDIR%%/mediastreamer/mediastreamer-filters.html
-%%HTMLDOCSDIR%%/mediastreamer/mediastreamer-msringplayer.html
-%%HTMLDOCSDIR%%/mediastreamer/mediastreamer-mssync.html
-%%HTMLDOCSDIR%%/mediastreamer/mediastreamer-running-processing-chains.html
-%%HTMLDOCSDIR%%/mediastreamer/msfilterimplementations.html
-%%HTMLDOCSDIR%%/mediastreamer/userapi.html
-%%HTMLDOCSDIR%%/ortp/book1.html
-%%HTMLDOCSDIR%%/ortp/index.sgml
-%%HTMLDOCSDIR%%/ortp/ortp-library-management-functions.html
-%%HTMLDOCSDIR%%/ortp/ortp-multiplexing-sessions-(in-a-one-thread-design).html
-%%HTMLDOCSDIR%%/ortp/ortp-rtp-payloads-and-profiles.html
-%%HTMLDOCSDIR%%/ortp/ortp-rtpsession-api.html
-%%HTMLDOCSDIR%%/ortp/ortp-stack-management-functions.html
-%%HTMLDOCSDIR%%/ortp/ortp-telephone-events-(rfc2833)-.html
-%%HTMLDOCSDIR%%/ortp/ortpapi.html
-%%HTMLDOCSDIR%%/osipua/book1.html
-%%HTMLDOCSDIR%%/osipua/index.sgml
-%%HTMLDOCSDIR%%/osipua/osipcallleg.html
-%%HTMLDOCSDIR%%/osipua/osipua--registrationctxt-api-.html
-%%HTMLDOCSDIR%%/osipua/osipua-osipcallleg-private-api.html
-%%HTMLDOCSDIR%%/osipua/osipua-osipcallleg-public-api.html
-%%HTMLDOCSDIR%%/osipua/osipua-osipua-private-api.html
-%%HTMLDOCSDIR%%/osipua/osipua-osipua-public-api.html
-%%HTMLDOCSDIR%%/osipua/osipua.html
-%%HTMLDOCSDIR%%/osipua/registrationctxt.html
-share/gnome/apps/Internet/linphone.desktop
-%%GNOME%%share/gnome/gnome-2.0/ui/GNOME_LinphoneApplet.xml
-share/gnome/help/linphone/C/docbook.css
-share/gnome/help/linphone/C/index.html
-share/gnome/help/linphone/C/params.html
-share/gnome/help/linphone/C/t1.html
-share/gnome/help/linphone/C/x118.html
-share/gnome/help/linphone/C/x121.html
-share/gnome/help/linphone/C/x137.html
-share/gnome/help/linphone/C/x143.html
-share/gnome/help/linphone/C/x167.html
-share/gnome/help/linphone/C/x172.html
-share/gnome/help/linphone/C/x188.html
-share/gnome/help/linphone/C/x26.html
-share/gnome/help/linphone/C/x36.html
-share/gnome/help/linphone/fr/docbook.css
-share/gnome/help/linphone/fr/params.html
-share/gnome/help/linphone/fr/registering.html
-share/gnome/help/linphone/fr/t1.html
-share/gnome/help/linphone/fr/x116.html
-share/gnome/help/linphone/fr/x134.html
-share/gnome/help/linphone/fr/x140.html
-share/gnome/help/linphone/fr/x164.html
-share/gnome/help/linphone/fr/x170.html
-share/gnome/help/linphone/fr/x188.html
-share/gnome/help/linphone/fr/x24.html
-share/gnome/help/linphone/fr/x34.html
-share/gnome/help/linphone/it/docbook.css
-share/gnome/help/linphone/it/params.html
-share/gnome/help/linphone/it/registering.html
-share/gnome/help/linphone/it/t1.html
-share/gnome/help/linphone/it/x116.html
-share/gnome/help/linphone/it/x134.html
-share/gnome/help/linphone/it/x140.html
-share/gnome/help/linphone/it/x164.html
-share/gnome/help/linphone/it/x170.html
-share/gnome/help/linphone/it/x189.html
-share/gnome/help/linphone/it/x24.html
-share/gnome/help/linphone/it/x34.html
-share/gnome/help/linphone/ja/params.html
-share/gnome/help/linphone/ja/t1.html
-share/gnome/help/linphone/ja/x112.html
-share/gnome/help/linphone/ja/x115.html
-share/gnome/help/linphone/ja/x131.html
-share/gnome/help/linphone/ja/x137.html
-share/gnome/help/linphone/ja/x161.html
-share/gnome/help/linphone/ja/x166.html
-share/gnome/help/linphone/ja/x182.html
-share/gnome/help/linphone/ja/x25.html
-share/gnome/help/linphone/ja/x35.html
-share/%%GNOME_PATH%%linphonec/linphonec
-share/%%GNOME_PATH%%pixmaps/linphone/linphone.png
-share/%%GNOME_PATH%%pixmaps/linphone/linphone2.png
-share/%%GNOME_PATH%%pixmaps/linphone/linphone2.xpm
-share/%%GNOME_PATH%%sounds/linphone/hello16000.wav
-share/%%GNOME_PATH%%sounds/linphone/hello8000.wav
-share/%%GNOME_PATH%%sounds/linphone/ringback.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/bigben.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/oldphone.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/orig.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/rock.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/sweet.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/synth.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/tapping.wav
-share/%%GNOME_PATH%%sounds/linphone/rings/toy.wav
+%%DOCSDIR%%/mediastreamer/book1.html
+%%DOCSDIR%%/mediastreamer/coreapi.html
+%%DOCSDIR%%/mediastreamer/index.sgml
+%%DOCSDIR%%/mediastreamer/mediastreamer-filters.html
+%%DOCSDIR%%/mediastreamer/mediastreamer-msringplayer.html
+%%DOCSDIR%%/mediastreamer/mediastreamer-mssync.html
+%%DOCSDIR%%/mediastreamer/mediastreamer-running-processing-chains.html
+%%DOCSDIR%%/mediastreamer/msfilterimplementations.html
+%%DOCSDIR%%/mediastreamer/userapi.html
+%%DOCSDIR%%/ortp/book1.html
+%%DOCSDIR%%/ortp/index.sgml
+%%DOCSDIR%%/ortp/ortp-library-management-functions.html
+%%DOCSDIR%%/ortp/ortp-multiplexing-sessions-(in-a-one-thread-design).html
+%%DOCSDIR%%/ortp/ortp-rtp-payloads-and-profiles.html
+%%DOCSDIR%%/ortp/ortp-rtpsession-api.html
+%%DOCSDIR%%/ortp/ortp-telephone-events-(rfc2833)-.html
+%%DOCSDIR%%/ortp/ortpapi.html
+%%DOCSDIR%%/osipua/book1.html
+%%DOCSDIR%%/osipua/index.sgml
+%%DOCSDIR%%/osipua/osipcallleg.html
+%%DOCSDIR%%/osipua/osipua--registrationctxt-api-.html
+%%DOCSDIR%%/osipua/osipua-osipcallleg-private-api.html
+%%DOCSDIR%%/osipua/osipua-osipcallleg-public-api.html
+%%DOCSDIR%%/osipua/osipua-osipua-private-api.html
+%%DOCSDIR%%/osipua/osipua-osipua-public-api.html
+%%DOCSDIR%%/osipua/osipua.html
+%%DOCSDIR%%/osipua/registrationctxt.html
+%%DATADIR%%/sounds/hello16000.wav
+%%DATADIR%%/sounds/hello8000.wav
+%%DATADIR%%/sounds/ringback.wav
+%%DATADIR%%/sounds/rings/oldphone.wav
+%%DATADIR%%/sounds/rings/orig.wav
+share/linphonec/linphonec
share/locale/de/LC_MESSAGES/linphone.mo
share/locale/es/LC_MESSAGES/linphone.mo
share/locale/fr/LC_MESSAGES/linphone.mo
share/locale/it/LC_MESSAGES/linphone.mo
share/locale/ja/LC_MESSAGES/linphone.mo
share/locale/pl/LC_MESSAGES/linphone.mo
-@dirrm share/%%GNOME_PATH%%sounds/linphone/rings
-@dirrm share/%%GNOME_PATH%%sounds/linphone
-@dirrm share/%%GNOME_PATH%%pixmaps/linphone
-@dirrm share/%%GNOME_PATH%%linphonec
-@dirrm share/gnome/help/linphone/ja
-@dirrm share/gnome/help/linphone/it
-@dirrm share/gnome/help/linphone/fr
-@dirrm share/gnome/help/linphone/C
-@dirrm share/gnome/help/linphone
-@dirrm %%HTMLDOCSDIR%%/osipua
-@dirrm %%HTMLDOCSDIR%%/ortp
-@dirrm %%HTMLDOCSDIR%%/mediastreamer
+@dirrm share/linphonec
+@dirrm %%DATADIR%%/sounds/rings
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/osipua
+@dirrm %%DOCSDIR%%/ortp
+@dirrm %%DOCSDIR%%/mediastreamer
@dirrm include/osipua
@dirrm include/ortp