aboutsummaryrefslogtreecommitdiff
path: root/net/linphone-base
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-18 20:52:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-18 20:52:23 +0000
commit250ab3a0957d5b0b86b1b14cb7a0879253fd154b (patch)
treea8250921c1390fa80afc6f01a2dc2a4cd419d541 /net/linphone-base
parent7ac31b1057a070acfb01d5948c3153a0e1a79bb5 (diff)
downloadports-250ab3a0957d5b0b86b1b14cb7a0879253fd154b.tar.gz
ports-250ab3a0957d5b0b86b1b14cb7a0879253fd154b.zip
Notes
Diffstat (limited to 'net/linphone-base')
-rw-r--r--net/linphone-base/Makefile10
-rw-r--r--net/linphone-base/Makefile.common2
-rw-r--r--net/linphone-base/distinfo6
-rw-r--r--net/linphone-base/files/patch-configure25
-rw-r--r--net/linphone-base/files/patch-console__linphonec.c32
-rw-r--r--net/linphone-base/files/patch-gnome::Makefile.in20
-rw-r--r--net/linphone-base/files/patch-mediastreamer2::Makefile.in30
-rw-r--r--net/linphone-base/files/patch-mediastreamer2__mssync.c19
-rw-r--r--net/linphone-base/files/patch-oRTP__src__rtpparse.c19
-rw-r--r--net/linphone-base/pkg-plist8
10 files changed, 79 insertions, 92 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index 03fa1f6bde24..21e176f69a52 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -24,14 +24,12 @@ LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
osip2.3:${PORTSDIR}/net/libosip2
USE_GNOME= glib20 gnomehack gnometarget intlhack pkgconfig
-USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
LIBTOOLFILES= configure oRTP/configure
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-ipv6 --disable-gtk-doc --enable-gnome_ui=no \
- --disable-ewarning --without-ilbc \
+ --disable-ewarning --without-ilbc --disable-strict \
--with-speex=${LOCALBASE} --with-osip=${LOCALBASE} \
--with-html-dir=${DOCSDIR}
INSTALLS_SHLIB= yes
@@ -41,6 +39,8 @@ MAN1= linphonec.1 sipomatic.1
CFLAGS+= -DPACKAGE_LOCALE_DIR='\"${PREFIX}/share/locale\"' \
-DPACKAGE_DATA_DIR='\"${PREFIX}/share\"' \
-DPACKAGE_SOUND_DIR='\"${DATADIR}/sounds\"'
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include "Makefile.common"
.include <bsd.port.pre.mk>
diff --git a/net/linphone-base/Makefile.common b/net/linphone-base/Makefile.common
index bbdb23ed7743..35a04f0814bb 100644
--- a/net/linphone-base/Makefile.common
+++ b/net/linphone-base/Makefile.common
@@ -3,7 +3,7 @@
#
LINPHONE_PORTNAME= linphone
-LINPHONE_PORTVERSION= 1.2.0
+LINPHONE_PORTVERSION= 1.3.0
LINPHONE_PORTREVISION= 0
LINPHONE_PORTEPOCH= 1
LINPHONE_MASTER_SITES= http://simon.morlat.free.fr/download/stable/source/
diff --git a/net/linphone-base/distinfo b/net/linphone-base/distinfo
index a55694b7a190..699404df251c 100644
--- a/net/linphone-base/distinfo
+++ b/net/linphone-base/distinfo
@@ -1,3 +1,3 @@
-MD5 (linphone-1.2.0.tar.gz) = bd5e513a665ce2e381afce64d569c707
-SHA256 (linphone-1.2.0.tar.gz) = 24496cae7c4919473d6f8e78506d762e671fe84a627a5dfda5cb44cda5c421d2
-SIZE (linphone-1.2.0.tar.gz) = 7372152
+MD5 (linphone-1.3.0.tar.gz) = a96ab62413949ec2977df38ea830f7ce
+SHA256 (linphone-1.3.0.tar.gz) = 29e8e6238b02a17058a2150df97be227428e43cd009f1f8eadb8b72eceb5daa3
+SIZE (linphone-1.3.0.tar.gz) = 7388450
diff --git a/net/linphone-base/files/patch-configure b/net/linphone-base/files/patch-configure
index 1cdf9ac14450..00f442961b29 100644
--- a/net/linphone-base/files/patch-configure
+++ b/net/linphone-base/files/patch-configure
@@ -1,22 +1,9 @@
---- configure.orig Thu Aug 25 07:37:04 2005
-+++ configure Thu Aug 25 23:31:24 2005
-@@ -23818,10 +23818,6 @@
- ;;
- esac
-
--if test "$GCC" = "yes" ; then
-- STRICT_OPTIONS="-Wall -Werror"
--fi
--
+--- configure.orig Sat Mar 4 01:55:47 2006
++++ configure Sat Mar 11 01:28:23 2006
+@@ -23532,23 +23532,6 @@
+ fi
- # Check whether --with-realprefix or --without-realprefix was given.
-@@ -23930,23 +23926,6 @@
- if test "x${realprefix}" = "xnone"; then
- realprefix=${prefix}
- fi
--
--
-cat >>confdefs.h <<_ACEOF
-#define PACKAGE_LOCALE_DIR "${realprefix}/${DATADIRNAME}/locale"
-_ACEOF
@@ -32,6 +19,8 @@
-cat >>confdefs.h <<_ACEOF
-#define PACKAGE_SOUND_DIR "${realprefix}/${DATADIRNAME}/sounds/linphone"
-_ACEOF
+-
+-
+ found_sound=no
- found_sound=no
diff --git a/net/linphone-base/files/patch-console__linphonec.c b/net/linphone-base/files/patch-console__linphonec.c
deleted file mode 100644
index cb14869cec25..000000000000
--- a/net/linphone-base/files/patch-console__linphonec.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- console/linphonec.c.orig Wed Nov 30 21:11:54 2005
-+++ console/linphonec.c Tue Dec 20 13:29:42 2005
-@@ -71,8 +71,8 @@
- //Process termination handling
- void term(int sig)
- {
-- terminate = TRUE;
- char input[LINE_MAX_LEN];
-+ terminate = TRUE;
- snprintf (input,sizeof(LINE_MAX_LEN),"%s", "terminate");
- linphonec_parse_command_line(&linphonec,input);
- snprintf (input,sizeof(LINE_MAX_LEN), "%s", "quit");
-@@ -161,9 +161,6 @@
- int
- linphonec_main_loop (LinphoneCore * opm, char * sipAddr)
- {
-- if (terminate_on_close) {
-- signal(SIGTERM, term);
-- }
- //auto call handling
- gboolean firstTimeInLoop=TRUE;
- char input[LINE_MAX_LEN];
-@@ -171,6 +168,9 @@
- fd_set fdset;
- struct timeval timeout;
- gboolean run=TRUE;
-+ if (terminate_on_close) {
-+ signal(SIGTERM, term);
-+ }
- printf("linphonec> ");fflush(stdout);
- while (run && !terminate)
- {
diff --git a/net/linphone-base/files/patch-gnome::Makefile.in b/net/linphone-base/files/patch-gnome::Makefile.in
index a099e5974cc4..3f896acc57c9 100644
--- a/net/linphone-base/files/patch-gnome::Makefile.in
+++ b/net/linphone-base/files/patch-gnome::Makefile.in
@@ -1,6 +1,6 @@
---- gnome/Makefile.in.orig Tue Mar 22 00:53:38 2005
-+++ gnome/Makefile.in Wed Mar 23 19:37:16 2005
-@@ -69,8 +69,7 @@
+--- gnome/Makefile.in.orig Sat Mar 4 01:55:42 2006
++++ gnome/Makefile.in Sat Mar 11 01:04:15 2006
+@@ -70,8 +70,7 @@
linphone_OBJECTS = $(am_linphone_OBJECTS)
am__DEPENDENCIES_1 =
@BUILD_GNOME_TRUE@linphone_DEPENDENCIES = $(am__DEPENDENCIES_1) \
@@ -10,30 +10,30 @@
am__linphone_applet_SOURCES_DIST = linphone.c linphone.h gui_utils.c \
gui_utils.h support.c support.h interface.c interface.h \
callbacks.c callbacks.h presence.c presence.h propertybox.c \
-@@ -90,8 +89,7 @@
+@@ -91,8 +90,7 @@
@BUILD_GNOME_APPLET_TRUE@ linphone_applet-applet.$(OBJEXT)
linphone_applet_OBJECTS = $(am_linphone_applet_OBJECTS)
@BUILD_GNOME_APPLET_TRUE@linphone_applet_DEPENDENCIES = \
-@BUILD_GNOME_APPLET_TRUE@ $(am__DEPENDENCIES_1) \
--@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphone.la
+-@BUILD_GNOME_APPLET_TRUE@ $(top_builddir)/coreapi/liblinphone.la
+@BUILD_GNOME_APPLET_TRUE@ $(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
-@@ -355,7 +353,7 @@
+@@ -363,7 +361,7 @@
@BUILD_GNOME_TRUE@linphone_LDADD = $(LIBGNOMEUI_LIBS) $(INTLLIBS) \
@BUILD_GNOME_TRUE@ $(LIBGNOME_LIBS) \
-@BUILD_GNOME_TRUE@ $(top_builddir)/coreapi/liblinphone.la
-+@BUILD_GNOME_TRUE@ -llinphone
++@BUILD_GNOME_TRUE@ -llinphone
- AM_CFLAGS = $(LIBGNOMEUI_CFLAGS) $(LIBGNOME_CFLAGS) $(GNOME_APPLETS_CFLAGS) $(IPV6_CFLAGS)
+ AM_CFLAGS = $(STRICT_OPTIONS) $(LIBGNOMEUI_CFLAGS) $(LIBGNOME_CFLAGS) $(GNOME_APPLETS_CFLAGS) $(IPV6_CFLAGS)
@BUILD_GNOME_APPLET_TRUE@gnome_appletdir = $(libexecdir)
-@@ -366,7 +364,7 @@
+@@ -374,7 +372,7 @@
@BUILD_GNOME_APPLET_TRUE@linphone_applet_CFLAGS = $(AM_CFLAGS) -DLINPHONE_APPLET
@BUILD_GNOME_APPLET_TRUE@linphone_applet_LDADD = \
@BUILD_GNOME_APPLET_TRUE@ $(GNOME_APPLETS_LIBS) \
--@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphone.la
+-@BUILD_GNOME_APPLET_TRUE@ $(top_builddir)/coreapi/liblinphone.la
+@BUILD_GNOME_APPLET_TRUE@ -llinphone
diff --git a/net/linphone-base/files/patch-mediastreamer2::Makefile.in b/net/linphone-base/files/patch-mediastreamer2::Makefile.in
index 413e367e4838..06d72049f4c2 100644
--- a/net/linphone-base/files/patch-mediastreamer2::Makefile.in
+++ b/net/linphone-base/files/patch-mediastreamer2::Makefile.in
@@ -1,20 +1,12 @@
---- mediastreamer2/Makefile.in.orig Tue Mar 22 00:53:40 2005
-+++ mediastreamer2/Makefile.in Wed Mar 23 17:53:26 2005
-@@ -53,7 +53,7 @@
- @BUILD_UGLIB_TRUE@am__DEPENDENCIES_2 = \
- @BUILD_UGLIB_TRUE@ $(top_builddir)/support/libuglib.la
- libmediastreamer2_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-- ../gsmlib/libgsm.la ../lpc10-1.5/liblpc10.la \
-+ ../lpc10-1.5/liblpc10.la \
- ../oRTP/src/libortp.la $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_2) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1)
-@@ -311,7 +311,7 @@
- msringplayer.c msringplayer.h waveheader.h
+--- mediastreamer2/Makefile.in.orig Wed Mar 8 19:41:19 2006
++++ mediastreamer2/Makefile.in Sat Mar 11 01:23:47 2006
+@@ -310,8 +310,7 @@
+ msfileplayer.c msfileplayer.h waveheader.h\
+ $(am__append_1)
+ libmediastreamer2_la_LIBADD = $(top_builddir)/oRTP/src/libortp.la \
+- $(ALSA_LIBS) \
+- -lrt
++ $(ALSA_LIBS)
- libmediastreamer2_la_LIBADD = $(GLIB_LIBS) \
-- ../gsmlib/libgsm.la \
-+ -lgsm \
- ../lpc10-1.5/liblpc10.la \
- ../oRTP/src/libortp.la \
- $(JACK_LIBS)\
+ INCLUDES = -I$(top_srcdir)/oRTP/include
+ ORTP_CFLAGS = `cat $(top_builddir)/oRTP/ortp.defs`
diff --git a/net/linphone-base/files/patch-mediastreamer2__mssync.c b/net/linphone-base/files/patch-mediastreamer2__mssync.c
new file mode 100644
index 000000000000..59a35367ef65
--- /dev/null
+++ b/net/linphone-base/files/patch-mediastreamer2__mssync.c
@@ -0,0 +1,19 @@
+--- mediastreamer2/mssync.c.orig Sat Mar 4 06:07:01 2006
++++ mediastreamer2/mssync.c Sat Mar 11 01:21:51 2006
+@@ -194,6 +194,7 @@
+ MSSync *s=(MSSync*)arg;
+ uint64_t realtime;
+ uint64_t orig=get_cur_time();
++ int64_t diff;
+ s->ticks=1;
+ ms_mutex_lock(&s->lock);
+ while(s->run){
+@@ -203,7 +204,7 @@
+ s->time+=s->interval;
+ while(1){
+ realtime=get_cur_time()-orig;
+- int64_t diff=s->time-realtime;
++ diff=s->time-realtime;
+ if (diff>0){
+ /* sleep until next tick */
+ sleepMs(diff);
diff --git a/net/linphone-base/files/patch-oRTP__src__rtpparse.c b/net/linphone-base/files/patch-oRTP__src__rtpparse.c
new file mode 100644
index 000000000000..972324a03631
--- /dev/null
+++ b/net/linphone-base/files/patch-oRTP__src__rtpparse.c
@@ -0,0 +1,19 @@
+--- oRTP/src/rtpparse.c.orig Wed Feb 1 01:06:16 2006
++++ oRTP/src/rtpparse.c Sat Mar 11 01:12:41 2006
+@@ -70,6 +70,7 @@
+ int msgsize;
+ RtpStream *rtpstream=&session->rtp;
+ rtp_stats_t *stats=&rtpstream->stats;
++ poly32_t *extseq;
+
+ return_if_fail(mp!=NULL);
+
+@@ -120,7 +121,7 @@
+ }else session->recv_ssrc=rtp->ssrc;
+
+ /* update some statistics */
+- poly32_t *extseq=(poly32_t*)&rtpstream->hwrcv_extseq;
++ extseq=(poly32_t*)&rtpstream->hwrcv_extseq;
+ if (rtp->seq_number>extseq->split.lo){
+ extseq->split.lo=rtp->seq_number;
+ }else if (rtp->seq_number<200 && extseq->split.lo>((1<<16) - 200)){
diff --git a/net/linphone-base/pkg-plist b/net/linphone-base/pkg-plist
index 80c360052857..24bce0bc6183 100644
--- a/net/linphone-base/pkg-plist
+++ b/net/linphone-base/pkg-plist
@@ -8,12 +8,11 @@ include/linphone/linphonecore.h
include/linphone/lpconfig.h
include/linphone/sndcard.h
include/linphone/uglib.h
-include/ortp/ortp-config.h
include/ortp/ortp.h
include/ortp/payloadtype.h
+include/ortp/port.h
include/ortp/rtcp.h
include/ortp/rtp.h
-include/ortp/rtpport.h
include/ortp/rtpsession.h
include/ortp/rtpsignaltable.h
include/ortp/sessionset.h
@@ -22,13 +21,14 @@ include/ortp/telephonyevents.h
lib/liblinphone.a
lib/liblinphone.la
lib/liblinphone.so
-lib/liblinphone.so.3
+lib/liblinphone.so.4
lib/libortp.a
lib/libortp.la
lib/libortp.so
-lib/libortp.so.2
+lib/libortp.so.4
libdata/pkgconfig/linphone.pc
libdata/pkgconfig/ortp.pc
+libexec/mediastream
%%DATADIR%%/sounds/hello16000.wav
%%DATADIR%%/sounds/hello8000.wav
%%DATADIR%%/sounds/ringback.wav