aboutsummaryrefslogtreecommitdiff
path: root/net/linphone/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-22 11:46:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-22 11:46:18 +0000
commite3497d3f3f15efeb638571050a1aa332253f3095 (patch)
treefd96fbba1e55b34a425e5fe1917a00d2d4468f5a /net/linphone/Makefile
parentcb7c04b5742eab7205a5a1dac0ac92ea9ee2bbb4 (diff)
downloadports-e3497d3f3f15efeb638571050a1aa332253f3095.tar.gz
ports-e3497d3f3f15efeb638571050a1aa332253f3095.zip
Notes
Diffstat (limited to 'net/linphone/Makefile')
-rw-r--r--net/linphone/Makefile36
1 files changed, 3 insertions, 33 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 7f388c16a773..77a019c51269 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -5,40 +5,10 @@
# $FreeBSD$
#
-PORTNAME= ${LINPHONE_PORTNAME}
-PORTVERSION= ${LINPHONE_PORTVERSION}
-PORTREVISION= ${LINPHONE_PORTREVISION}
-PORTEPOCH= ${LINPHONE_PORTEPOCH}
CATEGORIES= net gnome
-MASTER_SITES= ${LINPHONE_MASTER_SITES}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A web phone that supports SIP protocol
+LINPHONE_GUI= yes
-LIB_DEPENDS= linphone.4:${PORTSDIR}/net/linphone-base
+MASTERDIR= ${.CURDIR}/../../net/linphone-base
-USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnomepanel
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --disable-ipv6 --disable-gtk-doc \
- --with-speex=${LOCALBASE} --with-osip=${LOCALBASE}
-MAKE_ENV= SUBDIRS="pixmaps gnome"
-
-MAN1= linphone.1
-
-CFLAGS+= -DPACKAGE_LOCALE_DIR='\"${LOCALBASE}/share/locale\"' \
- -DPACKAGE_DATA_DIR='\"${PREFIX}/share/gnome\"' \
- -DPACKAGE_SOUND_DIR='\"${LOCALBASE}/share/linphone/sounds\"'
-
-.include "${.CURDIR}/../../net/linphone-base/Makefile.common"
-.include <bsd.port.pre.mk>
-
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/share/C/linphone.1 ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/share/linphone.desktop \
- ${PREFIX}/share/gnome/applications
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"