aboutsummaryrefslogtreecommitdiff
path: root/net/linphone/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-01-19 21:01:51 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-01-19 21:01:51 +0000
commit51d006637b167755763aca7016b62f0649d481fd (patch)
treeb6b0bdbd7590b3ac3970efd54a58446abc4bad81 /net/linphone/Makefile
parentdb706306e404ab792c8d263e6101c8267844d2c7 (diff)
Add linphone 0.9.1, a web phone that supports SIP protocol.
Notes
Notes: svn path=/head/; revision=73565
Diffstat (limited to 'net/linphone/Makefile')
-rw-r--r--net/linphone/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
new file mode 100644
index 000000000000..805daf38c4f8
--- /dev/null
+++ b/net/linphone/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linphone
+# Date created: 30 December 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linphone
+PORTVERSION= 0.9.1
+CATEGORIES= net
+MASTER_SITES= http://savannah.gnu.org/download/linphone/${PORTVERSION}/sources/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= osip.0:${PORTSDIR}/net/libosip
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix libpanel
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= speexdec.1 speexenc.1
+
+.include <bsd.port.mk>