aboutsummaryrefslogtreecommitdiff
path: root/net/linphone
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-05-16 20:31:05 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-05-16 20:31:05 +0000
commit341ae95f0ff751494e06b082f28cc2ee0a37a015 (patch)
treef0b279a9dd3c5fb771f249c9feca6de8ebcc430c /net/linphone
parentd20441355478abe23b5793ad736b8530ad170808 (diff)
downloadports-341ae95f0ff751494e06b082f28cc2ee0a37a015.tar.gz
ports-341ae95f0ff751494e06b082f28cc2ee0a37a015.zip
Notes
Diffstat (limited to 'net/linphone')
-rw-r--r--net/linphone/Makefile2
-rw-r--r--net/linphone/distinfo4
-rw-r--r--net/linphone/files/patch-gtk-main.c26
-rw-r--r--net/linphone/files/patch-gtk-status_icon.c19
-rw-r--r--net/linphone/pkg-plist6
5 files changed, 51 insertions, 6 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 601ecf68e95c..589102db85df 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= linphone
-PORTVERSION= 3.8.1
+PORTVERSION= 3.8.2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/3.8.x/sources
diff --git a/net/linphone/distinfo b/net/linphone/distinfo
index 3fcec6661048..78d648101406 100644
--- a/net/linphone/distinfo
+++ b/net/linphone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (linphone-3.8.1.tar.gz) = 8d45bc9ec9a795a29bfdbf60c665bdfa81b46f3c83e870d50ad7c3f25156bca7
-SIZE (linphone-3.8.1.tar.gz) = 15327283
+SHA256 (linphone-3.8.2.tar.gz) = a14a228fe0f7cd9918777558f8272690a6d7541f262a593893eb447b500fec6d
+SIZE (linphone-3.8.2.tar.gz) = 15366935
diff --git a/net/linphone/files/patch-gtk-main.c b/net/linphone/files/patch-gtk-main.c
new file mode 100644
index 000000000000..cb511cc2e03c
--- /dev/null
+++ b/net/linphone/files/patch-gtk-main.c
@@ -0,0 +1,26 @@
+--- gtk/main.c.orig 2015-05-13 14:47:31 UTC
++++ gtk/main.c
+@@ -1919,9 +1919,7 @@ void linphone_gtk_log_handler(OrtpLogLev
+ if (verbose){
+ const char *lname="undef";
+ char *msg;
+-#if defined(__linux) || defined(__APPLE__)
+ va_list cap;/*copy of our argument list: a va_list cannot be re-used (SIGSEGV on linux 64 bits)*/
+-#endif
+ switch(lev){
+ case ORTP_DEBUG:
+ lname="debug";
+@@ -1941,13 +1939,9 @@ void linphone_gtk_log_handler(OrtpLogLev
+ default:
+ g_error("Bad level !");
+ }
+-#if defined(__linux) || defined(__APPLE__)
+ va_copy(cap,args);
+ msg=g_strdup_vprintf(fmt,cap);
+ va_end(cap);
+-#else
+- msg=g_strdup_vprintf(fmt,args);
+-#endif
+ fprintf(stdout,"linphone-%s : %s\n",lname,msg);
+ ortp_free(msg);
+ }
diff --git a/net/linphone/files/patch-gtk-status_icon.c b/net/linphone/files/patch-gtk-status_icon.c
new file mode 100644
index 000000000000..9d5ad0bdd9da
--- /dev/null
+++ b/net/linphone/files/patch-gtk-status_icon.c
@@ -0,0 +1,19 @@
+--- gtk/status_icon.c.orig 2015-05-13 14:47:31 UTC
++++ gtk/status_icon.c
+@@ -25,7 +25,6 @@ Foundation, Inc., 59 Temple Place - Suit
+ #endif
+
+ #if !defined(WIN32) && !defined(__APPLE__) && GLIB_CHECK_VERSION(2, 26, 0)
+-#define STATUS_NOTIFIER_IS_USABLE 1
+ #endif
+
+ #include "status_notifier.h"
+@@ -195,7 +194,7 @@ static LinphoneStatusIcon *_linphone_sta
+ }
+
+ static void _linphone_status_icon_free(LinphoneStatusIcon *obj) {
+- if(obj->desc->uninit) obj->desc->uninit(obj->data);
++ if(obj->desc->uninit) obj->desc->uninit(obj);
+ if(obj->params) linphone_status_icon_params_unref(obj->params);
+ g_free(obj);
+ }
diff --git a/net/linphone/pkg-plist b/net/linphone/pkg-plist
index 6e73229b8e4f..2d52fc3b50ea 100644
--- a/net/linphone/pkg-plist
+++ b/net/linphone/pkg-plist
@@ -1,4 +1,4 @@
-bin/auto_answer
+bin/lp-autoanswer
bin/linphone
bin/linphonec
bin/linphonecsh
@@ -20,8 +20,8 @@ include/linphone/lpconfig.h
include/linphone/sipsetup.h
include/linphone/xml2lpc.h
lib/liblinphone.so
-lib/liblinphone.so.6
-lib/liblinphone.so.6.0.0
+lib/liblinphone.so.7
+lib/liblinphone.so.7.0.0
libdata/pkgconfig/linphone.pc
man/cs/man1/linphone.1.gz
man/cs/man1/linphonec.1.gz