aboutsummaryrefslogtreecommitdiff
path: root/net/linphone
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-16 19:00:51 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-16 19:00:51 +0000
commit0cb631680c0db01480dcd8c34c0d9e27567e9bc0 (patch)
tree72689a3dcc684e3239e97736f1c203de018806a0 /net/linphone
parent18641c2a3611b33d237053275e00858f07cabb1e (diff)
downloadports-0cb631680c0db01480dcd8c34c0d9e27567e9bc0.tar.gz
ports-0cb631680c0db01480dcd8c34c0d9e27567e9bc0.zip
Notes
Diffstat (limited to 'net/linphone')
-rw-r--r--net/linphone/Makefile19
-rw-r--r--net/linphone/distinfo4
-rw-r--r--net/linphone/files/patch-configure20
-rw-r--r--net/linphone/files/patch-coreapi__presence.c15
-rw-r--r--net/linphone/pkg-plist13
5 files changed, 44 insertions, 27 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 187d7fa4f05f..7e9ed0adcf5a 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= linphone
-PORTVERSION= 3.7.0
-PORTREVISION= 3
+PORTVERSION= 3.8.1
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= SAVANNAH/linphone/3.7.x/sources
+MASTER_SITES= SAVANNAH/linphone/3.8.x/sources
MAINTAINER= tijl@FreeBSD.org
COMMENT= SIP client supporting voice/video calls and text messaging
@@ -13,28 +12,30 @@ COMMENT= SIP client supporting voice/video calls and text messaging
LIB_DEPENDS= libbellesip.so:${PORTSDIR}/net/belle-sip \
libmediastreamer_base.so:${PORTSDIR}/net/mediastreamer \
libortp.so:${PORTSDIR}/net/ortp \
+ libpolarssl.so.8:${PORTSDIR}/security/polarssl13 \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
CONFLICTS_INSTALL= linphone-base-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-deplibs-link --disable-speex --disable-strict \
- --disable-tutorials \
+CONFIGURE_ARGS= --disable-deplibs-link --disable-silent-rules \
+ --disable-speex --disable-strict --disable-tutorials \
--enable-external-mediastreamer --enable-external-ortp \
+ --enable-lime --with-polarssl=${LOCALBASE} \
--with-readline=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig readline:port
USE_GNOME= gtk20 intltool libxml2
USE_LDCONFIG= yes
-OPTIONS_DEFINE= IPV6 NLS NOTIFY UPNP VIDEO
+OPTIONS_DEFINE= NLS NOTIFY UPNP VIDEO
OPTIONS_DEFAULT=NOTIFY UPNP VIDEO
OPTIONS_SUB= yes
-IPV6_CONFIGURE_ENABLE= ipv6
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
@@ -51,10 +52,6 @@ CONFIGURE_ARGS+=--enable-debug
.endif
post-patch:
- @${REINPLACE_CMD} '/linphonec_LDADD =/s/=/= $$(MEDIASTREAMER_LIBS)/' \
- ${WRKSRC}/console/Makefile.in
- @${REINPLACE_CMD} '/linphone_LDADD =/s/=/= $$(MEDIASTREAMER_LIBS)/' \
- ${WRKSRC}/gtk/Makefile.in
.for l in C fr it ja
@${REINPLACE_CMD} '/^install-data-local:/,/^$$/d' \
${WRKSRC}/share/$l/Makefile.in
diff --git a/net/linphone/distinfo b/net/linphone/distinfo
index e85094e3cded..3fcec6661048 100644
--- a/net/linphone/distinfo
+++ b/net/linphone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (linphone-3.7.0.tar.gz) = ff792b1cfc132fc4a54ae6c861c99d4139ec6f4b8ff4092ea2ce1e19d44c151c
-SIZE (linphone-3.7.0.tar.gz) = 12090691
+SHA256 (linphone-3.8.1.tar.gz) = 8d45bc9ec9a795a29bfdbf60c665bdfa81b46f3c83e870d50ad7c3f25156bca7
+SIZE (linphone-3.8.1.tar.gz) = 15327283
diff --git a/net/linphone/files/patch-configure b/net/linphone/files/patch-configure
index d97d2dd4c993..a92ea8b43140 100644
--- a/net/linphone/files/patch-configure
+++ b/net/linphone/files/patch-configure
@@ -1,8 +1,8 @@
---- configure.orig
+--- configure.orig 2015-04-02 09:04:58 UTC
+++ configure
-@@ -19486,12 +19486,6 @@
- ;;
- esac
+@@ -20382,12 +20382,6 @@ $as_echo "#define HAVE_NOTIFY1 1" >>conf
+ fi
+ fi
-case "$host_os" in
- *freebsd*)
@@ -13,12 +13,12 @@
case "$host_cpu" in
*arm*)
-@@ -20993,7 +20987,7 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
+@@ -22149,7 +22143,7 @@ fi
+ fi
+ if test "$found_sqlite" = "yes"; then
- SQLITE3_CFLAGS+="-DMSG_STORAGE_ENABLED"
+ SQLITE3_CFLAGS="$SQLITE3_CFLAGS -DMSG_STORAGE_ENABLED"
-
-
- enable_msg_storage=true
+ if test "$build_macos" = "yes" -o "$ios_found" = "yes"; then
+ SQLITE3_LIBS+=" -liconv"
+ fi
diff --git a/net/linphone/files/patch-coreapi__presence.c b/net/linphone/files/patch-coreapi__presence.c
index 95829fe4a610..e685d5bb6028 100644
--- a/net/linphone/files/patch-coreapi__presence.c
+++ b/net/linphone/files/patch-coreapi__presence.c
@@ -1,11 +1,18 @@
---- coreapi/presence.c.orig
+--- coreapi/presence.c.orig 2015-04-02 09:04:01 UTC
+++ coreapi/presence.c
-@@ -167,7 +167,7 @@
- ms_error("mktime() failed: %s", strerror(errno));
+@@ -164,12 +164,12 @@ static time_t parse_timestamp(const char
+ ret.tm_mon--;
+ ret.tm_year -= 1900;
+ ret.tm_isdst = 0;
+- seconds = mktime(&ret);
++ seconds = timegm(&ret);
+ if (seconds == (time_t)-1) {
+- ms_error("mktime() failed: %s", strerror(errno));
++ ms_error("timegm() failed: %s", strerror(errno));
return (time_t)-1;
}
- return seconds - timezone;
+ return seconds;
}
- static char * timestamp_to_string(time_t timestamp) {
+ char * linphone_timestamp_to_rfc3339_string(time_t timestamp) {
diff --git a/net/linphone/pkg-plist b/net/linphone/pkg-plist
index fda482996e91..6e73229b8e4f 100644
--- a/net/linphone/pkg-plist
+++ b/net/linphone/pkg-plist
@@ -1,10 +1,16 @@
+bin/auto_answer
bin/linphone
bin/linphonec
bin/linphonecsh
bin/lp-gen-wrappers
bin/lpc2xml_test
bin/xml2lpc_test
+include/linphone/buffer.h
+include/linphone/call_log.h
+include/linphone/call_params.h
+include/linphone/content.h
include/linphone/event.h
+include/linphone/linphone_tunnel.h
include/linphone/linphonecore.h
include/linphone/linphonecore_utils.h
include/linphone/linphonefriend.h
@@ -24,9 +30,13 @@ man/man1/linphone.1.gz
man/man1/linphonec.1.gz
man/man1/linphonecsh.1.gz
man/man1/sipomatic.1.gz
+share/appdata/linphone.appdata.xml
+share/applications/audio-assistant.desktop
share/applications/linphone.desktop
+share/icons/hicolor/48x48/apps/linphone.png
%%DATADIR%%/COPYING
%%DATADIR%%/about.ui
+%%DATADIR%%/audio_assistant.ui
%%DATADIR%%/buddylookup.ui
%%DATADIR%%/call_logs.ui
%%DATADIR%%/call_statistics.ui
@@ -45,6 +55,7 @@ share/applications/linphone.desktop
%%DATADIR%%/stock_people.png
%%DATADIR%%/tunnel_config.ui
%%DATADIR%%/waiting.ui
+%%NLS%%share/locale/ar/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/cs/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/de/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/es/LC_MESSAGES/linphone.mo
@@ -60,6 +71,7 @@ share/applications/linphone.desktop
%%NLS%%share/locale/ru/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/sr/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/sv/LC_MESSAGES/linphone.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/linphone.mo
share/pixmaps/linphone/active_chat.png
@@ -99,6 +111,7 @@ share/pixmaps/linphone/stopcall-red.png
share/pixmaps/linphone/stopcall-small.png
share/sounds/linphone/hello16000.wav
share/sounds/linphone/hello8000.wav
+share/sounds/linphone/incoming_chat.wav
share/sounds/linphone/ringback.wav
share/sounds/linphone/rings/bigben.wav
share/sounds/linphone/rings/oldphone-mono-30s.caf