aboutsummaryrefslogtreecommitdiff
path: root/net/lmd
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-24 09:54:52 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-24 09:54:52 +0000
commit4e7785c79dc2fd5b3ad8ee12022ac8a888dd1eea (patch)
tree9d7e2e11e2fa76ed70696a9e844b0ccc4b264dc9 /net/lmd
parenta69387c6d80c9ae61463733fa99be7e331e185cf (diff)
downloadports-4e7785c79dc2fd5b3ad8ee12022ac8a888dd1eea.tar.gz
ports-4e7785c79dc2fd5b3ad8ee12022ac8a888dd1eea.zip
Notes
Diffstat (limited to 'net/lmd')
-rw-r--r--net/lmd/Makefile10
-rw-r--r--net/lmd/files/patch-modules_check::Makefile6
-rw-r--r--net/lmd/pkg-plist8
3 files changed, 14 insertions, 10 deletions
diff --git a/net/lmd/Makefile b/net/lmd/Makefile
index a6b972a9d850..ddf3a9a82a03 100644
--- a/net/lmd/Makefile
+++ b/net/lmd/Makefile
@@ -20,8 +20,6 @@ MODULES= ldd_http_module.so
DOCS= INSTALL LICENSE README
PKGMESSAGE= ${WRKDIR}/pkg-message
-MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
-
post-patch:
${REINPLACE_CMD} -i.bak -e 's|varargs.h|stdarg.h|' \
${WRKSRC}/chkmodules.h \
@@ -50,4 +48,10 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64"
+MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\" -fPIC"
+.else
+MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/lmd/files/patch-modules_check::Makefile b/net/lmd/files/patch-modules_check::Makefile
index 7ef750a84888..312f1b56ce84 100644
--- a/net/lmd/files/patch-modules_check::Makefile
+++ b/net/lmd/files/patch-modules_check::Makefile
@@ -1,5 +1,5 @@
---- modules_check/Makefile.orig Mon Nov 26 07:31:09 2001
-+++ modules_check/Makefile Tue May 14 14:16:16 2002
+--- modules_check/Makefile.orig Sun Nov 25 17:31:09 2001
++++ modules_check/Makefile Sat Feb 21 14:25:58 2004
@@ -1,14 +1,15 @@
# If you want to debug lmd comment out this line and recompile it
# Launch lmd with -v option to see debug messages
@@ -16,7 +16,7 @@
socket.o:
- gcc -c ../socket.c -o socket.o
-+ ${CC} -c ../socket.c -o socket.o
++ ${CC} ${OPTS} -c ../socket.c -o socket.o
clean:
rm *.so *.o
diff --git a/net/lmd/pkg-plist b/net/lmd/pkg-plist
index 6bc546004a57..a4a274a66212 100644
--- a/net/lmd/pkg-plist
+++ b/net/lmd/pkg-plist
@@ -2,7 +2,7 @@ sbin/lmd
etc/rc.d/lmd.sh
etc/lmd.conf.sample
lib/ldd_http_module.so
-%%PORTDOCS%%share/doc/lmd/README
-%%PORTDOCS%%share/doc/lmd/INSTALL
-%%PORTDOCS%%share/doc/lmd/LICENSE
-%%PORTDOCS%%@dirrm share/doc/lmd
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%@dirrm %%DOCSDIR%%