aboutsummaryrefslogtreecommitdiff
path: root/net/luasocket/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-15 10:58:52 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-15 10:58:52 +0000
commit340400ffaf677d5d9c9a2e607dd5e362edd57cb2 (patch)
treef6f6930e7a2830cbe248e3087413df9d73df8204 /net/luasocket/Makefile
parent8e14c1122788455715895371b9272f605321889c (diff)
downloadports-340400ffaf677d5d9c9a2e607dd5e362edd57cb2.tar.gz
ports-340400ffaf677d5d9c9a2e607dd5e362edd57cb2.zip
Notes
Diffstat (limited to 'net/luasocket/Makefile')
-rw-r--r--net/luasocket/Makefile31
1 files changed, 9 insertions, 22 deletions
diff --git a/net/luasocket/Makefile b/net/luasocket/Makefile
index e780e68ede3a..f0121466738e 100644
--- a/net/luasocket/Makefile
+++ b/net/luasocket/Makefile
@@ -14,35 +14,22 @@ MASTER_SITES= http://luaforge.net/frs/download.php/1097/
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= IPv4 Sockets support for the Lua language
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
- ${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
USE_GMAKE= yes
+USE_LUA= 5.0
+LUA_COMPS= lua compat51
+
+COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && ${MAKE} -V WRKSRC)`
+MAKE_ENV= COMPATDIR="${COMPAT_SRC}"
post-extract:
- @ ${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
- @ ${RM} ${WRKSRC}/src/compat-5.1r4/compat-5.1.o
+ @${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/luasocket
- @${INSTALL_DATA} ${WRKSRC}/doc/dns.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/ftp.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/home.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/http.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/installation.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/introduction.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/ltn12.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/luasocket.png ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/mime.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/reference.css ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/reference.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/smtp.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/socket.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/tcp.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/udp.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/url.html ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
.include <bsd.port.mk>