aboutsummaryrefslogtreecommitdiff
path: root/net/lvwimax/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2010-11-30 07:25:00 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2010-11-30 07:25:00 +0000
commitd7f57ddc0c844bc9085a6206f9f3d93f6718093c (patch)
treebf0a8b826b61b1fc1f5dd117dde8908a4013bf32 /net/lvwimax/Makefile
parent61a794b4fadc4c489e1bdb98ed0770384b592d01 (diff)
A userland driver for wimax modems:
. Samsung SWC-U200; . Samsung SWC-E100.
Notes
Notes: svn path=/head/; revision=265433
Diffstat (limited to 'net/lvwimax/Makefile')
-rw-r--r--net/lvwimax/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/lvwimax/Makefile b/net/lvwimax/Makefile
new file mode 100644
index 000000000000..66950c962e3c
--- /dev/null
+++ b/net/lvwimax/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: net/lvwimax
+# Date created: 2010-06-04
+# Whom: bsam
+#
+# $FreeBSD$
+#
+
+PORTNAME= lvwimax
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.ipt.ru/pub/download/ \
+ ${MASTER_SITE_LOCAL}
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= A userland driver for Samsung WiMAX modems
+
+LICENSE= GPLv2
+
+USE_RC_SUBR= lvwimax
+
+PLIST_DIRSTRY= etc/devd
+PLIST_FILES= etc/devd/lvwimax.conf sbin/lvwimax
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+IGNORE= requires FreeBSD 8.0-RELEASE or later for libusb-1.0 support
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc/devd
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ < ${FILESDIR}/lvwimax.conf.in > ${WRKDIR}/lvwimax.conf
+ ${INSTALL_DATA} "${WRKDIR}/lvwimax.conf" ${PREFIX}/etc/devd
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>