aboutsummaryrefslogtreecommitdiff
path: root/net/mDNSResponder/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-08-01 19:12:17 +0000
committerRene Ladan <rene@FreeBSD.org>2010-08-01 19:12:17 +0000
commitf72ac1ec8d9cc365740b26a3f01353cc9dcbff2f (patch)
treecb2bc97a8c35991eafe3927b1caab8cd2b3a9b91 /net/mDNSResponder/Makefile
parentac12eb28288683d81c59665c87dce571bc40cbe2 (diff)
downloadports-f72ac1ec8d9cc365740b26a3f01353cc9dcbff2f.tar.gz
ports-f72ac1ec8d9cc365740b26a3f01353cc9dcbff2f.zip
Notes
Diffstat (limited to 'net/mDNSResponder/Makefile')
-rw-r--r--net/mDNSResponder/Makefile41
1 files changed, 16 insertions, 25 deletions
diff --git a/net/mDNSResponder/Makefile b/net/mDNSResponder/Makefile
index 13819e248851..896540ca27ba 100644
--- a/net/mDNSResponder/Makefile
+++ b/net/mDNSResponder/Makefile
@@ -7,34 +7,26 @@
#
PORTNAME= mDNSResponder
-PORTVERSION= 214
+PORTVERSION= 214.3
CATEGORIES= net dns
MASTER_SITES= http://opensource.apple.com/tarballs/mDNSResponder/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@sunpoet.net
COMMENT= Apple's mDNSResponder
-MAKE_JOBS_UNSAFE= yes
-
-USE_BISON= build
-USE_LDCONFIG= YES
-
-USE_GMAKE= YES
-USE_RC_SUBR= mdnsd.sh
-MAKE_ARGS+= os=freebsd LOCALBASE=${PREFIX} MANPATH=${MANPREFIX}/man
BUILD_WRKSRC= ${WRKSRC}/mDNSPosix
INSTALL_WRKSRC= ${WRKSRC}/mDNSPosix
-EXTRA_PROGS_BIN=mDNSClientPosix \
- mDNSIdentify \
- mDNSNetMonitor \
- mDNSProxyResponderPosix \
- mDNSResponderPosix
-EXTRA_PROGS_SBIN=dnsextd
+MAKE_ARGS+= os=freebsd LOCALBASE=${PREFIX} MANPATH=${MANPREFIX}/man
MAKE_JOBS_UNSAFE= yes
+USE_BISON= build
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_RC_SUBR= mdnsd
+EXTRA_PROGS_BIN=mDNSClientPosix mDNSIdentify mDNSNetMonitor \
+ mDNSProxyResponderPosix mDNSResponderPosix
+EXTRA_PROGS_SBIN=dnsextd
EXTRAMAN8= dnsextd.8 mDNSResponderPosix.8
-
MAN8= mdnsd.8 ${EXTRAMAN8}
CONFLICTS= avahi-libdns-[0-9]*
@@ -46,21 +38,20 @@ BROKEN= Does not compile on alpha
.endif
post-patch:
- ${MV} ${WRKSRC}/mDNSShared/mDNSResponder.8 \
+ @${MV} ${WRKSRC}/mDNSShared/mDNSResponder.8 \
${WRKSRC}/mDNSShared/mDNSResponderPosix.8
+
pre-build:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
-e 's|mDNSResponder.8|mDNSResponderPosix.8|g' \
${WRKSRC}/mDNSPosix/Makefile
post-install:
- cd ${INSTALL_WRKSRC}/build/prod && \
+ @cd ${INSTALL_WRKSRC}/build/prod && \
${INSTALL_PROGRAM} ${EXTRA_PROGS_BIN} ${PREFIX}/bin && \
${INSTALL_PROGRAM} ${EXTRA_PROGS_SBIN} ${PREFIX}/sbin
-. for section in 1 2 3 4 5 6 7 8
-. for page in ${EXTRAMAN${section}}
- ${INSTALL_MAN} ${WRKSRC}/mDNSShared/${page} ${MAN${section}PREFIX}/man/man${page:E}/
-. endfor
-. endfor
+.for page in ${EXTRAMAN8}
+ @${INSTALL_MAN} ${WRKSRC}/mDNSShared/${page} ${MAN8PREFIX}/man/man8/
+.endfor
.include <bsd.port.post.mk>