aboutsummaryrefslogtreecommitdiff
path: root/net/mDNSResponder
diff options
context:
space:
mode:
authorAlfred Perlstein <alfred@FreeBSD.org>2004-03-03 02:31:36 +0000
committerAlfred Perlstein <alfred@FreeBSD.org>2004-03-03 02:31:36 +0000
commitc706b9ff5b47501efa8cd885c85720b3eaa89167 (patch)
tree05e0390e734c63338cb67c100a8cd6d3550de661 /net/mDNSResponder
parent5e935a82ae35a9cec57d484ab4b6870c36201606 (diff)
Apple's mDNSResponder:
What is mDNSResponder? ---------------------- The mDNSResponder project is a component of Rendezvous, Apple's ease-of-use IP networking initiative: <http://developer.apple.com/macosx/rendezvous/index.html> Apple's Rendezvous software derives from the ongoing standardization work of the IETF Zero Configuration Networking Working Group: <http://zeroconf.org/> See rest of readme for other juicy details. Secial thanks to Apple for making this code available as well as to the various people inside Apple that made this possible.
Notes
Notes: svn path=/head/; revision=102780
Diffstat (limited to 'net/mDNSResponder')
-rw-r--r--net/mDNSResponder/distinfo2
-rw-r--r--net/mDNSResponder/files/patch-mDNSPosix::Makefile78
-rw-r--r--net/mDNSResponder/pkg-descr3
-rw-r--r--net/mDNSResponder/pkg-plist4
4 files changed, 87 insertions, 0 deletions
diff --git a/net/mDNSResponder/distinfo b/net/mDNSResponder/distinfo
new file mode 100644
index 000000000000..fa0392e5f8e3
--- /dev/null
+++ b/net/mDNSResponder/distinfo
@@ -0,0 +1,2 @@
+MD5 (mDNSResponder-62.tar.gz) = 345da920880bcc028eacf4d11d96cc61
+SIZE (mDNSResponder-62.tar.gz) = 767255
diff --git a/net/mDNSResponder/files/patch-mDNSPosix::Makefile b/net/mDNSResponder/files/patch-mDNSPosix::Makefile
new file mode 100644
index 000000000000..7609598edeb0
--- /dev/null
+++ b/net/mDNSResponder/files/patch-mDNSPosix::Makefile
@@ -0,0 +1,78 @@
+--- mDNSPosix/Makefile.old Wed Mar 3 01:39:05 2004
++++ mDNSPosix/Makefile Wed Mar 3 01:54:39 2004
+@@ -137,6 +137,7 @@
+ STRIP = strip -S
+ endif
+
++INSTBASE=/usr
+ # Configure per-OS peculiarities
+ ifeq ($(os),solaris)
+ CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME -lsocket -lnsl
+@@ -149,6 +150,11 @@
+ LDCONFIG = ldconfig
+ else
+ ifeq ($(os),freebsd)
++ifndef LOCALBASE
++LOCALBASE=/usr/local
++endif
++INSTSCRIPT=mdns.sh
++INSTBASE=$(LOCALBASE)
+ CFLAGS_OS =
+ LDCONFIG = ldconfig
+ else
+@@ -177,6 +183,7 @@
+ endif
+ endif
+ endif
++INSTSCRIPT?=mdns
+
+ ifeq ($(HAVE_IPV6),1)
+ CFLAGS_OS += -DHAVE_IPV6=1
+@@ -197,7 +204,7 @@
+ RUNLEVELSCRIPTSDIR = /etc
+ else
+ # else install into /etc/rc.d/ (*BSD)
+-STARTUPSCRIPTDIR = /etc/rc.d
++STARTUPSCRIPTDIR = $(INSTBASE)/etc/rc.d
+ endif
+ endif
+
+@@ -246,30 +253,30 @@
+ #############################################################################
+
+ # The Install targets place built stuff in their proper places
+-InstalledDaemon: /usr/sbin/mdnsd
++InstalledDaemon: $(INSTBASE)/sbin/mdnsd
+ @echo $< " installed"
+
+-InstalledLib: /usr/lib/libmdns.$(LDSUFFIX).$(LIBVERS) /usr/include/dns_sd.h
++InstalledLib: $(INSTBASE)/lib/libmdns.$(LDSUFFIX).$(LIBVERS) $(INSTBASE)/include/dns_sd.h
+ @echo $< " installed"
+
+-InstalledStartup: $(STARTUPSCRIPTDIR)/mdns
++InstalledStartup: $(STARTUPSCRIPTDIR)/$(INSTSCRIPT)
+ @echo $< " installed"
+
+-/usr/sbin/mdnsd: $(BUILDDIR)/mdnsd
++$(INSTBASE)/sbin/mdnsd: $(BUILDDIR)/mdnsd
+ $(CP) $< $@
+
+-/usr/lib/libmdns.$(LDSUFFIX).$(LIBVERS): $(BUILDDIR)/libmdns.$(LDSUFFIX)
++$(INSTBASE)/lib/libmdns.$(LDSUFFIX).$(LIBVERS): $(BUILDDIR)/libmdns.$(LDSUFFIX)
+ $(CP) $< $@
+- $(LN) $@ /usr/lib/libmdns.$(LDSUFFIX)
++ $(LN) $@ $(INSTBASE)/lib/libmdns.$(LDSUFFIX)
+ ifdef LDCONFIG
+ # -m means 'merge into existing database', -R means 'rescan directories'
+ $(LDCONFIG) -mR
+ endif
+
+-/usr/include/dns_sd.h: $(SHAREDDIR)/dns_sd.h
++$(INSTBASE)/include/dns_sd.h: $(SHAREDDIR)/dns_sd.h
+ $(CP) $< $@
+
+-$(STARTUPSCRIPTDIR)/mdns: mdnsd.sh $(STARTUPSCRIPTDIR)
++$(STARTUPSCRIPTDIR)/$(INSTSCRIPT): mdnsd.sh $(STARTUPSCRIPTDIR)
+ $(CP) $< $@
+ chmod ugo+x $@
+ ifdef RUNLEVELSCRIPTSDIR
diff --git a/net/mDNSResponder/pkg-descr b/net/mDNSResponder/pkg-descr
new file mode 100644
index 000000000000..a04ce7f095bf
--- /dev/null
+++ b/net/mDNSResponder/pkg-descr
@@ -0,0 +1,3 @@
+The mDNSResponder project is a component of Rendezvous,
+Apple's ease-of-use IP networking initiative:
+<http://developer.apple.com/macosx/rendezvous/index.html>
diff --git a/net/mDNSResponder/pkg-plist b/net/mDNSResponder/pkg-plist
new file mode 100644
index 000000000000..67c2c512f764
--- /dev/null
+++ b/net/mDNSResponder/pkg-plist
@@ -0,0 +1,4 @@
+etc/rc.d/mdns.sh
+lib/libmdns.so
+lib/libmdns.so.1
+sbin/mdnsd