aboutsummaryrefslogtreecommitdiff
path: root/net/mediastreamer
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-22 15:33:29 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-22 15:33:29 +0000
commit626c664682a7551de34d48b524b3ede490166ee8 (patch)
treed975b350993430f0ac43224a9c41aec49845ceae /net/mediastreamer
parentec1c35f87c9270cc2c890591e53d6650be30ef3b (diff)
downloadports-626c664682a7551de34d48b524b3ede490166ee8.tar.gz
ports-626c664682a7551de34d48b524b3ede490166ee8.zip
Notes
Diffstat (limited to 'net/mediastreamer')
-rw-r--r--net/mediastreamer/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index dfb6015d9206..1a930bdedf2b 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mediastreamer
PORTVERSION= 2.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/mediastreamer
@@ -18,23 +18,23 @@ LIB_DEPENDS= libortp.so:${PORTSDIR}/net/ortp
CONFLICTS_INSTALL= linphone-base-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa --disable-glx --disable-pulseaudio \
+CONFIGURE_ARGS= --disable-alsa --disable-pulseaudio \
--disable-silent-rules --disable-strict \
--with-gsm=${LOCALBASE} xxd_found=yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig
-USE_GNOME= gnomehier
+USE_GNOME= gnomehier intltool
USE_LDCONFIG= yes
OPTIONS_DEFINE= IPV6 NLS UPNP VIDEO
OPTIONS_GROUP= AUDIOOPT VIDEOOPT
OPTIONS_GROUP_AUDIOOPT= GSM OPUS SPANDSP SPEEX
-OPTIONS_GROUP_VIDEOOPT= FFMPEG THEORA V4L VPX XVIDEO
+OPTIONS_GROUP_VIDEOOPT= FFMPEG GLX THEORA V4L VPX XVIDEO
OPTIONS_DEFAULT= UPNP VIDEO \
GSM OPUS SPANDSP SPEEX \
- FFMPEG THEORA V4L VPX XVIDEO
+ FFMPEG GLX THEORA V4L VPX XVIDEO
OPTIONS_SUB= yes
AUDIOOPT_DESC= Audio options
@@ -42,6 +42,9 @@ AUDIOOPT_DESC= Audio options
FFMPEG_CONFIGURE_ENABLE=ffmpeg
FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+GLX_CONFIGURE_ENABLE= glx
+GLX_USE= GL=glew
+
GSM_CONFIGURE_ENABLE= gsm
GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
@@ -49,7 +52,6 @@ IPV6_CONFIGURE_ENABLE= ipv6
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-NLS_USE= GNOME=intltool
OPUS_CONFIGURE_ENABLE= opus
OPUS_LIB_DEPENDS= libopus.so:${PORTSDIR}/audio/opus
@@ -88,4 +90,14 @@ post-patch:
@${REINPLACE_CMD} 's,gsm/gsm\.h,gsm.h,' \
${WRKSRC}/configure ${WRKSRC}/src/audiofilters/gsm.c
+pre-build:
+# Transform file to C array (similar to xxd -i from editors/vim)
+.for i in yuv2rgb.fs yuv2rgb.vs
+ (cd ${WRKSRC}/src && { \
+ ${ECHO_CMD} 'unsigned char ${i:S/./_/}[] = {' && \
+ /usr/bin/hexdump -v -e '" " 12/1 " 0x%02x," "\n" \
+ " 0x00 };\nunsigned int ${i:S/./_/}_len = %_Ad;"' ${i} | \
+ ${SED} 's/ 0x ,//g' ; } > ${i}.h)
+.endfor
+
.include <bsd.port.mk>