aboutsummaryrefslogtreecommitdiff
path: root/net/mediatomb/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:31 +0000
commitd78beb132cdff1572d8b545be1fb09eea396d6ae (patch)
tree3ae246ccbda59847628903cdf71a3645fe2d5a86 /net/mediatomb/Makefile
parent4d32bbcef6444fe1625b9b0a62da9c7aceadd457 (diff)
Notes
Diffstat (limited to 'net/mediatomb/Makefile')
-rw-r--r--net/mediatomb/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index 7885ee347fd8..7672b4d7fcc2 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -55,13 +55,15 @@ EXTERNAL_TRANSCODING_DESC= external transcoding support
ID3LIB_DESC= id3lib support
LIBEXTRACTOR_DESC= libextractor support
+SQLITE_USES= sqlite
+MYSQL_USES= mysql
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSQLITE}
CONFIGURE_ARGS+= --enable-sqlite3 \
--with-sqlite3-h="${LOCALBASE}/include" \
--with-sqlite3-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= libsqlite3.so:databases/sqlite3
.else
CONFIGURE_ARGS+= --disable-sqlite3
.endif
@@ -69,7 +71,6 @@ CONFIGURE_ARGS+= --disable-sqlite3
.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+= --enable-mysql \
--with-mysql-cfg="${LOCALBASE}/bin/mysql_config"
-USE_MYSQL= yes
.else
CONFIGURE_ARGS+= --disable-mysql
.endif