aboutsummaryrefslogtreecommitdiff
path: root/net/micro_inetd
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-15 14:13:10 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-15 14:13:10 +0000
commitb2ed23561fe3ba0b254e7e718492f2ca6e6b42a9 (patch)
treee10a0547c316f7beb376b07e2480a13597e7ada8 /net/micro_inetd
parent0dbd2ee84e92f2903659ae6ed3d4d7f4fb86a069 (diff)
downloadports-b2ed23561fe3ba0b254e7e718492f2ca6e6b42a9.tar.gz
ports-b2ed23561fe3ba0b254e7e718492f2ca6e6b42a9.zip
Notes
Diffstat (limited to 'net/micro_inetd')
-rw-r--r--net/micro_inetd/Makefile25
-rw-r--r--net/micro_inetd/distinfo3
-rw-r--r--net/micro_inetd/files/patch-Makefile24
-rw-r--r--net/micro_inetd/pkg-descr8
4 files changed, 60 insertions, 0 deletions
diff --git a/net/micro_inetd/Makefile b/net/micro_inetd/Makefile
new file mode 100644
index 000000000000..e2a6460b305e
--- /dev/null
+++ b/net/micro_inetd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: micro_inetd
+# Date created: 2006-08-13
+# Whom: Pankov Pavel <pankov_p@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= micro_inetd
+PORTVERSION= 2005.06.29
+CATEGORIES= net
+MASTER_SITES= http://www.acme.com/software/micro_inetd/
+DISTNAME= ${PORTNAME}_29jun2005
+
+MAINTAINER= pankov_p@mail.ru
+COMMENT= A inetd-like program intended for temporarily usage
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/micro_inetd
+MAN1= micro_inetd.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/micro_inetd ${TARGETDIR}/bin/micro_inetd
+ ${INSTALL_MAN} ${WRKSRC}/micro_inetd.1 ${MAN1PREFIX}/man/man1/micro_inetd.1
+
+.include <bsd.port.mk>
diff --git a/net/micro_inetd/distinfo b/net/micro_inetd/distinfo
new file mode 100644
index 000000000000..071fbee31944
--- /dev/null
+++ b/net/micro_inetd/distinfo
@@ -0,0 +1,3 @@
+MD5 (micro_inetd_29jun2005.tar.gz) = 515eb503e98d34c8beb7ed8df4123a0a
+SHA256 (micro_inetd_29jun2005.tar.gz) = b4e13e86fae75d929daa0992970f44a6e08b3abbd7bc9a5fa524ff9f4741f706
+SIZE (micro_inetd_29jun2005.tar.gz) = 5891
diff --git a/net/micro_inetd/files/patch-Makefile b/net/micro_inetd/files/patch-Makefile
new file mode 100644
index 000000000000..3006952bd161
--- /dev/null
+++ b/net/micro_inetd/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig Wed Jan 2 05:24:29 2002
++++ Makefile Tue Aug 15 14:43:17 2006
+@@ -5,16 +5,15 @@
+ #SYSV_LIBS = -lnsl -lsocket
+
+
+-CC = gcc
+-CFLAGS = -O
+-LDFLAGS = -s $(SYSV_LIBS)
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/local/man/man1
++CC?= gcc
++CFLAGS?= -O
++LDFLAGS?= -s $(SYSV_LIBS)
++BINDIR?= /usr/local/bin
++MANDIR?= /usr/local/man/man1
+
+ all: micro_inetd
+
+ micro_inetd: micro_inetd.c
+- $(CC) $(CFLAGS) micro_inetd.c $(LDFLAGS) -o micro_inetd
+
+ install: all
+ rm -f $(BINDIR)/micro_inetd
diff --git a/net/micro_inetd/pkg-descr b/net/micro_inetd/pkg-descr
new file mode 100644
index 000000000000..7ecbc32ab5ca
--- /dev/null
+++ b/net/micro_inetd/pkg-descr
@@ -0,0 +1,8 @@
+Like inetd, this program listens on the net for requests and spawns a
+server to handle them. However, it only handles one port and one
+program. Other limitations:
+* only 'stream' socket type
+* only 'nowait'
+* doesn't switch user-ids
+
+WWW: http://www.acme.com/software/micro_inetd/