aboutsummaryrefslogtreecommitdiff
path: root/net/micro_proxy
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-02 13:35:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-02 13:35:17 +0000
commit852d38311c031da8b06b59a2a1c6784e0e773179 (patch)
treec670c26689b76355380db6e7ccfe5f7768c24038 /net/micro_proxy
parent1c4823be1913baebd358a88cb13fadfdb82e7408 (diff)
downloadports-852d38311c031da8b06b59a2a1c6784e0e773179.tar.gz
ports-852d38311c031da8b06b59a2a1c6784e0e773179.zip
Notes
Diffstat (limited to 'net/micro_proxy')
-rw-r--r--net/micro_proxy/Makefile32
-rw-r--r--net/micro_proxy/distinfo2
-rw-r--r--net/micro_proxy/pkg-deinstall15
-rw-r--r--net/micro_proxy/pkg-descr11
-rw-r--r--net/micro_proxy/pkg-message18
5 files changed, 78 insertions, 0 deletions
diff --git a/net/micro_proxy/Makefile b/net/micro_proxy/Makefile
new file mode 100644
index 000000000000..13ef21e027c9
--- /dev/null
+++ b/net/micro_proxy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: micro_proxy
+# Date created: 2 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= micro_proxy
+PORTVERSION= 20021030
+CATEGORIES= net
+MASTER_SITES= http://www.acme.com/software/micro_proxy/
+DISTNAME= ${PORTNAME}_30oct2002
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A really small HTTP/HTTPS proxy
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= libexec/micro_proxy
+MAN8= micro_proxy.8
+
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}.o
+ ${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.o -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${MANPREFIX}/man/man8
+
+post-install:
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/micro_proxy/distinfo b/net/micro_proxy/distinfo
new file mode 100644
index 000000000000..8dfbe2fb0ecb
--- /dev/null
+++ b/net/micro_proxy/distinfo
@@ -0,0 +1,2 @@
+MD5 (micro_proxy_30oct2002.tar.gz) = d83288fbc61b73a9dc0f62a49c6f1ab2
+SIZE (micro_proxy_30oct2002.tar.gz) = 5822
diff --git a/net/micro_proxy/pkg-deinstall b/net/micro_proxy/pkg-deinstall
new file mode 100644
index 000000000000..954499641f94
--- /dev/null
+++ b/net/micro_proxy/pkg-deinstall
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case $2 in
+POST-DEINSTALL)
+cat << "EOF"
+===============================================================================
+Micro_proxy has been successfully deinstalled. If you ran it with inetd(8) make
+sure you remove all the manual configuration.
+===============================================================================
+EOF
+;;
+esac
diff --git a/net/micro_proxy/pkg-descr b/net/micro_proxy/pkg-descr
new file mode 100644
index 000000000000..209c7f5342a9
--- /dev/null
+++ b/net/micro_proxy/pkg-descr
@@ -0,0 +1,11 @@
+Microproxy is a very small Unix-based HTTP/HTTPS proxy. It runs from inetd,
+which means its performance is poor. But for low-traffic sites, it's quite
+adequate.
+
+It implements all the basic features of an HTTP/HTTPS proxy, including IPv6
+forwarding, in only 320 lines of code.
+
+WWW: http://www.acme.com/software/micro_proxy/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/net/micro_proxy/pkg-message b/net/micro_proxy/pkg-message
new file mode 100644
index 000000000000..83738e8a1d19
--- /dev/null
+++ b/net/micro_proxy/pkg-message
@@ -0,0 +1,18 @@
+===============================================================================
+
+Micro_proxy has been successfully installed. If you want to run micro_proxy
+with inetd add
+
+ webproxy 8080/tcp
+
+to services(5),
+
+ webproxy stream tcp nowait nobody %%PREFIX%%/libexec/micro_proxy -R 10000 micro_proxy
+
+to inetd.conf(5),
+
+ enable_inetd="YES"
+
+to rc.conf(5) and restart inetd(8). See micro_proxy(8) for more information.
+
+===============================================================================