aboutsummaryrefslogtreecommitdiff
path: root/net/minidlna/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2010-12-14 06:11:04 +0000
committerMikhail Teterin <mi@FreeBSD.org>2010-12-14 06:11:04 +0000
commit39faccbe393b2c31feb9510072b6407c40952953 (patch)
treeba56637458de9e66a6a66d2b24eebd1f9a58e0b9 /net/minidlna/Makefile
parentae08b48a275b7443447bcde65ce2716b243eea69 (diff)
downloadports-39faccbe393b2c31feb9510072b6407c40952953.tar.gz
ports-39faccbe393b2c31feb9510072b6407c40952953.zip
Notes
Diffstat (limited to 'net/minidlna/Makefile')
-rw-r--r--net/minidlna/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
new file mode 100644
index 000000000000..55ca58cab6b3
--- /dev/null
+++ b/net/minidlna/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: minidlna
+# Date created: 2010-06-13
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= minidlna
+PORTVERSION= 2010.12.12
+CATEGORIES= net multimedia www
+MASTER_SITES= http://aldan.algebra.com/~mi/
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Media-server compatible with "Digital Life Network Alliance"
+
+LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ exif:${PORTSDIR}/graphics/libexif \
+ id3tag:${PORTSDIR}/audio/libid3tag \
+ ogg:${PORTSDIR}/audio/libogg \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ FLAC:${PORTSDIR}/audio/flac \
+ avformat:${PORTSDIR}/multimedia/ffmpeg
+
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+MAKEFILE= ${FILESDIR}/BSDmakefile
+NO_WRKSUBDIR= yes
+MAKE_ENV+= FILESDIR="${FILESDIR}" INSTALL_DATA="${INSTALL_DATA}"
+EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude getifaddr.c
+
+PKGMESSAGE= ${WRKSRC}/pkg-message
+SUB_FILES+= pkg-message
+USE_RC_SUBR= minidlna.sh
+SUB_LIST+= USER=${USERS}
+
+USERS= dlna
+GROUPS= dlna
+
+post-install:
+ ${FMT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 801000
+EXTRA_PATCHES= ${FILESDIR}/scandir-patch
+.endif
+
+.include <bsd.port.post.mk>