aboutsummaryrefslogtreecommitdiff
path: root/net/minidlna
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-06-18 10:26:46 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-06-18 10:27:53 +0000
commitfd5e21bd97945073316f3a3fbd110c13ef3827ae (patch)
treeb6c08c563e9f384c694305cdc2b57ca937646255 /net/minidlna
parentc996e21d9a4bce39cddf953a6fe49127ed279259 (diff)
downloadports-fd5e21bd97945073316f3a3fbd110c13ef3827ae.tar.gz
ports-fd5e21bd97945073316f3a3fbd110c13ef3827ae.zip
Diffstat (limited to 'net/minidlna')
-rw-r--r--net/minidlna/Makefile2
-rw-r--r--net/minidlna/files/patch-metadata.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index 38d6d6a04493..5b7e6c81a60d 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -1,6 +1,6 @@
PORTNAME= minidlna
PORTVERSION= 1.3.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net multimedia www
MASTER_SITES= SF
diff --git a/net/minidlna/files/patch-metadata.c b/net/minidlna/files/patch-metadata.c
new file mode 100644
index 000000000000..32b4bde4729b
--- /dev/null
+++ b/net/minidlna/files/patch-metadata.c
@@ -0,0 +1,14 @@
+--- metadata.c.orig 2022-08-30 05:42:54 UTC
++++ metadata.c
+@@ -146,6 +146,11 @@ check_for_captions(const char *path, int64_t detailID)
+ strcpy(p, ".smi");
+ ret = access(file, R_OK);
+ }
++ if (ret != 0)
++ {
++ strcpy(p, ".ass");
++ ret = access(file, R_OK);
++ }
+
+ if (ret == 0)
+ {