aboutsummaryrefslogtreecommitdiff
path: root/net/minisapserver/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-11 05:44:12 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-11 05:44:12 +0000
commitdc3f24d64de2e1bb6322886788baee8308afce92 (patch)
tree6bbb7cc677e08d426a5a954bc0c37c1946cba217 /net/minisapserver/Makefile
parentb51a9346277733a010c62fc6ff38f1bb1b3a8405 (diff)
downloadports-dc3f24d64de2e1bb6322886788baee8308afce92.tar.gz
ports-dc3f24d64de2e1bb6322886788baee8308afce92.zip
Notes
Diffstat (limited to 'net/minisapserver/Makefile')
-rw-r--r--net/minisapserver/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/minisapserver/Makefile b/net/minisapserver/Makefile
index d0c1cdffff72..695d62052862 100644
--- a/net/minisapserver/Makefile
+++ b/net/minisapserver/Makefile
@@ -6,25 +6,27 @@
#
PORTNAME= minisapserver
-PORTVERSION= 0.2.4
+PORTVERSION= 0.3.0
CATEGORIES= net multimedia
-MASTER_SITES= http://download.videolan.org/pub/videolan/miniSAPserver/${PORTVERSION}/
-DISTNAME= miniSAPserver-${PORTVERSION}
+MASTER_SITES= http://downloads.videolan.org/pub/videolan/miniSAPserver/${PORTVERSION}/
MAINTAINER= ahze@FreeBSD.org
COMMENT= SAP and SLP announcement for the VLC Media Player
+USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
MAN1= sapserver.1
-PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
PLIST_FILES= bin/sapserver etc/sap.cfg-dist etc/rc.d/sapserver.sh
USE_RC_SUBR= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= SLP "Enable SLP support via openslp" off
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
.if defined(WITH_SLP)
LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
@@ -47,10 +49,6 @@ post-patch:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|; s|%%RC_SUBR%%|${RC_SUBR}|' \
${FILESDIR}/sapserver.sh >${WRKDIR}/sapserver.sh
@${CP} -f ${WRKSRC}/sap.cfg ${WRKSRC}/sap.cfg-dist
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's|${PORTDOCS}||' \
- ${WRKSRC}/Makefile.in
-.endif
post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/sapserver.sh ${PREFIX}/etc/rc.d/