aboutsummaryrefslogtreecommitdiff
path: root/net/minissdpd/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-12-20 14:38:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-12-20 14:38:52 +0000
commit0f4258f20f5220d9fe8ac205fe5ca73c0a04676c (patch)
treeaae9e69f3e5fade7612c4c6b98a01bb1bcf59ae8 /net/minissdpd/Makefile
parentbae5602d5f49afc0ee9a0b33aa8c17f1f03c0348 (diff)
downloadports-0f4258f20f5220d9fe8ac205fe5ca73c0a04676c.tar.gz
ports-0f4258f20f5220d9fe8ac205fe5ca73c0a04676c.zip
Notes
Diffstat (limited to 'net/minissdpd/Makefile')
-rw-r--r--net/minissdpd/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/minissdpd/Makefile b/net/minissdpd/Makefile
new file mode 100644
index 000000000000..669ec10f0101
--- /dev/null
+++ b/net/minissdpd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: minissdpd
+# Date created: 20 Dec 2009
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= minissdpd
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://miniupnp.free.fr/files/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= UPnP IGD discovery speed ehancer
+
+USE_RC_SUBR= minissdpd
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -D_GNU_SOURCE
+
+PLIST_FILES= sbin/minissdpd
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^(CC|CFLAGS)/d' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+
+.include <bsd.port.mk>