aboutsummaryrefslogtreecommitdiff
path: root/net/minissdpd
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-12-20 14:38:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-12-20 14:38:52 +0000
commit0f4258f20f5220d9fe8ac205fe5ca73c0a04676c (patch)
treeaae9e69f3e5fade7612c4c6b98a01bb1bcf59ae8 /net/minissdpd
parentbae5602d5f49afc0ee9a0b33aa8c17f1f03c0348 (diff)
downloadports-0f4258f20f5220d9fe8ac205fe5ca73c0a04676c.tar.gz
ports-0f4258f20f5220d9fe8ac205fe5ca73c0a04676c.zip
Notes
Diffstat (limited to 'net/minissdpd')
-rw-r--r--net/minissdpd/Makefile30
-rw-r--r--net/minissdpd/distinfo3
-rw-r--r--net/minissdpd/files/minissdpd.in27
-rw-r--r--net/minissdpd/pkg-descr11
4 files changed, 71 insertions, 0 deletions
diff --git a/net/minissdpd/Makefile b/net/minissdpd/Makefile
new file mode 100644
index 000000000000..669ec10f0101
--- /dev/null
+++ b/net/minissdpd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: minissdpd
+# Date created: 20 Dec 2009
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= minissdpd
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://miniupnp.free.fr/files/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= UPnP IGD discovery speed ehancer
+
+USE_RC_SUBR= minissdpd
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -D_GNU_SOURCE
+
+PLIST_FILES= sbin/minissdpd
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^(CC|CFLAGS)/d' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/net/minissdpd/distinfo b/net/minissdpd/distinfo
new file mode 100644
index 000000000000..521637799860
--- /dev/null
+++ b/net/minissdpd/distinfo
@@ -0,0 +1,3 @@
+MD5 (minissdpd-1.0.tar.gz) = 9c1665cd72f4672f6951af4a809287e7
+SHA256 (minissdpd-1.0.tar.gz) = e04da4aa2eae0c5c5247c8bf65da703ed11e68c53d9f0e62565986f30029b5e9
+SIZE (minissdpd-1.0.tar.gz) = 12996
diff --git a/net/minissdpd/files/minissdpd.in b/net/minissdpd/files/minissdpd.in
new file mode 100644
index 000000000000..32147a897ee1
--- /dev/null
+++ b/net/minissdpd/files/minissdpd.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: minissdpd
+# REQUIRE: NETWORKING SERVERS DAEMON ldconfig resolv
+
+. %%RC_SUBR%%
+
+# Add the following line to /etc/rc.conf to enable minissdpd
+# minissdpd_enable="YES"
+# minissdpd_flags="<set as needed>"
+
+name=minissdpd
+rcvar=`set_rcvar`
+load_rc_config $name
+
+minissdpd_enable=${minissdpd_enable:-"NO"}
+
+command="%%PREFIX%%/sbin/minissdpd"
+pidfile="/var/run/${name}.pid"
+sockfile="/var/run/${name}.sock"
+address="0.0.0.0"
+command_args="-s ${sockfile} -p ${pidfile} -i ${address}"
+
+run_rc_command "$1"
diff --git a/net/minissdpd/pkg-descr b/net/minissdpd/pkg-descr
new file mode 100644
index 000000000000..b5484451d9a0
--- /dev/null
+++ b/net/minissdpd/pkg-descr
@@ -0,0 +1,11 @@
+Every UPnP device and UPnP client (or control point in UPnP terminology) needs
+to listen to SSDP packets broadcasted to the group 239.255.255.250:1900. When
+several UPnP devices are running on the same server, or several UPnP control
+points are trying a discovery process on the same server, there is concurence to
+open a bind a socket on the UDP port 1900.
+
+MiniSSDPd can also provide a history of the SSDP NOTIFY packets sent on the
+network during a period of a few minutes and it keeps track of all UPnP devices
+that announced themselves on the network through SSDP NOTIFY packets.
+
+WWW: http://miniupnp.free.fr/minissdpd.html