aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpd
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2007-04-02 20:55:58 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2007-04-02 20:55:58 +0000
commit1908d3a661dd9bb68867a1ebb2c5dd2679e2c9d7 (patch)
tree6872e37189c90430d33d781d134269922be17c6e /net/miniupnpd
parent18dfb9aa85344f1453990b56dd9550dcf85cdb0e (diff)
downloadports-1908d3a661dd9bb68867a1ebb2c5dd2679e2c9d7.tar.gz
ports-1908d3a661dd9bb68867a1ebb2c5dd2679e2c9d7.zip
Notes
Diffstat (limited to 'net/miniupnpd')
-rw-r--r--net/miniupnpd/Makefile33
-rw-r--r--net/miniupnpd/distinfo3
-rw-r--r--net/miniupnpd/files/miniupnpd.conf.sample.in41
-rw-r--r--net/miniupnpd/files/miniupnpd.sh.in26
-rw-r--r--net/miniupnpd/pkg-descr5
-rw-r--r--net/miniupnpd/pkg-message18
-rw-r--r--net/miniupnpd/pkg-plist3
7 files changed, 129 insertions, 0 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
new file mode 100644
index 000000000000..6ac763cf6fa3
--- /dev/null
+++ b/net/miniupnpd/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: miniupnpd
+# Date created: 22 March 2007
+# Whom: Daniel O'Connor <darius@dons.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= miniupnpd
+PORTVERSION= 1.0
+PORTREVISION= 4
+CATEGORIES= net
+MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
+ http://miniupnp.free.fr/files/
+DISTNAME= ${PORTNAME}-1.0-RC4
+
+MAINTAINER= darius@dons.net.au
+COMMENT= A UPnP IGD implementation which uses pf
+
+USE_GMAKE= yes
+
+SUB_FILES= miniupnpd.conf.sample
+SUB_LIST= UUID=${UUID}
+
+UUID!= uuidgen
+
+USE_RC_SUBR= miniupnpd.sh
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${PREFIX}/sbin/miniupnpd
+ @${INSTALL_DATA} ${WRKDIR}/miniupnpd.conf.sample ${PREFIX}/etc/miniupnpd.conf.sample
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/miniupnpd/distinfo b/net/miniupnpd/distinfo
new file mode 100644
index 000000000000..32b4190b51af
--- /dev/null
+++ b/net/miniupnpd/distinfo
@@ -0,0 +1,3 @@
+MD5 (miniupnpd-1.0-RC4.tar.gz) = de6fd266bf15c4f6781895d19c8efbca
+SHA256 (miniupnpd-1.0-RC4.tar.gz) = 2091f66d85487499afa084bca56717c0e848e6f50c4ea3624797d67764c745b3
+SIZE (miniupnpd-1.0-RC4.tar.gz) = 47687
diff --git a/net/miniupnpd/files/miniupnpd.conf.sample.in b/net/miniupnpd/files/miniupnpd.conf.sample.in
new file mode 100644
index 000000000000..e54a73ef2d2c
--- /dev/null
+++ b/net/miniupnpd/files/miniupnpd.conf.sample.in
@@ -0,0 +1,41 @@
+# WAN network interface
+ext_ifname=ed0
+# if the WAN interface has several IP addresses, you
+# can specify the one to use below
+#ext_ip=
+
+# there can be multiple listening ips for receiving SSDP traffic.
+# the 1st IP is also used for UPnP Soap traffic.
+#listening_ip= 192.168.0.61
+listening_ip=10.0.2.1
+port=5555
+
+# bitrates reported by daemon in bits per second
+bitrate_up=131072
+bitrate_down=524288
+
+# default presentation url is http address on port 80
+#presentation_url=
+
+# report system uptime instead of daemon uptime
+system_uptime=yes
+
+# notify interval in seconds default is 30 seconds.
+#notify_interval=240
+
+# log packets in pf
+#packet_log=no
+
+# uuid : generated by the install a new one can be created with
+# uuidgen
+uuid=%%UUID%%
+
+# UPnP permission rules
+# (allow|deny) (external port range) ip/mask (internal port range)
+# A port range is <min port>-<max port> or <port> if there is only
+# one port in the range.
+# ip/mask format must be nn.nn.nn.nn/nn
+allow 1024-65535 10.0.2.0/24 1024-65535
+allow 1024-65535 10.0.2.0/24 1024-65535
+deny 0-65535 0.0.0.0/0 0-65535
+
diff --git a/net/miniupnpd/files/miniupnpd.sh.in b/net/miniupnpd/files/miniupnpd.sh.in
new file mode 100644
index 000000000000..8d5905528523
--- /dev/null
+++ b/net/miniupnpd/files/miniupnpd.sh.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: miniupnpd
+# REQUIRE: NETWORKING SERVERS DAEMON ldconfig resolv
+
+. %%RC_SUBR%%
+
+miniupnpd_enable=${miniupnpd_enable:-"NO"}
+miniupnpd_config=${miniupnpd_config:-"%%PREFIX%%/etc/miniupnpd.conf"}
+miniupnpd_flags=${miniupnpd_flags}
+
+name=miniupnpd
+rcvar=`set_rcvar`
+load_rc_config $name
+
+command="%%PREFIX%%/sbin/miniupnpd"
+pidfile="/var/run/${name}.pid"
+command_args="-f $miniupnpd_config"
+
+required_files=$miniupnpd_config
+
+run_rc_command "$1"
+
diff --git a/net/miniupnpd/pkg-descr b/net/miniupnpd/pkg-descr
new file mode 100644
index 000000000000..6b4094da8228
--- /dev/null
+++ b/net/miniupnpd/pkg-descr
@@ -0,0 +1,5 @@
+Mini UPnPd is a lightweight implementation of a UPnP IGD daemon. This is
+supposed to be run on your gateway machine to allow client systems to redirect
+ports and punch holes in the firewall.
+
+WWW: http://miniupnp.free.fr/
diff --git a/net/miniupnpd/pkg-message b/net/miniupnpd/pkg-message
new file mode 100644
index 000000000000..fe2f2c9cff52
--- /dev/null
+++ b/net/miniupnpd/pkg-message
@@ -0,0 +1,18 @@
+
+*** !!WARNING!! !!WARNING!! !!WARNING!! ***
+This port allows machines within your network to create holes in your
+firewall. Please ensure this is really what you want!
+*** !!WARNING!! !!WARNING!! !!WARNING!! ***
+
+For this daemon to work, you must modify your pf rules to add an anchor
+in both the NAT and rules section. Both must be called 'miniupnpd'.
+Example:
+
+# NAT section
+# UPnPd rdr anchor
+rdr-anchor "miniupnpd"
+
+# Rules section
+# uPnPd rule anchor
+anchor "miniupnpd"
+
diff --git a/net/miniupnpd/pkg-plist b/net/miniupnpd/pkg-plist
new file mode 100644
index 000000000000..5998ecd111fc
--- /dev/null
+++ b/net/miniupnpd/pkg-plist
@@ -0,0 +1,3 @@
+etc/miniupnpd.conf.sample
+sbin/miniupnpd
+