aboutsummaryrefslogtreecommitdiff
path: root/net/miredo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-13 19:39:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-13 19:39:24 +0000
commit66702080b0f5a895a863fa3c18927a628db450a5 (patch)
treec37a1532ab9fd524abe38c64cd4ed5db0a1495d5 /net/miredo
parent5077a80b8b3187edadb23ec04cd6147dc3417abd (diff)
downloadports-66702080b0f5a895a863fa3c18927a628db450a5.tar.gz
ports-66702080b0f5a895a863fa3c18927a628db450a5.zip
Notes
Diffstat (limited to 'net/miredo')
-rw-r--r--net/miredo/Makefile47
-rw-r--r--net/miredo/distinfo3
-rw-r--r--net/miredo/files/isatapd.in26
-rw-r--r--net/miredo/files/miredo.in26
-rw-r--r--net/miredo/files/miredo_server.in26
-rw-r--r--net/miredo/pkg-descr6
-rw-r--r--net/miredo/pkg-plist25
7 files changed, 159 insertions, 0 deletions
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
new file mode 100644
index 000000000000..587eb27244a0
--- /dev/null
+++ b/net/miredo/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: miredo
+# Date created: 2006-08-12
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= miredo
+PORTVERSION= 0.9.8
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.remlab.net/files/miredo/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Opensource Teredo (IPv6 tunneling) implementation
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+USE_GETOPT_LONG= yes
+USE_LDCONFIG= yes
+
+MAN1= teredo-mire.1
+MAN5= miredo-server.conf.5 miredo.conf.5 isatapd.conf.5
+MAN8= miredo-server.8 miredo.8 isatapd.8 miredo-checkconf.8
+USE_RC_SUBR= miredo_server miredo isatapd
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+USE_ICONV= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/miredo/distinfo b/net/miredo/distinfo
new file mode 100644
index 000000000000..7fe6157f6c88
--- /dev/null
+++ b/net/miredo/distinfo
@@ -0,0 +1,3 @@
+MD5 (miredo-0.9.8.tar.bz2) = a46c6ceb51f09df96c5be37c248e704a
+SHA256 (miredo-0.9.8.tar.bz2) = 103469e039cdf8f921055523953cea0df9cc30b64e32b4299f195fc25008cff6
+SIZE (miredo-0.9.8.tar.bz2) = 441803
diff --git a/net/miredo/files/isatapd.in b/net/miredo/files/isatapd.in
new file mode 100644
index 000000000000..17f0f5a8b8a6
--- /dev/null
+++ b/net/miredo/files/isatapd.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: isatapd
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable isatapd:
+#
+#isatapd_enable="YES"
+#
+isatapd_enable="${isatapd_enable-NO}"
+
+. /etc/rc.subr
+
+name=isatapd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/${name}
+required_files=%%PREFIX%%/etc/isatapd.conf
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/miredo/files/miredo.in b/net/miredo/files/miredo.in
new file mode 100644
index 000000000000..b084e6168c2d
--- /dev/null
+++ b/net/miredo/files/miredo.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: miredo
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable miredo:
+#
+#miredo_enable="YES"
+#
+miredo_enable="${miredo_enable-NO}"
+
+. /etc/rc.subr
+
+name=miredo
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/${name}
+required_files=%%PREFIX%%/etc/miredo.conf
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/miredo/files/miredo_server.in b/net/miredo/files/miredo_server.in
new file mode 100644
index 000000000000..506a8832de3a
--- /dev/null
+++ b/net/miredo/files/miredo_server.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: miredo_server
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable miredo-server:
+#
+#miredo_server_enable="YES"
+#
+miredo_server_enable="${miredo_server_enable-NO}"
+
+. /etc/rc.subr
+
+name=miredo_server
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/${name}
+required_files=%%PREFIX%%/etc/miredo-server.conf
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/miredo/pkg-descr b/net/miredo/pkg-descr
new file mode 100644
index 000000000000..4b98191320b4
--- /dev/null
+++ b/net/miredo/pkg-descr
@@ -0,0 +1,6 @@
+Miredo is an open-source Teredo IPv6 tunneling software, for Linux and the BSD
+operating systems. It includes functionnal implementations of all components of
+the Teredo specification (client, relay and server). It is meant to provide IPv6
+connectivity even from behind NAT devices.
+
+WWW: http://www.simphalempin.com/dev/miredo/
diff --git a/net/miredo/pkg-plist b/net/miredo/pkg-plist
new file mode 100644
index 000000000000..93f13ac20f10
--- /dev/null
+++ b/net/miredo/pkg-plist
@@ -0,0 +1,25 @@
+bin/teredo-mire
+sbin/miredo
+sbin/miredo-server
+sbin/miredo-checkconf
+sbin/isatapd
+lib/libteredo.so.2
+lib/libteredo.la
+lib/libteredo.so
+lib/libtun6.so.1
+lib/libtun6.la
+lib/libtun6.so
+include/libteredo/teredo.h
+include/libteredo/teredo-udp.h
+include/libteredo/tunnel.h
+include/libtun6/tun6.h
+@unexec [ -f %%TARGETDIR%%/etc/miredo.conf ] && cmp -s %%TARGETDIR%%/etc/miredo.conf %%TARGETDIR%%/etc/miredo.conf-dist && rm %%TARGETDIR%%/etc/miredo.conf || exit 0
+etc/miredo.conf-dist
+@exec [ -f %B/miredo.conf ] || cp %F %B/miredo.conf
+etc/miredo-server.conf-dist
+etc/isatapd.conf-dist
+%%NLS%%share/locale/en/LC_MESSAGES/miredo.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/miredo.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/miredo.mo
+@dirrm include/libteredo
+@dirrm include/libtun6