aboutsummaryrefslogtreecommitdiff
path: root/net/miredo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-23 11:19:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-23 11:19:14 +0000
commit0b86a909bedd0fec795032c0df3badaae65946da (patch)
treef18a1410edfe89ba5246416f2f27516e333429db /net/miredo
parent74aac1489fa4db77c1feb2d2fd8934e92fd90937 (diff)
downloadports-0b86a909bedd0fec795032c0df3badaae65946da.tar.gz
ports-0b86a909bedd0fec795032c0df3badaae65946da.zip
Notes
Diffstat (limited to 'net/miredo')
-rw-r--r--net/miredo/Makefile34
1 files changed, 19 insertions, 15 deletions
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
index 6cfe6128290d..5e255f767964 100644
--- a/net/miredo/Makefile
+++ b/net/miredo/Makefile
@@ -1,21 +1,27 @@
# Created by: Andreas Kohn <andreas@syndrom23.de>
# $FreeBSD$
-PORTNAME= miredo
-PORTVERSION= 1.2.6
-PORTREVISION= 4
-CATEGORIES= net ipv6
-MASTER_SITES= http://www.remlab.net/files/miredo/archive/
+PORTNAME= miredo
+PORTVERSION= 1.2.6
+PORTREVISION= 5
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.remlab.net/files/miredo/archive/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Opensource Teredo (IPv6 tunneling) implementation
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Opensource Teredo (IPv6 tunneling) implementation
-LIB_DEPENDS= libJudy.so:${PORTSDIR}/devel/judy
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool localbase tar:xz
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --enable-examplesdir=$(EXAMPLESDIR)
-USE_LDCONFIG= yes
+LIB_DEPENDS= libJudy.so:${PORTSDIR}/devel/judy
+
+USES= libtool localbase tar:xz
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var --enable-examplesdir=${EXAMPLESDIR}
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+USE_RC_SUBR= miredo-server miredo
OPTIONS_DEFINE= POLICYTABLE NLS
OPTIONS_SUB= yes
@@ -24,9 +30,7 @@ NLS_USES= gettext iconv
NLS_CONFIGURE_ENABLE= nls
POLICYTABLE_DESC= Install policy table to support teredo
-USE_RC_SUBR= miredo-server miredo
-
post-install-POLICYTABLE-on:
- $(INSTALL_DATA) $(FILESDIR)/ip6addrctl.conf /etc
+ ${INSTALL_DATA} ${FILESDIR}/ip6addrctl.conf /etc
.include <bsd.port.mk>