aboutsummaryrefslogtreecommitdiff
path: root/net/mono-zeroconf
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-08-27 14:19:39 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-08-27 14:19:39 +0000
commit95f73b58b5304a8d3b91805f37e2498c280e86f6 (patch)
tree63eb67ee8c1e0735e9ff724f91c9730ed8a47175 /net/mono-zeroconf
parent7ff547bd10a55d5a12991757e31a72f912955432 (diff)
downloadports-95f73b58b5304a8d3b91805f37e2498c280e86f6.tar.gz
ports-95f73b58b5304a8d3b91805f37e2498c280e86f6.zip
Notes
Diffstat (limited to 'net/mono-zeroconf')
-rw-r--r--net/mono-zeroconf/Makefile38
-rw-r--r--net/mono-zeroconf/distinfo3
-rw-r--r--net/mono-zeroconf/pkg-descr7
-rw-r--r--net/mono-zeroconf/pkg-plist24
4 files changed, 72 insertions, 0 deletions
diff --git a/net/mono-zeroconf/Makefile b/net/mono-zeroconf/Makefile
new file mode 100644
index 000000000000..e6d4bc2310d3
--- /dev/null
+++ b/net/mono-zeroconf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mono-zeroconf
+# Date created: Aug 27 2008
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mono-zeroconf
+PORTVERSION= 0.7.6
+CATEGORIES= net
+MASTER_SITES= http://download.banshee-project.org/${PORTNAME}/
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Cross platform Zero Configuration Networking library for Mono
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono \
+ ${LOCALBASE}/libdata/pkgconfig/avahi-sharp.pc:${PORTSDIR}/net/avahi-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= DOCS "Install documentation" on
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig gnomehack
+CONFIGURE_ARGS+= --program-transform-name="" \
+ --disable-mdnsresponder
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+
+.if !defined(WITHOUT_DOCS) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/monodocer:${PORTSDIR}/devel/monodoc
+CONFIGURE_ARGS+= --enable-docs
+.else
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/mono-zeroconf/distinfo b/net/mono-zeroconf/distinfo
new file mode 100644
index 000000000000..a69ade7f5c21
--- /dev/null
+++ b/net/mono-zeroconf/distinfo
@@ -0,0 +1,3 @@
+MD5 (mono-zeroconf-0.7.6.tar.gz) = 2e1e976a9131b8cc01ad21f795a2cafd
+SHA256 (mono-zeroconf-0.7.6.tar.gz) = a8ebee089f0f308085329269e45ba3f9fa0a12ecdbaa239980c32a47ec9aa15b
+SIZE (mono-zeroconf-0.7.6.tar.gz) = 132283
diff --git a/net/mono-zeroconf/pkg-descr b/net/mono-zeroconf/pkg-descr
new file mode 100644
index 000000000000..1462c73ffa64
--- /dev/null
+++ b/net/mono-zeroconf/pkg-descr
@@ -0,0 +1,7 @@
+Mono.Zeroconf is a cross platform Zero Configuration Networking library
+for Mono and .NET. It provides a unified API for performing the most
+common zeroconf operations on a variety of platforms and subsystems: all
+the operating systems supported by Mono and both the Avahi
+and Bonjour/mDNSResponder transports.
+
+WWW: http://www.mono-project.com/Mono.Zeroconf
diff --git a/net/mono-zeroconf/pkg-plist b/net/mono-zeroconf/pkg-plist
new file mode 100644
index 000000000000..f675111a68b2
--- /dev/null
+++ b/net/mono-zeroconf/pkg-plist
@@ -0,0 +1,24 @@
+bin/mzclient
+lib/mono-zeroconf/MZClient.exe
+lib/mono-zeroconf/MZClient.exe.mdb
+lib/mono-zeroconf/Mono.Zeroconf.Providers.Avahi.dll
+lib/mono-zeroconf/Mono.Zeroconf.Providers.Avahi.dll.mdb
+lib/mono/gac/Mono.Zeroconf/2.0.0.76__e60c4f4a95e1099e/Mono.Zeroconf.dll
+lib/mono/gac/Mono.Zeroconf/2.0.0.76__e60c4f4a95e1099e/Mono.Zeroconf.dll.mdb
+lib/mono/gac/policy.1.0.Mono.Zeroconf/0.0.0.0__e60c4f4a95e1099e/policy.1.0.Mono.Zeroconf.dll
+lib/mono/gac/policy.1.0.Mono.Zeroconf/0.0.0.0__e60c4f4a95e1099e/policy.1.0.config
+lib/mono/gac/policy.2.0.Mono.Zeroconf/0.0.0.0__e60c4f4a95e1099e/policy.2.0.Mono.Zeroconf.dll
+lib/mono/gac/policy.2.0.Mono.Zeroconf/0.0.0.0__e60c4f4a95e1099e/policy.2.0.config
+lib/mono/mono-zeroconf/Mono.Zeroconf.dll
+%%PORTDOCS%%lib/monodoc/sources/mono-zeroconf-docs.zip
+%%PORTDOCS%%lib/monodoc/sources/mono-zeroconf-docs.tree
+%%PORTDOCS%%lib/monodoc/sources/mono-zeroconf-docs.source
+libdata/pkgconfig/mono-zeroconf.pc
+@dirrm lib/mono/mono-zeroconf
+@dirrm lib/mono/gac/policy.2.0.Mono.Zeroconf/0.0.0.0__e60c4f4a95e1099e
+@dirrm lib/mono/gac/policy.2.0.Mono.Zeroconf
+@dirrm lib/mono/gac/policy.1.0.Mono.Zeroconf/0.0.0.0__e60c4f4a95e1099e
+@dirrm lib/mono/gac/policy.1.0.Mono.Zeroconf
+@dirrm lib/mono/gac/Mono.Zeroconf/2.0.0.76__e60c4f4a95e1099e
+@dirrm lib/mono/gac/Mono.Zeroconf
+@dirrm lib/mono-zeroconf