aboutsummaryrefslogtreecommitdiff
path: root/net/mosh
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-04-26 11:27:00 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-04-26 11:27:00 +0000
commit787eff03860fe7edc8bc675534dde04a43403e0a (patch)
treefddbaa69616e7eba6fb873cf2772e09a0c43ede3 /net/mosh
parent5ab10a42424fbfbc2de00208257bf2cc35234f51 (diff)
downloadports-787eff03860fe7edc8bc675534dde04a43403e0a.tar.gz
ports-787eff03860fe7edc8bc675534dde04a43403e0a.zip
Notes
Diffstat (limited to 'net/mosh')
-rw-r--r--net/mosh/Makefile7
-rw-r--r--net/mosh/distinfo4
-rw-r--r--net/mosh/files/patch-configure37
-rw-r--r--net/mosh/files/patch-src__crypto__byteorder.h11
-rw-r--r--net/mosh/files/patch-src__frontend__mosh-server.cc19
-rw-r--r--net/mosh/files/patch-src__terminal__terminaldispatcher.cc20
-rw-r--r--net/mosh/pkg-message4
7 files changed, 8 insertions, 94 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 82bfbf0a22da..0efd7b46e51d 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mosh
-PORTVERSION= 1.1.3
-PORTREVISION= 2
+PORTVERSION= 1.2
CATEGORIES= net
MASTER_SITES= http://cloud.github.com/downloads/keithw/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -19,11 +18,11 @@ LICENSE= GPLv3
LIB_DEPENDS= protobuf.7:${PORTSDIR}/devel/protobuf
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/Pty.pm:${PORTSDIR}/devel/p5-IO-Tty
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/typeof/typeof.hpp:${PORTSDIR}/devel/boost-libs
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-boost=${LOCALBASE} --with-utempter
+CONFIGURE_ARGS= --with-utempter
+INSTALL_TARGET= install-strip
LATEST_LINK= mosh-term
diff --git a/net/mosh/distinfo b/net/mosh/distinfo
index 35382a42cbe4..9a225bbc0bbf 100644
--- a/net/mosh/distinfo
+++ b/net/mosh/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mosh-1.1.3.tar.gz) = 53234667e53625791ca43ced1ec43834cbd86a019c67ce5e4bd65556113c6eee
-SIZE (mosh-1.1.3.tar.gz) = 264478
+SHA256 (mosh-1.2.tar.gz) = 8b2d346a2f0d560ceb2ca91ff396fa859f81bb321ebd8c26fc564db8b335433a
+SIZE (mosh-1.2.tar.gz) = 296000
diff --git a/net/mosh/files/patch-configure b/net/mosh/files/patch-configure
deleted file mode 100644
index dfc311c4954b..000000000000
--- a/net/mosh/files/patch-configure
+++ /dev/null
@@ -1,37 +0,0 @@
---- ./configure.orig 2012-04-03 13:04:06.000000000 -0400
-+++ ./configure 2012-04-10 15:28:42.000000000 -0400
-@@ -5515,7 +5515,20 @@
- done
-
-
--for ac_header in pty.h util.h
-+for ac_header in pty.h util.h libutil.h
-+do :
-+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
-+ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
-+if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
-+ cat >>confdefs.h <<_ACEOF
-+#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
-+_ACEOF
-+
-+fi
-+
-+done
-+
-+for ac_header in endian.h sys/endian.h
- do :
- as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
- ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
-@@ -6275,7 +6288,11 @@
- fi
-
-
--ac_fn_c_check_decl "$LINENO" "htobe64" "ac_cv_have_decl_htobe64" "#include <endian.h>
-+ac_fn_c_check_decl "$LINENO" "htobe64" "ac_cv_have_decl_htobe64" "#if defined(HAVE_ENDIAN_H)
-+#include <endian.h>
-+#elif defined(HAVE_SYS_ENDIAN_H)
-+#include <sys/endian.h>
-+#endif
- "
- if test "x$ac_cv_have_decl_htobe64" = xyes; then :
-
diff --git a/net/mosh/files/patch-src__crypto__byteorder.h b/net/mosh/files/patch-src__crypto__byteorder.h
deleted file mode 100644
index 9feebec5f4ab..000000000000
--- a/net/mosh/files/patch-src__crypto__byteorder.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/crypto/byteorder.h.orig 2012-03-10 13:57:21.000000000 -0500
-+++ ./src/crypto/byteorder.h 2012-04-10 15:28:42.000000000 -0400
-@@ -22,7 +22,7 @@
- #include "config.h"
-
- #ifdef HAVE_HTOBE64
--# include <endian.h>
-+# include <sys/endian.h>
- #elif HAVE_OSX_SWAP
- # include <libkern/OSByteOrder.h>
- # define htobe64 OSSwapHostToBigInt64
diff --git a/net/mosh/files/patch-src__frontend__mosh-server.cc b/net/mosh/files/patch-src__frontend__mosh-server.cc
deleted file mode 100644
index d63be6493ad0..000000000000
--- a/net/mosh/files/patch-src__frontend__mosh-server.cc
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./src/frontend/mosh-server.cc.orig 2012-04-02 18:08:49.000000000 -0400
-+++ ./src/frontend/mosh-server.cc 2012-04-11 06:59:21.000000000 -0400
-@@ -39,6 +39,7 @@
- #include <arpa/inet.h>
- #include <getopt.h>
- #include <time.h>
-+#include <libutil.h>
-
- extern "C" {
- #include "selfpipe.h"
-@@ -127,7 +128,7 @@
- && (strcmp( argv[ 1 ], "new" ) == 0) ) {
- /* new option syntax */
- int opt;
-- while ( (opt = getopt( argc, argv, "i:p:c:s" )) != -1 ) {
-+ while ( (opt = getopt( argc - 1, argv + 1, "i:p:c:s" )) != -1 ) {
- switch ( opt ) {
- case 'i':
- desired_ip = optarg;
diff --git a/net/mosh/files/patch-src__terminal__terminaldispatcher.cc b/net/mosh/files/patch-src__terminal__terminaldispatcher.cc
deleted file mode 100644
index e54d680f5ef7..000000000000
--- a/net/mosh/files/patch-src__terminal__terminaldispatcher.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./src/terminal/terminaldispatcher.cc.orig 2012-04-11 06:57:23.000000000 -0400
-+++ ./src/terminal/terminaldispatcher.cc 2012-04-11 06:58:05.000000000 -0400
-@@ -85,7 +85,7 @@
- if ( endptr == segment_begin ) {
- val = -1;
- }
-- if ( errno == 0 ) {
-+ if ( errno == 0 || segment_begin == endptr ) {
- parsed_params.push_back( val );
- }
-
-@@ -99,7 +99,7 @@
- if ( endptr == segment_begin ) {
- val = -1;
- }
-- if ( errno == 0 ) {
-+ if ( errno == 0 || segment_begin == endptr ) {
- parsed_params.push_back( val );
- }
-
diff --git a/net/mosh/pkg-message b/net/mosh/pkg-message
index 93defff663a3..40f969571b7e 100644
--- a/net/mosh/pkg-message
+++ b/net/mosh/pkg-message
@@ -1,3 +1,4 @@
+=====================================================================
Please note that mosh requires UTF-8 character set. To set this on a
per-user basis, you should add the following to ~/.login_conf:
me:\
@@ -5,4 +6,5 @@ me:\
:lang=en_US.UTF-8:\
:setenv=LC_COLLATE=C:
-This must be done on both the client and the server.
+This only needs to be completed on the client.
+=====================================================================