aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-02-01 09:53:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-02-01 09:53:21 +0000
commit436f1fdfe558352077662a0a90709da7a506b5ba (patch)
treee7a49cf921e99e8c0f4c2faafd8dcdfbce82d4df /net/mosquitto
parentef9c66b705755278bb32e96c4d3370026b95ac3f (diff)
downloadports-436f1fdfe558352077662a0a90709da7a506b5ba.tar.gz
ports-436f1fdfe558352077662a0a90709da7a506b5ba.zip
Notes
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 41ddaedd2eff..4b390c5ef0a6 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -18,28 +18,26 @@ BUILD_DEPENDS= xsltproc:textproc/libxslt
USES= cmake ssl
USE_RC_SUBR= mosquitto
USE_LDCONFIG= yes
+CMAKE_ARGS= -DCMAKE_LIBDATADIR:PATH="${PREFIX}/libdata"
USERS= nobody
-NOCONFIGURE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= WS
-CMAKE_ARGS+= -DCMAKE_LIBDATADIR="${PREFIX}/libdata"
-
WS_DESC= MQTT over Websockets support
WS_LIB_DEPENDS= libwebsockets.so:net/libwebsockets
WS_CMAKE_ON= -DWITH_WEBSOCKETS=ON
post-patch:
-# do not run ldconfig in stage dir
+ @${REINPLACE_CMD} -e '45s,^,#include <sys/socket.h>,' \
+ ${WRKSRC}/src/websockets.c
@${REINPLACE_CMD} -e '/ldconfig/d' ${WRKSRC}/src/CMakeLists.txt \
${WRKSRC}/lib/CMakeLists.txt ${WRKSRC}/lib/cpp/CMakeLists.txt
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/CMakeLists.txt
post-install:
-# Adjust configuration files
${MV} ${STAGEDIR}${ETCDIR}/mosquitto.conf ${STAGEDIR}${ETCDIR}/mosquitto.conf.sample
${MV} ${STAGEDIR}${ETCDIR}/pwfile.example ${STAGEDIR}${ETCDIR}/pwfile.sample
${MV} ${STAGEDIR}${ETCDIR}/pskfile.example ${STAGEDIR}${ETCDIR}/pskfile.sample