aboutsummaryrefslogtreecommitdiff
path: root/net/mpd4
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-10-31 20:37:56 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-10-31 20:37:56 +0000
commit9ba6c57fc33c2720206b2d86fb5c37ff7f74b734 (patch)
tree2b76178781879f334df178e1a96f9d288715bc7f /net/mpd4
parent77e683aece3629682669773e3f5bb7d57ead2a52 (diff)
downloadports-9ba6c57fc33c2720206b2d86fb5c37ff7f74b734.tar.gz
ports-9ba6c57fc33c2720206b2d86fb5c37ff7f74b734.zip
Notes
Diffstat (limited to 'net/mpd4')
-rw-r--r--net/mpd4/Makefile12
-rw-r--r--net/mpd4/distinfo6
-rw-r--r--net/mpd4/files/mpd4.sh37
-rw-r--r--net/mpd4/files/mpd4.sh.in45
-rw-r--r--net/mpd4/pkg-descr15
-rw-r--r--net/mpd4/pkg-plist72
6 files changed, 68 insertions, 119 deletions
diff --git a/net/mpd4/Makefile b/net/mpd4/Makefile
index 1d03e2c17766..4bee08ad472e 100644
--- a/net/mpd4/Makefile
+++ b/net/mpd4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mpd4
-PORTVERSION= 4.0b4
+PORTVERSION= 4.0b5
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= glebius
@@ -20,6 +20,13 @@ LIB_DEPENDS= pdel.0:${PORTSDIR}/devel/libpdel
MTREE_FILE= ${FILESDIR}/mpd4.mtree
MAN8= mpd4.8
MANCOMPRESSED= maybe
+USE_RC_SUBR= mpd4.sh
+HTMLNUM!= jot 60 1
+CONFSUF= conf links secret script
+PORTDOCS= ${HTMLNUM:S/^/mpd/:S/$/.html/} mpd.html mpd.ps README \
+ mpd_toc.html
+PLIST_DIRS= etc/mpd4
+PLIST_FILES= ${CONFSUF:S/^/etc\/mpd4\/mpd./:S/$/.sample/} sbin/mpd4
USE_OPENSSL= yes
@@ -29,7 +36,4 @@ USE_OPENSSL= yes
IGNORE= does not compile on FreeBSD 4.x; use net/mpd instead
.endif
-post-install:
- @${INSTALL_SCRIPT} -m 751 ${FILESDIR}/mpd4.sh ${PREFIX}/etc/rc.d/mpd4.sh.sample
-
.include <bsd.port.post.mk>
diff --git a/net/mpd4/distinfo b/net/mpd4/distinfo
index b75129016fef..b7e97bcc2be7 100644
--- a/net/mpd4/distinfo
+++ b/net/mpd4/distinfo
@@ -1,3 +1,3 @@
-SIZE (mpd4/mpd4-4.0b4.tar.gz) = 338472
-MD5 (mpd4/mpd4-4.0b4.tar.gz) = 033c0a1620eab8ba8706a9f08e902dec
-SHA256 (mpd4/mpd4-4.0b4.tar.gz) = 19303efa25f0f5a069ac734433ae355c97fec776a5209deeff0a5cdb3c45d87f
+SIZE (mpd4/mpd4-4.0b5.tar.gz) = 349380
+MD5 (mpd4/mpd4-4.0b5.tar.gz) = 0490e23853a34d8d032aae07487690e8
+SHA256 (mpd4/mpd4-4.0b5.tar.gz) = 9ef32902c99a05b926df21e4edd1b3db213959ae88e640a7b283b0f38e77a34c
diff --git a/net/mpd4/files/mpd4.sh b/net/mpd4/files/mpd4.sh
deleted file mode 100644
index b267a10d13c5..000000000000
--- a/net/mpd4/files/mpd4.sh
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-DAEMON=/usr/local/sbin/mpd4
-PIDFILE=/var/run/mpd4.pid
-
-case "$1" in
-start)
- if [ -f "${DAEMON}" -a -x "${DAEMON}" ]; then
- if [ -f "${PIDFILE}" ]; then
- echo ' mpd4 PID file found - not starting'
- else
- "${DAEMON}" -b -p "${PIDFILE}"
- echo -n ' mpd4'
- fi
- else
- echo ' "${DAEMON}" executable not found - mpd4 not starting'
- fi
- ;;
-stop)
- if [ -f "${PIDFILE}" ]; then
- read -r pid junk < "${PIDFILE}"
- kill ${pid}
- else
- echo ' mpd4 PID file not found - not killing'
- fi
- ;;
-restart)
- $0 stop
- sleep 2
- $0 start
- ;;
-*)
- echo "usage: ${0##*/} {start|stop|restart}" >&2
- ;;
-esac
-
diff --git a/net/mpd4/files/mpd4.sh.in b/net/mpd4/files/mpd4.sh.in
new file mode 100644
index 000000000000..c6772ccfb593
--- /dev/null
+++ b/net/mpd4/files/mpd4.sh.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: mpd
+# REQUIRE: NETWORKING
+# BEFORE: SERVERS
+
+#
+# Add the following lines to /etc/rc.conf to enable mpd4:
+# mpd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable mpd4.
+# mpd_flags (string): Set to "-b" by default.
+# Extra flags passed to start command.
+#
+# See mpd(8) for flags.
+#
+
+. %%RC_SUBR%%
+
+name="mpd4"
+rcvar=`set_rcvar mpd`
+
+load_rc_config ${name}
+
+: ${mpd_enable="NO"}
+: ${mpd_flags="-b"}
+
+pidfile="/var/run/${name}.pid"
+command="%%PREFIX%%/sbin/${name}"
+required_files="%%PREFIX%%/etc/${name}/mpd.conf %%PREFIX%%/etc/${name}/mpd.links"
+
+case "${mpd_flags}" in
+*-p\ *)
+ echo "ERROR: \$mpd_flags includes -p option." \
+ "PID file is already set to $pidfile."
+ exit 1
+ ;;
+*)
+ command_args="${mpd_flags} -p ${pidfile}"
+ ;;
+esac
+
+run_rc_command "$1"
diff --git a/net/mpd4/pkg-descr b/net/mpd4/pkg-descr
index 655837db7ad1..0a57ce2467ea 100644
--- a/net/mpd4/pkg-descr
+++ b/net/mpd4/pkg-descr
@@ -5,15 +5,24 @@ all data packets strictly in the kernel. It supports several of
the numerous PPP sub-protocols and extensions, such as:
Multi-link PPP capability
- PAP, CHAP, and MS-CHAP authentication
- EAP authentication
+ PAP, CHAP, MS-CHAP and EAP authentication
PPP compression and encryption
+ IPCP and IPV6CP parameter negotiation
+
+Mpd have support for many link types:
+
+ Serial port modem
Point-to-Point Tunnelling Protocol (PPTP)
PPP over Ethernet (PPPoE)
- RADIUS (authentication and accounting)
+ PPP over TCP
+ PPP over UDP
+ PPP over specified netgraph(4) node
Mpd also includes many additional features:
+ IPv4 and IPv6 support
+ RADIUS authentication and accounting
+ NetFlow traffic accounting
Dial-on-demand with idle timeout
Multiple active connections running simultaneously
Dynamic demand based link management (also known as ``rubber bandwidth'')
diff --git a/net/mpd4/pkg-plist b/net/mpd4/pkg-plist
deleted file mode 100644
index 168d5695535f..000000000000
--- a/net/mpd4/pkg-plist
+++ /dev/null
@@ -1,72 +0,0 @@
-etc/mpd4/mpd.conf.sample
-etc/mpd4/mpd.links.sample
-etc/mpd4/mpd.secret.sample
-etc/mpd4/mpd.script.sample
-etc/rc.d/mpd4.sh.sample
-sbin/mpd4
-share/doc/mpd4/README
-share/doc/mpd4/mpd.ps
-share/doc/mpd4/mpd.html
-share/doc/mpd4/mpd1.html
-share/doc/mpd4/mpd10.html
-share/doc/mpd4/mpd11.html
-share/doc/mpd4/mpd12.html
-share/doc/mpd4/mpd13.html
-share/doc/mpd4/mpd14.html
-share/doc/mpd4/mpd15.html
-share/doc/mpd4/mpd16.html
-share/doc/mpd4/mpd17.html
-share/doc/mpd4/mpd18.html
-share/doc/mpd4/mpd19.html
-share/doc/mpd4/mpd2.html
-share/doc/mpd4/mpd20.html
-share/doc/mpd4/mpd21.html
-share/doc/mpd4/mpd22.html
-share/doc/mpd4/mpd23.html
-share/doc/mpd4/mpd24.html
-share/doc/mpd4/mpd25.html
-share/doc/mpd4/mpd26.html
-share/doc/mpd4/mpd27.html
-share/doc/mpd4/mpd28.html
-share/doc/mpd4/mpd29.html
-share/doc/mpd4/mpd3.html
-share/doc/mpd4/mpd30.html
-share/doc/mpd4/mpd31.html
-share/doc/mpd4/mpd32.html
-share/doc/mpd4/mpd33.html
-share/doc/mpd4/mpd34.html
-share/doc/mpd4/mpd35.html
-share/doc/mpd4/mpd36.html
-share/doc/mpd4/mpd37.html
-share/doc/mpd4/mpd38.html
-share/doc/mpd4/mpd39.html
-share/doc/mpd4/mpd4.html
-share/doc/mpd4/mpd40.html
-share/doc/mpd4/mpd41.html
-share/doc/mpd4/mpd42.html
-share/doc/mpd4/mpd43.html
-share/doc/mpd4/mpd44.html
-share/doc/mpd4/mpd45.html
-share/doc/mpd4/mpd46.html
-share/doc/mpd4/mpd47.html
-share/doc/mpd4/mpd48.html
-share/doc/mpd4/mpd49.html
-share/doc/mpd4/mpd5.html
-share/doc/mpd4/mpd50.html
-share/doc/mpd4/mpd51.html
-share/doc/mpd4/mpd52.html
-share/doc/mpd4/mpd53.html
-share/doc/mpd4/mpd54.html
-share/doc/mpd4/mpd55.html
-share/doc/mpd4/mpd56.html
-share/doc/mpd4/mpd57.html
-share/doc/mpd4/mpd58.html
-share/doc/mpd4/mpd59.html
-share/doc/mpd4/mpd6.html
-share/doc/mpd4/mpd60.html
-share/doc/mpd4/mpd7.html
-share/doc/mpd4/mpd8.html
-share/doc/mpd4/mpd9.html
-share/doc/mpd4/mpd_toc.html
-@dirrm etc/mpd4
-@dirrm share/doc/mpd4