aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-07-22 21:22:44 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-07-22 21:22:44 +0000
commitea05d11e52923e13ad57f352fb8519a83f960bc5 (patch)
treec8a9bfd445cff00b564ed866902f37099c877d74 /net/mpich2/Makefile
parent3930aaeae2e5310e4df00662e20323109ba74a69 (diff)
Notes
Diffstat (limited to 'net/mpich2/Makefile')
-rw-r--r--net/mpich2/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index e6131fd6ad65..7396a172c8cc 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mpich2
-PORTVERSION= 1.1
+PORTVERSION= 1.1.1
PORTEPOCH= 3
CATEGORIES= net parallel
MASTER_SITES= http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${PORTVERSION}/
@@ -33,12 +33,17 @@ USE_PERL5_BUILD=yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-romio --enable-sharedlibs=gcc
+CONFIGURE_ARGS= --enable-romio --enable-sharedlibs=gcc \
+ --docdir=${DOCSDIR}
CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}" CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lexecinfo ${PTHREAD_LIBS}"
+ LDFLAGS="-L${LOCALBASE}/lib -lexecinfo ${PTHREAD_LIBS}" \
+ PACKAGE=${PORTNAME}
FFLAGS?= -O2
NOCCACHE= yes
-MAKE_ENV= CCACHE_DISABLE=yes
+MAKE_ENV= CCACHE_DISABLE=yes PACKAGE=${PORTNAME}
+.if defined(WITH_DEBUG)
+MAKE_ENV+= VERBOSE=1
+.endif
USE_FORTRAN= yes
F90FLAGS+= ${FFLAGS}
@@ -83,7 +88,9 @@ LIBSSO= fmpich mpich mpichcxx
THREAD2FIX= configure test/mpi/threads/comm/Makefile.in \
test/mpi/threads/pt2pt/Makefile.in \
- src/mpe2/src/logging/configure
+ src/mpe2/src/logging/configure \
+ src/mpi/romio/configure src/openpa/configure \
+ src/pm/hydra/configure
LOCALBASE2FIX= src/mpe2/src/slog2sdk/trace_rlog/configure \
src/mpe2/src/slog2sdk/trace_sample/configure \
src/mpe2/src/graphics/configure