aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-24 11:55:13 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-24 11:55:13 +0000
commit629b964108bbe260c97df9017b0db9c8facff4f8 (patch)
tree182f59eb4c76c6288376d2611c24bd56d9f81262 /net/mpich2
parent23ce4f6db61b68bcf323450557bf40015fde8c73 (diff)
Notes
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile8
-rw-r--r--net/mpich2/pkg-plist18
2 files changed, 10 insertions, 16 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 6d0e74c6d042..beac62f06046 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpich2
DISTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 5
CATEGORIES= net java parallel
MASTER_SITES= http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${DISTVERSION}/
@@ -26,6 +26,7 @@ USES= libtool:keepla fortran perl5 pkgconfig python
USE_GCC= yes
USE_LDCONFIG= yes
USE_PERL5= build
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
@@ -41,9 +42,11 @@ CONFIGURE_ARGS= --enable-romio --enable-shared \
--docdir="${DOCSDIR}" \
--with-python="${PYTHON_CMD}"
CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
+ MPI_CFLAGS="${LOCALBASE}/include" \
PACKAGE=${PORTNAME} \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
.if ${FFLAGS} == "-O"
FFLAGS= -O2
@@ -173,6 +176,9 @@ post-install:
.for pg in ${BIN2STRIP}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${pg}
.endfor
+.if ${PORT_OPTIONS:MJAVA}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/trace_rlog/libTraceInput.so
+.endif
.if defined(MAINTAINER_MODE)
regression-test: install
diff --git a/net/mpich2/pkg-plist b/net/mpich2/pkg-plist
index 9b96b893a717..275f6e15b435 100644
--- a/net/mpich2/pkg-plist
+++ b/net/mpich2/pkg-plist
@@ -880,9 +880,9 @@ sbin/mpeuninstall
%%DATADIR%%/examples/graphics/cpi.c
%%DATADIR%%/examples/graphics/cxgraphics.c
%%DATADIR%%/examples/graphics/fxgraphics.f
-%%DATADIR%%/examples/logfiles/barrier.rlog
-%%DATADIR%%/examples/logfiles/fpilog.clog
-%%DATADIR%%/examples/logfiles/fpilog.slog2
+%%JAVA%%%%DATADIR%%/examples/logfiles/barrier.rlog
+%%JAVA%%%%DATADIR%%/examples/logfiles/fpilog.clog
+%%JAVA%%%%DATADIR%%/examples/logfiles/fpilog.slog2
%%DATADIR%%/examples/logging/Makefile
%%DATADIR%%/examples/logging/comm1_isr.c
%%DATADIR%%/examples/logging/comm1_isr_loop.c
@@ -903,15 +903,3 @@ sbin/mpeuninstall
%%DATADIR%%/examples/logging/pthread_sendrecv.c
%%DATADIR%%/examples/logging/pthread_sendrecv_user.c
%%DATADIR%%/examples/logging/srtest.c
-@dirrm %%DATADIR%%/examples/logfiles
-@dirrm %%DATADIR%%/examples/logging
-@dirrm %%DATADIR%%/examples/graphics
-@dirrm %%DATADIR%%/examples/collchk
-@dirrm %%DATADIR%%/examples
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www4
-%%JAVA%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/jumpshot-4/html
-%%JAVA%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/jumpshot-4
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%JAVA%%@dirrm lib/trace_rlog
-@dirrm include/primitives