aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-12-20 16:39:14 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-12-20 16:39:14 +0000
commit2833b42e4d5c27a6fd8efc47f92fdb6feafaae3d (patch)
tree72b8dab553c8fe6a79497e7fa59676e91451724f /net/mpich2
parent0398e71ab9761c2be509d77151b40c3699ba3335 (diff)
downloadports-2833b42e4d5c27a6fd8efc47f92fdb6feafaae3d.tar.gz
ports-2833b42e4d5c27a6fd8efc47f92fdb6feafaae3d.zip
Notes
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 1a1c804a4272..99876179404b 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -18,11 +18,11 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
-USES= libtool:keepla fortran perl5 pkgconfig python
+USES= execinfo libtool:keepla localbase fortran perl5 \
+ pkgconfig python
USE_GCC= yes
USE_LDCONFIG= yes
USE_PERL5= build
@@ -46,8 +46,6 @@ CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
PACKAGE="${PORTNAME}" \
PTHREAD_LIBS="-lpthread"
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
.if ${FFLAGS} == "-O"
FFLAGS= -O2
.endif