aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-02-22 22:34:16 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-02-22 22:34:16 +0000
commite38319bd4086efbd5e3c5921104049bf1041b824 (patch)
treead61e3f270c3e9a95f277d5dba93d2b0821380c4 /net/mpich2
parentada4244510458265880b81c8cc2ec9b16b7a01bb (diff)
downloadports-e38319bd4086efbd5e3c5921104049bf1041b824.tar.gz
ports-e38319bd4086efbd5e3c5921104049bf1041b824.zip
Notes
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile25
-rw-r--r--net/mpich2/pkg-plist58
2 files changed, 50 insertions, 33 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 2e76cd13256d..880e5925a8c7 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -17,10 +17,27 @@ COMMENT= Message Passing Interface (MPI) Library
PATCH_SITES= ftp://ftp.mcs.anl.gov/pub/mpi/patch/${PORTVERSION:R}/
PATCHFILES= 8713 8697
-RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-BUILD_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-CONFIGURE_ARGS= -cflags="${CFLAGS}" -prefix=${PREFIX}/mpich \
- -mpe_opts="--with-wishloc=wish8.4"
+CONFIGURE_ARGS= -cflags="${CFLAGS}" -prefix=${PREFIX}/mpich
+
+.if defined(WITHOUT_X11)
+WITHOUT_TK= yes
+CONFIGURE_ARGS+=--disable-mpe_graphics
+PLIST_SUB+= X11="@comment "
+.else
+USE_XLIB= yes
+CONFIGURE_ARGS+=--enable-mpe_graphics
+PLIST_SUB+= X11=""
+.endif
+
+.if defined(WITHOUT_TK)
+CONFIGURE_ARGS+=-mpe_opts="--without-tcldir --without-tkdir --without-wishloc"
+PLIST_SUB+= TK="@comment "
+.else
+RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+BUILD_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+CONFIGURE_ARGS+=-mpe_opts="--with-wishloc=wish8.4"
+PLIST_SUB+= TK=""
+.endif
.if defined(WITHOUT_JAVA)
CONFIGURE_ARGS+= --without-java
diff --git a/net/mpich2/pkg-plist b/net/mpich2/pkg-plist
index 49eb7c4babce..38e9ad8aae3d 100644
--- a/net/mpich2/pkg-plist
+++ b/net/mpich2/pkg-plist
@@ -116,11 +116,11 @@ mpich/include/mpif.h
mpich/include/mpio.h
mpich/include/mpiof.h
mpich/include/protofix.h
-mpich/lib/libampe.a
+%%X11%%mpich/lib/libampe.a
mpich/lib/libfmpich.a
mpich/lib/liblmpe.a
mpich/lib/libmpe.a
-mpich/lib/libmpe_nompi.a
+%%X11%%mpich/lib/libmpe_nompi.a
mpich/lib/libmpich.a
mpich/lib/libmpichfsup.a
mpich/lib/libpmpich++.a
@@ -216,28 +216,28 @@ mpich/share/examples/srtest.c
%%JAVA%%@dirrm mpich/share/jumpshot-3
mpich/share/machines.freebsd
mpich/share/machines.sample
-mpich/share/upshot/bin/upshot
-mpich/share/upshot/bitmaps/2x2
-mpich/share/upshot/bitmaps/black
-mpich/share/upshot/bitmaps/boxes
-mpich/share/upshot/bitmaps/dimple3
-mpich/share/upshot/bitmaps/dllines3
-mpich/share/upshot/bitmaps/dllines4
-mpich/share/upshot/bitmaps/drlines3
-mpich/share/upshot/bitmaps/drlines4
-mpich/share/upshot/bitmaps/gray
-mpich/share/upshot/bitmaps/gray2
-mpich/share/upshot/bitmaps/gray3
-mpich/share/upshot/bitmaps/hlines2
-mpich/share/upshot/bitmaps/hlines3
-mpich/share/upshot/bitmaps/hlines4
-mpich/share/upshot/bitmaps/light_gray
-mpich/share/upshot/bitmaps/vlines2
-mpich/share/upshot/bitmaps/vlines3
-mpich/share/upshot/bitmaps/vlines4
-mpich/share/upshot/bitmaps/white
-mpich/share/upshot/logfiles/fft.trf
-mpich/share/upshot/logfiles/sam_hyp.16.log
+%%TK%%mpich/share/upshot/bin/upshot
+%%TK%%mpich/share/upshot/bitmaps/2x2
+%%TK%%mpich/share/upshot/bitmaps/black
+%%TK%%mpich/share/upshot/bitmaps/boxes
+%%TK%%mpich/share/upshot/bitmaps/dimple3
+%%TK%%mpich/share/upshot/bitmaps/dllines3
+%%TK%%mpich/share/upshot/bitmaps/dllines4
+%%TK%%mpich/share/upshot/bitmaps/drlines3
+%%TK%%mpich/share/upshot/bitmaps/drlines4
+%%TK%%mpich/share/upshot/bitmaps/gray
+%%TK%%mpich/share/upshot/bitmaps/gray2
+%%TK%%mpich/share/upshot/bitmaps/gray3
+%%TK%%mpich/share/upshot/bitmaps/hlines2
+%%TK%%mpich/share/upshot/bitmaps/hlines3
+%%TK%%mpich/share/upshot/bitmaps/hlines4
+%%TK%%mpich/share/upshot/bitmaps/light_gray
+%%TK%%mpich/share/upshot/bitmaps/vlines2
+%%TK%%mpich/share/upshot/bitmaps/vlines3
+%%TK%%mpich/share/upshot/bitmaps/vlines4
+%%TK%%mpich/share/upshot/bitmaps/white
+%%TK%%mpich/share/upshot/logfiles/fft.trf
+%%TK%%mpich/share/upshot/logfiles/sam_hyp.16.log
mpich/www/index.html
mpich/www/www1/Jumpshots.html
mpich/www/www1/MPI.html
@@ -538,11 +538,11 @@ mpich/www/www4/index.html
@dirrm mpich/www/www3
@dirrm mpich/www/www1
@dirrm mpich/www
-@dirrm mpich/share/upshot/sbin
-@dirrm mpich/share/upshot/logfiles
-@dirrm mpich/share/upshot/bitmaps
-@dirrm mpich/share/upshot/bin
-@dirrm mpich/share/upshot
+%%TK%%@dirrm mpich/share/upshot/sbin
+%%TK%%@dirrm mpich/share/upshot/logfiles
+%%TK%%@dirrm mpich/share/upshot/bitmaps
+%%TK%%@dirrm mpich/share/upshot/bin
+%%TK%%@dirrm mpich/share/upshot
@dirrm mpich/share/examples
@dirrm mpich/share
@dirrm mpich/sbin