aboutsummaryrefslogtreecommitdiff
path: root/net/mping
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-21 20:02:54 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-21 20:02:54 +0000
commitf8ebe371f65f879f9e369bde1910e34fa903376d (patch)
tree34b2947e42d43d271a377275e6be574e76b5e6c7 /net/mping
parent2196ce4482a339d93003bf9888d296d47e5f31b3 (diff)
downloadports-f8ebe371f65f879f9e369bde1910e34fa903376d.tar.gz
ports-f8ebe371f65f879f9e369bde1910e34fa903376d.zip
Notes
Diffstat (limited to 'net/mping')
-rw-r--r--net/mping/Makefile33
-rw-r--r--net/mping/distinfo3
-rw-r--r--net/mping/pkg-descr12
3 files changed, 48 insertions, 0 deletions
diff --git a/net/mping/Makefile b/net/mping/Makefile
new file mode 100644
index 000000000000..21b997be4a60
--- /dev/null
+++ b/net/mping/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mping
+# Date Created: 19 Dec 2005
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mping
+PORTVERSION= 2.01
+CATEGORIES= net ipv6
+MASTER_SITES= http://mping.uninett.no/
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Mping network statistics collector
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= sbin/mping
+PORTDOCS= ChangeLog README TODO
+
+MAN8= mping.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/mping ${PREFIX}/sbin/mping
+ ${INSTALL_MAN} ${WRKSRC}/man/mping.8 ${PREFIX}/man/man8/mping.8
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/mping/distinfo b/net/mping/distinfo
new file mode 100644
index 000000000000..dd993b693dc5
--- /dev/null
+++ b/net/mping/distinfo
@@ -0,0 +1,3 @@
+MD5 (mping-2.01.tar.gz) = 3339d3b15aef46699a2712de52d8ba32
+SHA256 (mping-2.01.tar.gz) = 7728ef3e31299b453e3d7cbb70b2ba0cdd3f5a9a71cae691b9756a7a3a76dde1
+SIZE (mping-2.01.tar.gz) = 159203
diff --git a/net/mping/pkg-descr b/net/mping/pkg-descr
new file mode 100644
index 000000000000..cf723b695d57
--- /dev/null
+++ b/net/mping/pkg-descr
@@ -0,0 +1,12 @@
+Mping is a system for collecting packet delay and loss
+statistics in a TCP/IP network using ICMP echo.
+
+Mping is based on original ping(8) with following new features:
+
+- Ability to ping multiple hosts simultaneously
+- Prints 10/50/90-percentile as well as min/avg/max.
+
+WWW: http://mping.uninett.no/
+
+-- Babak Farrokhi
+babak@farrokhi.net